Mauvaise affectation d'IP sur réseau local

Le
Sergio
Voilà :
J'ai un portable avec lequel je me connecte au boulot (et ailleurs). Au
boulot, il faut affecter une IP fixe dans le sous-réseau (du style
192.168.x.yyy), attribuée par l'admin système (cad moi).

Pour celà j'ai configuré la carte réseau avec deux possibilités :
- Dans l'onglet "général", je mets en config automatique (pour quand je
me connecte de chez moi ou d'un endroit civilisé avec DHCP).
- Dans l'onglet "configuration alternative", je mets l'IP fixe et les
DNS et passerelles de la boîte.

Depuis quelques jours, j'avais des micro-coupures. CAD, que j'avais de
temps en temps une info-bulle "Réseau machin est maintenant connecté,
vitesse 100Mb/s". Pas trop gênant, sauf que ça m'occasionnait des
coupure quand j'étais en session SSH avec un des serveurs (sous Linux,
mais pas d'importance).

J'ai fait une inspection en règle des câbles et switches de mon poste
jusqu'au routeur : rien.

Jusqu'à ce que, ce matin, je fasse un scan en règle du réseau pour
vérifier les IP de la boîte Et ô surprise ! j'avais une IP
différente de mon IP affectée !

Les "ipconfig /renew" (ou l'équivalent "réparer" dans la boîte de
dialogue) se sodait en time-out.

J'ai réinstallé le pilote de la carte éthernet (ça réinitialise tout),
rien à y faire. Je m'en suis sorti en supprimant la double
configuration IP. Et, là l'"ipconfig /renew" remarche.

Ça vient d'où ? Un DHCP parasite sur le réseau ?

Au fait mon portable est sous XP familiale, SP2 à jour.

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Supportez le libre : http://www.framasoft.net/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Antoine ROUCHET
Le #14347361
"Sergio" news:
Voilà :
J'ai un portable avec lequel je me connecte au boulot (et ailleurs). Au
boulot, il faut affecter une IP fixe dans le sous-réseau (du style
192.168.x.yyy), attribuée par l'admin système (cad moi...).

Pour celà j'ai configuré la carte réseau avec deux possibilités :
- Dans l'onglet "général", je mets en config automatique (pour quand je me
connecte de chez moi ou d'un endroit civilisé avec DHCP).
- Dans l'onglet "configuration alternative", je mets l'IP fixe et les DNS
et passerelles de la boîte.

Depuis quelques jours, j'avais des micro-coupures. CAD, que j'avais de
temps en temps une info-bulle "Réseau machin est maintenant connecté,
vitesse 100Mb/s". Pas trop gênant, sauf que ça m'occasionnait des coupure
quand j'étais en session SSH avec un des serveurs (sous Linux, mais pas
d'importance).

J'ai fait une inspection en règle des câbles et switches de mon poste
jusqu'au routeur : rien.

Jusqu'à ce que, ce matin, je fasse un scan en règle du réseau pour
vérifier les IP de la boîte... Et ô surprise ! j'avais une IP différente
de mon IP affectée !

Les "ipconfig /renew" (ou l'équivalent "réparer" dans la boîte de
dialogue) se sodait en time-out.

J'ai réinstallé le pilote de la carte éthernet (ça réinitialise tout),
rien à y faire. Je m'en suis sorti en supprimant la double configuration
IP. Et, là l'"ipconfig /renew" remarche.

Ça vient d'où ? Un DHCP parasite sur le réseau ?

Au fait mon portable est sous XP familiale, SP2 à jour.



Bonjour.

L'hypothèse du DHCP parasite est à étudier en effet, c'est un cas de figure
assez courant. Moultes périphériques peuvent intergrer un serveur DHCP de
nos jours :-)

Un simple sniffer réseau (type Ethereal par exemple) et l'ordi configuré en
DHCP devrait répondre à cette question rapidement.

Antoine.
Nina Popravka
Le #14347351
On Thu, 02 Aug 2007 15:16:42 +0200, Sergio

Ça vient d'où ? Un DHCP parasite sur le réseau ?



Si tu avais regardé en faisant un ipconfig /all au lieu de te jeter
sur un renew, tu le saurais, puisque tu aurais vu l'adresse du serveur
dhcp éventuel :-)
--
Nina
Pierre Goiffon
Le #14347331
Sergio wrote:
J'ai un portable avec lequel je me connecte au boulot (et ailleurs). Au
boulot, il faut affecter une IP fixe dans le sous-réseau (du style
192.168.x.yyy), attribuée par l'admin système (cad moi...).

Pour celà j'ai configuré la carte réseau avec deux possibilités :
- Dans l'onglet "général", je mets en config automatique (pour quand je
me connecte de chez moi ou d'un endroit civilisé avec DHCP).
- Dans l'onglet "configuration alternative", je mets l'IP fixe et les
DNS et passerelles de la boîte.

Depuis quelques jours, j'avais des micro-coupures. CAD, que j'avais de
temps en temps une info-bulle "Réseau machin est maintenant connecté,
vitesse 100Mb/s".


(...)
Jusqu'à ce que, ce matin, je fasse un scan en règle du réseau pour
vérifier les IP de la boîte... Et ô surprise ! j'avais une IP différente
de mon IP affectée !

Les "ipconfig /renew" (ou l'équivalent "réparer" dans la boîte de
dialogue) se sodait en time-out.



Pas sûr de bien avoir compris ce qu'il s'est passé à votre travail et la
raison pour laquelle le renew tombait en timeout ?? Votre poste
serait-il tombé sur un DHCP au travail ?

A tout hasard, voyez cette méthode sur le site de l'excellent JCB :
http://www.bellamyjc.org/fr/windows2000.html#NETSH
_Dine & Clau_
Le #14609681
Salut Sergio,

Ça vient d'où ? Un DHCP parasite sur le réseau ?



Au fait mon portable est sous XP familiale, SP2 à jour.



En fait je n'ai pas ta solution, mais en compulsant la doc sur le
sujet pour un pb similaire (changement intempestif de l'adresse ip de
mon portable sur le réseau local), j'ai pu lire que par défaut la
version XP home se connecte toujours en utilisant le "user" "tout le
monde" ou "anyone" à contrario de la version XP pro. (plusieurs
différences sont d'ailleurs à noter dans l'installation de ces deux OS
- c'est le même, mais c'est différent ;+))

Mon portable est en XP pro SP 2 mis-à-j 04 2007 et j'ai le même pb.

Le XP home serait plus du genre "attribution de l'adresse ip par dhcp
du routeur" tandis que le XP pro serait plus "viril" "donne-moi
l'adresse ip renseignée dans la config du portable".

Mais, il faut jouer aussi avec le firewall du modem-routeur qui
souvent est réglé par adressage ip suivant les adresses mac des cartes
des pc ...

Voilà pour la théorie, mais en pratique, je crois que les dhcp des
routeurs ne sont pas toujours à la hauteur et attribue les adresses IP
suivant l'ordre d'arrivée. Soit, si tu arrives à 11 heures, ton
adresse IP est déjà prise ,+)...

Il en résulte alors un conflit dans l'adressage et on se retrouve sur
le portable avec une autre adresse que celle habituelle. Cela pertube
évidemment l'ensemble du réseau, les autres machines envoyant sur
l'ancienne adresse IP.

Espérant avoir aidé qlq peu ... ;+)

__
CB
C&C
Nina Popravka
Le #14609601
On Mon, 24 Sep 2007 21:18:51 -0700, _Dine & Clau_

[ Absolument n'importe quoi ]

Espérant avoir aidé qlq peu ... ;+)



Vous m'avez fait rire, au moins...

--
Nina
Sergio
Le #14609551
_Dine & Clau_ a émis l'idée suivante :
Salut Sergio,

Ça vient d'où ? Un DHCP parasite sur le réseau ?



Au fait mon portable est sous XP familiale, SP2 à jour.



En fait je n'ai pas ta solution, mais en compulsant la doc sur le
sujet pour un pb similaire (changement intempestif de l'adresse ip de
mon portable sur le réseau local), j'ai pu lire que par défaut la
version XP home se connecte toujours en utilisant le "user" "tout le
monde" ou "anyone" à contrario de la version XP pro. (plusieurs
différences sont d'ailleurs à noter dans l'installation de ces deux OS
- c'est le même, mais c'est différent ;+))

Mon portable est en XP pro SP 2 mis-à-j 04 2007 et j'ai le même pb.



C'est un vieux message... La solution du mystère était simple : Il y
avait bien un serveur DHCP sur le réseau... Mais ça je pouvais pas
deviner...

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
_Dine & Clau_
Le #14609511
On 25 sep, 10:54, Nina Popravka du Jeufra_Kamasussera (aie aie.com) ;
+)
Vous m'avez fait rire, au moins...


Trèèèèès bien ce cours !

Merci à toi
__
CB
C&C
Phil
Le #14609501
_Dine & Clau_ news::

[Un grand moment d'humour]

Mais j'avoue ne pas avoir tout compris , surtout la "virilité" de Xp Pro.

Mébon ...


--
Phil
_Dine & Clau_
Le #14609091
On 25 sep, 17:24, Phil
Mais j'avoue ne pas avoir tout compris , surtout la "virilité" de Xp Pr o.


Bon sans "mais". ;)

J'ai fait l'amalgame.

La méthode d'attribution des adresses IP est totalement indépendante
de l'OS employé. (XP pro ou Home).

L'amalgame provient du fait qu'en Win XP home, tout est configuré par
défaut en dhcp automatique et l'utilisateur "tout le monde" ou
"anyone".

Si tout le monde peut entrer sans nom et sans mdp, n'est-ce pas
féminin ? Heu... ?? =8=O
__
CB
:+) & =8=O
Phil
Le #14609011
_Dine & Clau_ news::

La méthode d'attribution des adresses IP est totalement indépendante
de l'OS employé. (XP pro ou Home).



Ca , c'est vrai, ca ...
L'amalgame provient du fait qu'en Win XP home, tout est configuré par
défaut en dhcp automatique et l'utilisateur "tout le monde" ou
"anyone".



Xp Pro se configure aussi en dhcp par defaut.
Et Xphome , je ne crois pas que ce soit "tout le monde" , mais un nom
défini à l'install.
Mais peut-etre me fourvoie-je. Je ne pratique pas le Home .
Si tout le monde peut entrer sans nom et sans mdp, n'est-ce pas
féminin ? Heu... ?? =8=O
__



C'est toi qui le dit .. ;-)


--
Phil
Publicité
Poster une réponse
Anonyme