mauvaise valeur de la RAM

Le
Alexi Dubois
Bonjour,

j'ai 4 barrettes de 1 Go chacune, que j'ai testées indépendamment sans
problèmes. Elles affichaient bien 1 Go chacune. En en mettant deux,
elles affichent bien 2 Go. Mais en mettant les 4, elles affichent 3,7 Go
au lieu 4 Go !

il manque 300 Mo :-(


Est-ce que ça peut venir de la carte mère ?


Merci
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ascadix
Le #23076721
Il se trouve que Alexi Dubois a formulé :
Bonjour,

j'ai 4 barrettes de 1 Go chacune, que j'ai testées indépendamment sans
problèmes. Elles affichaient bien 1 Go chacune. En en mettant deux, elles
affichent bien 2 Go. Mais en mettant les 4, elles affichent 3,7 Go au lieu 4
Go !

il manque 300 Mo :-(


Est-ce que ça peut venir de la carte mère ?


Merci



Tu le lit où ton "3.7" ?

Si c'est dans la fenetre "propriétés systeme" de Windows, je t'invite à
chercher sur gogole le mystére des 3.7 au lieu 4 Go sur les Win 32 bits

--
@+
Ascadix
adresse @mail valide, mais ajoutez "sesame" dans l'objet pour que ça
arrive.
Alexi Dubois
Le #23076711
Ascadix a écrit :
Il se trouve que Alexi Dubois a formulé :
Bonjour,

j'ai 4 barrettes de 1 Go chacune, que j'ai testées indépendamment sans
problèmes. Elles affichaient bien 1 Go chacune. En en mettant deux,
elles affichent bien 2 Go. Mais en mettant les 4, elles affichent 3,7
Go au lieu 4 Go !

il manque 300 Mo :-(


Est-ce que ça peut venir de la carte mère ?


Merci



Tu le lit où ton "3.7" ?

Si c'est dans la fenetre "propriétés systeme" de Windows, je t'invite à
chercher sur gogole le mystére des 3.7 au lieu 4 Go sur les Win 32 bits




je le lis dès le démarrage du pc lors du décompte de la mémoire et
ensuite avec memtest : il s'agit donc bien d'un pb matériel.

je le lis aussi non sur windows mais sur linux

Voilà ! :-|
Th.A.C
Le #23077281
Le 01/02/2011 20:58, Alexi Dubois a écrit :

je le lis dès le démarrage du pc lors du décompte de la mémoire et
ensuite avec memtest : il s'agit donc bien d'un pb matériel.

je le lis aussi non sur windows mais sur linux

Voilà ! :-|




Regarde dans la doc de ta carte mère, c'est indiqué en général.
Az Sam
Le #23077321
Il se trouve que Alexi Dubois a formulé :
Bonjour,

j'ai 4 barrettes de 1 Go chacune, que j'ai testées indépendamment sans
problèmes. Elles affichaient bien 1 Go chacune. En en mettant deux, elles
affichent bien 2 Go. Mais en mettant les 4, elles affichent 3,7 Go au
lieu 4 Go !







chipset Via ?

--
Cordialement,
Az Sam.
patpro ~ patrick proniewski
Le #23077571
In article "Th.A.C"
Le 01/02/2011 20:58, Alexi Dubois a écrit :
>
> je le lis dès le démarrage du pc lors du décompte de la mémoire et
> ensuite avec memtest : il s'agit donc bien d'un pb matériel.
>
> je le lis aussi non sur windows mais sur linux
>
> Voilà ! :-|
>

Regarde dans la doc de ta carte mère, c'est indiqué en général.



C'est normal. Dans l'architecture classique et vieillissante du
"compatible PC" 32 bits avec BIOS et tout et tout, tu as un trou dans la
ram entre 3 et 4Go. Si tu as de la chance (ie. une bonne carte mère), tu
perds 300 Mo, si tu n'as pas de chance (ie. une carte mère plus grand
public), tu peux perdre 700 ou 800 Mo.

C'est détaillé dans la doc de ta carte mère normalement.

patpro

--
A vendre : KVM IP 16 ports APC
http://patpro.net/blog/index.php/2008/01/12/133
Alexi Dubois
Le #23077871
patpro ~ patrick proniewski a écrit :
In article "Th.A.C"
Le 01/02/2011 20:58, Alexi Dubois a écrit :
je le lis dès le démarrage du pc lors du décompte de la mémoire et
ensuite avec memtest : il s'agit donc bien d'un pb matériel.

je le lis aussi non sur windows mais sur linux

Voilà ! :-|



Regarde dans la doc de ta carte mère, c'est indiqué en général.



C'est normal. Dans l'architecture classique et vieillissante du
"compatible PC" 32 bits avec BIOS et tout et tout, tu as un trou dans la
ram entre 3 et 4Go. Si tu as de la chance (ie. une bonne carte mère), tu
perds 300 Mo, si tu n'as pas de chance (ie. une carte mère plus grand
public), tu peux perdre 700 ou 800 Mo.

C'est détaillé dans la doc de ta carte mère normalement.

patpro




dans la doc, je n'ai pas vu grand chose, mais bon...
C'est incroyable cette histoire de trou de mémoire.
Je perd 4096 - 3780 = 400 Mo environ, je m'en sors pas trop mal alors...

Il s'agit d'une MSI 865PE des années 2005


OK merci à tous pour vos réponses !
patpro ~ patrick proniewski
Le #23078181
In article Alexi Dubois
> C'est normal. Dans l'architecture classique et vieillissante du
> "compatible PC" 32 bits avec BIOS et tout et tout, tu as un trou dans la
> ram entre 3 et 4Go. Si tu as de la chance (ie. une bonne carte mère), tu
> perds 300 Mo, si tu n'as pas de chance (ie. une carte mère plus grand
> public), tu peux perdre 700 ou 800 Mo.
>
> C'est détaillé dans la doc de ta carte mère normalement.
>
> patpro
>

dans la doc, je n'ai pas vu grand chose, mais bon...
C'est incroyable cette histoire de trou de mémoire.
Je perd 4096 - 3780 = 400 Mo environ, je m'en sors pas trop mal alors...



J'ai retrouvé le nom exact du truc, c'est le "PCI Hole"

http://en.wikipedia.org/wiki/PCI_hole

J'avais le même souci il y a quelques années sur un serveur en FreeBSD
(pentium 4) dont j'avais upgradé la RAM à 4Go.
Depuis que je suis sur un serveur Xeon 64 Bit, je n'ai pas remarqué la
présence d'un trou dans la mémoire (cela dit, sur 16 Go... :) )

patpro

--
A vendre : KVM IP 16 ports APC
http://patpro.net/blog/index.php/2008/01/12/133
Alexi Dubois
Le #23079581
patpro ~ patrick proniewski a écrit :
In article Alexi Dubois
C'est normal. Dans l'architecture classique et vieillissante du
"compatible PC" 32 bits avec BIOS et tout et tout, tu as un trou dans la
ram entre 3 et 4Go. Si tu as de la chance (ie. une bonne carte mère), tu
perds 300 Mo, si tu n'as pas de chance (ie. une carte mère plus grand
public), tu peux perdre 700 ou 800 Mo.

C'est détaillé dans la doc de ta carte mère normalement.

patpro



dans la doc, je n'ai pas vu grand chose, mais bon...
C'est incroyable cette histoire de trou de mémoire.
Je perd 4096 - 3780 = 400 Mo environ, je m'en sors pas trop mal alors...



J'ai retrouvé le nom exact du truc, c'est le "PCI Hole"

http://en.wikipedia.org/wiki/PCI_hole

J'avais le même souci il y a quelques années sur un serveur en FreeBSD
(pentium 4) dont j'avais upgradé la RAM à 4Go.
Depuis que je suis sur un serveur Xeon 64 Bit, je n'ai pas remarqué la
présence d'un trou dans la mémoire (cela dit, sur 16 Go... :) )

patpro



est-ce que mettre 4Go peut amoindrir les performances ?
j'ai lu qu'au-delà du PCI hole la mémoire n'était plus cachée et que
Linux utilisait la mémoire en partant de la fin, donc de la mémoire non
cachée.
patpro ~ Patrick Proniewski
Le #23079571
In article Alexi Dubois
est-ce que mettre 4Go peut amoindrir les performances ?
j'ai lu qu'au-delà du PCI hole la mémoire n'était plus cachée et que
Linux utilisait la mémoire en partant de la fin, donc de la mémoire non
cachée.



Je n'en sais rien, mais e n'ai jamais vu de situation où plus de mémoire
est nuisible.

patpro

--
A vendre ! http://www.patpro.net/blog/index.php/2008/01/12/133
Th.A.C
Le #23081131
Le 02/02/2011 15:16, Alexi Dubois a écrit :

j'ai lu qu'au-delà du PCI hole la mémoire n'était plus cachée et que
Linux utilisait la mémoire en partant de la fin, donc de la mémoire non
cachée.



Il faut mieux lire :-)
Ca ne concerne que certaines cartes dont le bios est buggé:

http://www.generation-nt.com/reponses/lenteur-apres-passage-a-4-go-de-ram-entraide-1808821.html
Publicité
Poster une réponse
Anonyme