Me.recalc

Le
Phil HAL
Bonjour à tous,
Je suis confronté à un petit problème particulièrement gênant que je
n'arrive pas à résoudre.

J'ai une base de données (v2003) fractionnée avec des formulaires comportant
des boutons.

Depuis quelques temps, tous ceux qui font un appel à recalc systématiquement
me plantent la base
J'ai également testé :
DoCmd.DoMenuItem acFormBar, acRecordsMenu, 5, , acMenuVer70

..même effet !

En ouvrant la partie contenant les formulaires, états avec un Access
2007, tout fonctionne correctement.
Dans la version 2003, j'ai compilé mes modules sans succès.

J'ai testé le recalc dans une autre base et cela fonctionne.

Merci d'avance pour votre aide

Philippe
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Rv
Le #18451851
Salut,

Peut-être en partant d'une base vierge et en réimportant tous les objets
de l'ancienne base dans cette nouvelle. As-tu essayé ?

A+

Rv

"Phil HAL" 4975e7a8$0$9375$
Bonjour à tous,
Je suis confronté à un petit problème particulièrement gênant que je
n'arrive pas à résoudre.

J'ai une base de données (v2003) fractionnée avec des formulaires
comportant des boutons.

Depuis quelques temps, tous ceux qui font un appel à recalc
systématiquement me plantent la base...
J'ai également testé :
DoCmd.DoMenuItem acFormBar, acRecordsMenu, 5, , acMenuVer70

..même effet !

En ouvrant la partie contenant les formulaires, états... avec un Access
2007, tout fonctionne correctement.
Dans la version 2003, j'ai compilé mes modules sans succès.

J'ai testé le recalc dans une autre base et cela fonctionne.

Merci d'avance pour votre aide

Philippe




Phil HAL
Le #18466031
Merci pour l'idée Rv,
J'ai effectivement essayé, l'opération d'importation en une seule fois m'a
occasionné des plantages également.
Je vais retenter en plusieurs fois...
...ou dispatcher un runtime 2007 aux utilisateurs (au bord de la crise de
nerf).

Ph

Salut,

Peut-être en partant d'une base vierge et en réimportant tous les
objets de l'ancienne base dans cette nouvelle. As-tu essayé ?

A+

Rv

"Phil HAL" 4975e7a8$0$9375$
Bonjour à tous,
Je suis confronté à un petit problème particulièrement gênant que je
n'arrive pas à résoudre.

J'ai une base de données (v2003) fractionnée avec des formulaires
comportant des boutons.

Depuis quelques temps, tous ceux qui font un appel à recalc
systématiquement me plantent la base...
J'ai également testé :
DoCmd.DoMenuItem acFormBar, acRecordsMenu, 5, , acMenuVer70

..même effet !

En ouvrant la partie contenant les formulaires, états... avec un Access
2007, tout fonctionne correctement.
Dans la version 2003, j'ai compilé mes modules sans succès.

J'ai testé le recalc dans une autre base et cela fonctionne.

Merci d'avance pour votre aide

Philippe








Publicité
Poster une réponse
Anonyme