Media player dans formulaire.

Le
Léila
Bonjourà tous.
J'ai inséré le contrôle Active X Windows Media Player dans un formulaire de
mon application, qui lit un fichier "*.wmv" à l'ouverture du formulaire. Ca
marchait parfaitement bien sur mes deux postes mais à présent, ça ne marche
plus que sur un seul. Sur l'autre, on voit bien que la lecture se fait, mais
la fenêtre du lecteur prend un fond de couleur verte qui persiste, et aucune
vidéo ne s'affiche. Qu'est-ce qui a bien pu se passer sur ce poste? Je n'en
ai aucune idée. J'espère que vous pourrez m'aider. Merci.



__________ Information provenant d'ESET Smart Security, version de la base
des signatures de virus 5111 (20100513) __________

Le message a été vérifié par ESET Smart Security.

http://www.eset.com





__________ Information provenant d'ESET Smart Security, version de la base des signatures de virus 5111 (20100513) __________

Le message a été vérifié par ESET Smart Security.

http://www.eset.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
3stone
Le #22116701
Salut,

Avec cette méthode, tu n'as pas fini d'être em*****
Même si cela fonctionne sur l'un ou l'autre de TES postes,
rien ne garanti que cela fonctionne sur un autre poste,
si ce poste ne possède pas l'activeX ou de la bonne version.

La meilleure méthode est de simplement démarrer la vidéo
en laissant le choix du "player" par défaut déclarer sur ce poste.

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)



Léila wrote:
Bonjourà tous.
J'ai inséré le contrôle Active X Windows Media Player dans un
formulaire de
mon application, qui lit un fichier "*.wmv" à l'ouverture du
formulaire. Ca
marchait parfaitement bien sur mes deux postes mais à présent, ça ne
marche
plus que sur un seul. Sur l'autre, on voit bien que la lecture se
fait, mais
la fenêtre du lecteur prend un fond de couleur verte qui persiste, et
aucune
vidéo ne s'affiche. Qu'est-ce qui a bien pu se passer sur ce poste?
Je n'en
ai aucune idée. J'espère que vous pourrez m'aider. Merci.



__________ Information provenant d'ESET Smart Security, version de la
base
des signatures de virus 5111 (20100513) __________

Le message a été vérifié par ESET Smart Security.

http://www.eset.com





__________ Information provenant d'ESET Smart Security, version de la
base des signatures de virus 5111 (20100513) __________

Le message a été vérifié par ESET Smart Security.

http://www.eset.com
Léila
Le #22117911
3stone wrote:
Salut,

Avec cette méthode, tu n'as pas fini d'être em*****
Même si cela fonctionne sur l'un ou l'autre de TES postes,
rien ne garanti que cela fonctionne sur un autre poste,
si ce poste ne possède pas l'activeX ou de la bonne version.



D'accord 3stone, mais il n'y a pas de problème d'ActiveX ni de version sur
mes postes. Tout fonctionnait bien et subitement, ça ne marche plus. Le
curseur de lecture avance, j'ai bien le son, mais pour la vidéo, rien qu'un
fond vert.
J'ai tout de même fait la remarque suivante:
Lorsque je crée une nouvelle base et que j'insère le lecteur dans un
formulaire, ça marche bien. En décochant la référence wmp.dll, puis en
redémarrant la base, il n' y a pas de vidéo, ce qui est normal!! Par contre
ce qui n'est pas normal, c'est lorsque je recoche la référence wmp.dll puis
redémarre la base: la vidéo laisse la place à ce triste fond vert et plus
possible de réparer. Il faut absolument recommencer avec une base vierge
pour que ça marche.

La meilleure méthode est de simplement démarrer la vidéo
en laissant le choix du "player" par défaut déclarer sur ce poste.



J'ai tout simplement opté pour ce choix parce qu'alors au cours de la
lecture, on a devant soit quelques commandes du lecteur (précédent, suivant,
volume, pause, arrêt, etc...)



__________ Information provenant d'ESET Smart Security, version de la base des signatures de virus 5111 (20100513) __________

Le message a été vérifié par ESET Smart Security.

http://www.eset.com
Publicité
Poster une réponse
Anonyme