MEFC - problème avec "OU"

Le
j-pascal
Bonsoir,

Chacune des propositions suivantes fonctionne séparément, mais si je
mets un "OU" pour les regrouper, ça ne fonctionne plus !

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


Ici !

=ou(ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX));ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX)))

Merci pour vos lumières,

(PS : j'utilise ça dans une MEFC
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #19383921
Bonsoir,
Si mes yeux ne m'abusent, tu enchaîne 2 fois de suite les mêmes "ou" !
Un éclaircissement ?
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"j-pascal" news:
Bonsoir,

Chacune des propositions suivantes fonctionne séparément, mais si je mets
un "OU" pour les regrouper, ça ne fonctionne plus !

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


Ici !

=ou(ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX));ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX)))

Merci pour vos lumières,

(PS : j'utilise ça dans une MEFC




Jacky
Le #19383911
Bonsoir,

Il doit y avoir quelque chose qui m'échappe,
Pourquoi mettre 2 fois les même conditions ???
Sinon
=ou (h3=condition1; h3=condition2; h3=condition3; h3=condition4)
--
Salutations
JJ


"j-pascal"
Bonsoir,

Chacune des propositions suivantes fonctionne séparément, mais si je mets
un "OU" pour les regrouper, ça ne fonctionne plus !

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


Ici !

=ou(ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX));ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX)))

Merci pour vos lumières,

(PS : j'utilise ça dans une MEFC




garnote
Le #19383901
Si tes yeux t'abusent, les miens m'abusent aussi :-)

Serge

"Philippe.R" u7be%
Bonsoir,
Si mes yeux ne m'abusent, tu enchaîne 2 fois de suite les mêmes "ou" !
Un éclaircissement ?
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"j-pascal" news:
Bonsoir,

Chacune des propositions suivantes fonctionne séparément, mais si je mets
un "OU" pour les regrouper, ça ne fonctionne plus !

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


Ici !

=ou(ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX));ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX)))

Merci pour vos lumières,

(PS : j'utilise ça dans une MEFC







Jacky
Le #19383971
N'abusez pas trop tout de même
;o))

--
Salutations
JJ


"garnote"
Si tes yeux t'abusent, les miens m'abusent aussi :-)

Serge

"Philippe.R" u7be%
Bonsoir,
Si mes yeux ne m'abusent, tu enchaîne 2 fois de suite les mêmes "ou" !
Un éclaircissement ?
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"j-pascal" news:
Bonsoir,

Chacune des propositions suivantes fonctionne séparément, mais si je
mets un "OU" pour les regrouper, ça ne fonctionne plus !

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


Ici !

=ou(ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX));ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX)))

Merci pour vos lumières,

(PS : j'utilise ça dans une MEFC











j-pascal
Le #19385011
Bonsoir à tous,

Désolé, j'ai posté trop vite avant d'aller au théâtre, pour trouver la
réponse au retour ;-)

J'ai mal recopié la formule qui me posait pb au boulot cet am.

Je regarde ça demain, quand j'aurai les yeux en face des trous !

Encore désolé ;-(

JP

Bonsoir,

Il doit y avoir quelque chose qui m'échappe,
Pourquoi mettre 2 fois les même conditions ???
Sinon
=ou (h3=condition1; h3=condition2; h3=condition3; h3=condition4)
--
Salutations
JJ


"j-pascal"
Bonsoir,

Chacune des propositions suivantes fonctionne séparément, mais si je mets
un "OU" pour les regrouper, ça ne fonctionne plus !

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


Ici !

=ou(ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX));ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX)))

Merci pour vos lumières,

(PS : j'utilise ça dans une MEFC






j-pascal
Le #19393431
Re,

Je confirme, j'ai un problème avec la formule qui suit :

La cellule s'affiche en couleur (par défaut), si sa valeur ne figure
pas dans la plage nommée "destinataire_1" (sinon, la MEFC s'applique) :

=H3=RECHERCHEV(H3;destinataire_1;1;FAUX)

Cette même cellule s'affiche en couleur (par défaut), si sa valeur ne
figure pas dans la plage nommée "destinataire_2" (sinon, la MEFC
s'applique):

H3=RECHERCHEV(H3;destinataire_2;1;FAUX)


Par contre, et c'est là le problème, si la valeur de la cellule ne
figure ni dans la plage "destinataire_1", ni dans la plage
"destinataire_2", la MEFC ne s'applique pas alors que le test est vrai
!

=OU(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


J'ai beau réfléchir (un peu !), je ne vois pas ce qui cloche !

Merci pour vos lumières,

JP

Bonsoir,

Chacune des propositions suivantes fonctionne séparément, mais si je mets un
"OU" pour les regrouper, ça ne fonctionne plus !

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


Ici !

=ou(ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX));ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX)))

Merci pour vos lumières,

(PS : j'utilise ça dans une MEFC


Philippe.R
Le #19394221
Bonjour,
Fais l'essai de cette façon :

=(H3=RECHERCHEV(H3;destinataire_1;1;FAUX)+(H3=RECHERCHEV(H3;destinataire_2;1;FAUX))=1
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"j-pascal" news:
Re,

Je confirme, j'ai un problème avec la formule qui suit :

La cellule s'affiche en couleur (par défaut), si sa valeur ne figure pas
dans la plage nommée "destinataire_1" (sinon, la MEFC s'applique) :

=H3=RECHERCHEV(H3;destinataire_1;1;FAUX)

Cette même cellule s'affiche en couleur (par défaut), si sa valeur ne
figure pas dans la plage nommée "destinataire_2" (sinon, la MEFC
s'applique):

H3=RECHERCHEV(H3;destinataire_2;1;FAUX)


Par contre, et c'est là le problème, si la valeur de la cellule ne figure
ni dans la plage "destinataire_1", ni dans la plage "destinataire_2", la
MEFC ne s'applique pas alors que le test est vrai !

=OU(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


J'ai beau réfléchir (un peu !), je ne vois pas ce qui cloche !

Merci pour vos lumières,

JP

Bonsoir,

Chacune des propositions suivantes fonctionne séparément, mais si je mets
un "OU" pour les regrouper, ça ne fonctionne plus !

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


Ici !

=ou(ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX));ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX)))

Merci pour vos lumières,

(PS : j'utilise ça dans une MEFC






Jacky
Le #19394211
Re..

Essaye:

=OU(NON(ESTERREUR(H3=RECHERCHEV(H3;destinataire_1;1;FAUX)));NON(ESTERREUR(H3=RECHERCHEV(H3;destinataire_2;1;FAUX))))

--
Salutations
JJ


"j-pascal"
Re,

Je confirme, j'ai un problème avec la formule qui suit :

La cellule s'affiche en couleur (par défaut), si sa valeur ne figure pas
dans la plage nommée "destinataire_1" (sinon, la MEFC s'applique) :

=H3=RECHERCHEV(H3;destinataire_1;1;FAUX)

Cette même cellule s'affiche en couleur (par défaut), si sa valeur ne
figure pas dans la plage nommée "destinataire_2" (sinon, la MEFC
s'applique):

H3=RECHERCHEV(H3;destinataire_2;1;FAUX)


Par contre, et c'est là le problème, si la valeur de la cellule ne figure
ni dans la plage "destinataire_1", ni dans la plage "destinataire_2", la
MEFC ne s'applique pas alors que le test est vrai !

=OU(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


J'ai beau réfléchir (un peu !), je ne vois pas ce qui cloche !

Merci pour vos lumières,

JP

Bonsoir,

Chacune des propositions suivantes fonctionne séparément, mais si je mets
un "OU" pour les regrouper, ça ne fonctionne plus !

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


Ici !

=ou(ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX));ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX)))

Merci pour vos lumières,

(PS : j'utilise ça dans une MEFC






j-pascal
Le #19395201
Bonjour Philippe,

Merci pour cette proposition, mais (sauf erreur de ma part) ça ne
fonctionne pas !

Je suis surpris que ce simple test avec "OU" ne fonctionne pas !!

A bientôt,

jp

Bonjour,
Fais l'essai de cette façon :

=(H3=RECHERCHEV(H3;destinataire_1;1;FAUX)+(H3=RECHERCHEV(H3;destinataire_2;1;FAUX))=1
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"j-pascal" news:
Re,

Je confirme, j'ai un problème avec la formule qui suit :

La cellule s'affiche en couleur (par défaut), si sa valeur ne figure pas
dans la plage nommée "destinataire_1" (sinon, la MEFC s'applique) :

=H3=RECHERCHEV(H3;destinataire_1;1;FAUX)

Cette même cellule s'affiche en couleur (par défaut), si sa valeur ne
figure pas dans la plage nommée "destinataire_2" (sinon, la MEFC
s'applique):

H3=RECHERCHEV(H3;destinataire_2;1;FAUX)


Par contre, et c'est là le problème, si la valeur de la cellule ne figure
ni dans la plage "destinataire_1", ni dans la plage "destinataire_2", la
MEFC ne s'applique pas alors que le test est vrai !

=OU(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


J'ai beau réfléchir (un peu !), je ne vois pas ce qui cloche !

Merci pour vos lumières,

JP

Bonsoir,

Chacune des propositions suivantes fonctionne séparément, mais si je mets
un "OU" pour les regrouper, ça ne fonctionne plus !

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


Ici !

=ou(ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX));ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX)))

Merci pour vos lumières,

(PS : j'utilise ça dans une MEFC








j-pascal
Le #19395191
Bonjour Jacky,

Merci ; ça fonctionne !

J'aurais bien aimé savoir pour quelle raison ma modeste formule ne
fonctionne pas ...

@+ ?

JP

Re..

Essaye:

=OU(NON(ESTERREUR(H3=RECHERCHEV(H3;destinataire_1;1;FAUX)));NON(ESTERREUR(H3=RECHERCHEV(H3;destinataire_2;1;FAUX))))

--
Salutations
JJ


"j-pascal"
Re,

Je confirme, j'ai un problème avec la formule qui suit :

La cellule s'affiche en couleur (par défaut), si sa valeur ne figure pas
dans la plage nommée "destinataire_1" (sinon, la MEFC s'applique) :

=H3=RECHERCHEV(H3;destinataire_1;1;FAUX)

Cette même cellule s'affiche en couleur (par défaut), si sa valeur ne
figure pas dans la plage nommée "destinataire_2" (sinon, la MEFC
s'applique):

H3=RECHERCHEV(H3;destinataire_2;1;FAUX)


Par contre, et c'est là le problème, si la valeur de la cellule ne figure
ni dans la plage "destinataire_1", ni dans la plage "destinataire_2", la
MEFC ne s'applique pas alors que le test est vrai !

=OU(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


J'ai beau réfléchir (un peu !), je ne vois pas ce qui cloche !

Merci pour vos lumières,

JP

Bonsoir,

Chacune des propositions suivantes fonctionne séparément, mais si je mets
un "OU" pour les regrouper, ça ne fonctionne plus !

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))

=ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX))


Ici !

=ou(ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX));ou(H3=RECHERCHEV(H3;destinataire_1;1;FAUX);H3=RECHERCHEV(H3;destinataire_2;1;FAUX)))

Merci pour vos lumières,

(PS : j'utilise ça dans une MEFC








Publicité
Poster une réponse
Anonyme