mélange autorisations individu et groupe bloquant

Le
pmanet
MACOSX 10.4.10 ayant beaucoup vécu.

pour je ne sais quelles raisons, un certain nombre d'applis se
retrouvent avec les autorisations suivantes :
possesseur : moi -> WR
groupe : moi W et pas W
et ça semble beaucoup les gener. Exemple : CCC refusait de bosser, j'ai
corrigé le groupe moi en RW et c'est parti, alors qu'en tant que
possessseur,j'était déclaré RW.

je me demande d'ou vient cette apparition d'un groupe moi, et
l'autorisation en lecture seule.

de meme, en quoi le fait que je sois autorisé correctement comme
possesseur, mais qu'en tant que groupe, je ne le sois pas, peut-il géner
l'appli ? Je découvre que c'est le cas pour pas mal d'applis, mais pas
pour toutes (les autres ont admin comme groupe).

si je regarde avec Sharepoint, je m'aperçois qu'il y a 2 entités avec le
meme numero qui sont à la fois qualifiées de groupe et d'individu (moi,
comme 501, et un autre comme 507). Je ne sais pas d'où ça vient. Comment
corriger cette situation sans risquer de perturber mes droits comme
individu ?

Je précise que d'après Sharepoint, le groupe moi 501 n'a pas de membre.

--
www.D-L-S.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas-MICHEL'_remove_'
Le #2992431
gmanet
MACOSX 10.4.10 ayant beaucoup vécu.

pour je ne sais quelles raisons, un certain nombre d'applis se
retrouvent avec les autorisations suivantes :
possesseur : moi -> WR
groupe : moi W et pas W


Je suppose que tu veux dire R et pas W ?

et ça semble beaucoup les gener. Exemple : CCC refusait de bosser, j'ai
corrigé le groupe moi en RW et c'est parti, alors qu'en tant que
possessseur,j'était déclaré RW.


C'est pas normal. En principe, l'ordre de recherche est "ugo" :
le système commence par l'utilisateur puis il va checker le groupe
en fin de course il applique les droits de "others"

Tu n'aurais pas des ACL par hasard ?
(ls -le pour voir les acl)

je me demande d'ou vient cette apparition d'un groupe moi, et
l'autorisation en lecture seule.


ça, c'est normal il me semble.
Au tout début de Mac OS X, le GID (groupe par défaut) de tous les
utilisateurs était staff.
Depuis quelques versions, à la création d'un nouvel utilisateur le
système crée un groupe du même nom, comme sous linux.

Quand aux autorisations par défaut, c'est un umask 022
un dossier sera rwxr-xr-x et un fichier sera rw-r--r--

de meme, en quoi le fait que je sois autorisé correctement comme
possesseur, mais qu'en tant que groupe, je ne le sois pas, peut-il géner
l'appli ? Je découvre que c'est le cas pour pas mal d'applis, mais pas
pour toutes (les autres ont admin comme groupe).


Cela ne devrait pas géner puisque c'est sensé d'abord regarder le user.
Dans ton cas, il y a un souci.

si je regarde avec Sharepoint, je m'aperçois qu'il y a 2 entités avec le
meme numero qui sont à la fois qualifiées de groupe et d'individu (moi,
comme 501, et un autre comme 507). Je ne sais pas d'où ça vient. Comment
corriger cette situation sans risquer de perturber mes droits comme
individu ?


Pas tout suivis. Tu veux dire qu'il y a un UID et un GID du même nom qui
n'ont pas les mêmes numéro ? si c'est ça c'est pas grave.

Je précise que d'après Sharepoint, le groupe moi 501 n'a pas de membre.


Normal.

Pour avoir la liste complète des membres d'un groupe, il faut
additionner les membres listés plus chercher tous les utilisateurs dont
le GID est celui de ce groupe.

Par exemple chez moi wheel n'a aucun membre listé mais le GID de root
est 0, donc root fait partie du groupe wheel


--
Nicolas - MICHEL at bluewin point ch
AIM : michelnicolas

pmanet
Le #2990001
Nicolas MICHEL
pour je ne sais quelles raisons, un certain nombre d'applis se
retrouvent avec les autorisations suivantes :
possesseur : moi -> WR
groupe : moi W et pas W


Je suppose que tu veux dire R et pas W ?


exact, milles excuses.

et ça semble beaucoup les gener. Exemple : CCC refusait de bosser, j'ai
corrigé le groupe moi en RW et c'est parti, alors qu'en tant que
possessseur,j'était déclaré RW.


C'est pas normal. En principe, l'ordre de recherche est "ugo" :
le système commence par l'utilisateur puis il va checker le groupe
en fin de course il applique les droits de "others"

Tu n'aurais pas des ACL par hasard ?
(ls -le pour voir les acl)


arggg, j'en ai 10320 !!! d'où ça sort ? je croyais que c'était un truc
d'origine PC qu'il fallat faire exprès de mettre en place, ça ne tombe
pas du ciel ?

si je regarde avec Sharepoint, je m'aperçois qu'il y a 2 entités avec le
meme numero qui sont à la fois qualifiées de groupe et d'individu (moi,
comme 501, et un autre comme 507). Je ne sais pas d'où ça vient. Comment
corriger cette situation sans risquer de perturber mes droits comme
individu ?


Pas tout suivis. Tu veux dire qu'il y a un UID et un GID du même nom qui
n'ont pas les mêmes numéro ? si c'est ça c'est pas grave.


non, moi UID et GID ont le meme 501 ; il y a un autre utilisateur JP qui
a un UID et GID 507. Mais je vois que ça semble devenu normal.
bon, donc le groupe staff a disparu ? effectivement je ne le trouve plus


Ce qui est anormal, c'est qu'un grand nombre d'applis se retrouvent avec
des autorisations divergentes pour mon UID et GID, et qu'en plus elles
tiennent plus compte de la GUID que de l'UID.


--
www.D-L-S.org


Nicolas-MICHEL'_remove_'
Le #2989891
manet
Tu n'aurais pas des ACL par hasard ?
(ls -le pour voir les acl)


arggg, j'en ai 10320 !!! d'où ça sort ? je croyais que c'était un truc
d'origine PC qu'il fallat faire exprès de mettre en place, ça ne tombe
pas du ciel ?


C'est étrange en effêt.
Vu d'ici, je ne peux pas te dire comment c'est arrivé, mais je suppose
que tu vas pouvoir tracker le problème et nous expliquer.

A présent tu peux commencer par désactiver les ACL, pour voir comment ça
réagit, puis tu pourras les enlever.

Pour désactiver les ACL :
sudo fsaclctl -p / -d

Pour les enlever, en fonction du numéro de l'ACL :
%> sudo chmod -a# 0 test

Il y a aussi des utilitaires qui font ça graphiquement, mais j'ai oublié
les noms.

non, moi UID et GID ont le meme 501 ; il y a un autre utilisateur JP qui
a un UID et GID 507. Mais je vois que ça semble devenu normal.
bon, donc le groupe staff a disparu ? effectivement je ne le trouve plus


disparu, je ne sais pas. Perso je l'ai encore sur mon mac, peut-être
suite à une install par update
Mais ce n'est plus le GID par défaut de tous les utilisateurs.

Ce qui est anormal, c'est qu'un grand nombre d'applis se retrouvent avec
des autorisations divergentes pour mon UID et GID, et qu'en plus elles
tiennent plus compte de la GUID que de l'UID.


Pas tout compris.
Peux-tu faire un "ls -lae /Applications" pour qu'on comprenne stp ?

Bon courrage.
--
Nicolas - MICHEL at bluewin point ch
AIM : michelnicolas


Publicité
Poster une réponse
Anonyme