Mémoire au-delà de 3GB

Le
Clément
Bonjour,
J'ai acquis un nouveau mobo de marque Asus avec un cpu Core 2 Quad ainsi que
4 x 1 GB de mémoire et Windows XP sp2 Pro. Lorsque j'installe 3 x 1GB de
mémoire, il n'y a pas de problème et tout fonctionne bien, mais lorsque je
mets le 4e module, rien ne se passe au démarrge. J'ai lu dans le livre du
mobo que si on installe 4 x 1GB, le systeme pouvait ne pas fonctionner, mais
j'ai aussi entendu que l'on pouvait modifier le boot.ini, le système pourrait
l'accepter. Est-ce quelqu'un parmi vous sait comment on peut procéder à ce
changement.

Merci.

Clément
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Claude BELLAMY
Le #1123702
"Clément" news:
Bonjour,
J'ai acquis un nouveau mobo de marque Asus avec un cpu Core 2 Quad ainsi
que
4 x 1 GB de mémoire et Windows XP sp2 Pro. Lorsque j'installe 3 x 1GB de
mémoire, il n'y a pas de problème et tout fonctionne bien, mais lorsque je
mets le 4e module, rien ne se passe au démarrge. J'ai lu dans le livre du
mobo que si on installe 4 x 1GB, le systeme pouvait ne pas fonctionner,
mais
j'ai aussi entendu que l'on pouvait modifier le boot.ini, le système
pourrait
l'accepter. Est-ce quelqu'un parmi vous sait comment on peut procéder à ce
changement.



(copier-coller d'une de mes réponses précédentes à ce sujet)

Tout système 32 bits peut adresser juqu'à 2^32 octets, soit 4 Go.

Cependant, Windows NT 32 bits (toute version standard de NT4, W2K, XP,
W2K3, Vista) gère ces 4 Go de façon un peu spéciale, à savoir qu'une partie
est réservé au système (par défaut 2 Go) et une autre aux applications
utilisateur (par défaut 2 Go)

Le switch /3GB utilisé dans la ligne de commande du fichier boot.ini permet
de répartir ces 4 Go en
3 Go pour les programmes
1 Go pour le système.

P.ex.
multi(0)disk(0)rdisk(1)partition(3)windows="Windows 2003" /fastdetect
/3GB
multi(0)disk(0)rdisk(0)partiton(1)windows="Windows XP" /3GB /fastdetect
/NoExecute=AlwaysOff

Mais il ne faut pas croire que ce commutateur partage la RAM physique comme
un gateau avec une part de 3Go pour le mode user et une part de 1Go pour le
mode kernel.
C'est beaucoup plus complexe que çà !
cf. :
http://msdn2.microsoft.com/en-us/library/aa366912.aspx + les autres
chapitres ...

Cela signifie que le mode user PEUT adresser jusqu'à 3 Go, (mais non pas
qu'on réserve 3 Go obligatoirement) et que mode kernel PEUT adresser jusqu'à
1 Go.


PS: le switch /3GB ne fonctionne pas sous W2K PRO, ni W2K SRV "lambda", ni
XP Home
Il n'est utilisable qu'avec :
Windows NT Server 4.0, Enterprise Edition
Windows 2000 Advanced Server
Windows 2000 Datacenter Server
Windows XP Pro
Windows Server 2003
Windows Server 2003, Enterprise Edition
Windows Server 2003, Datacenter Edition


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org

Clément
Le #1123112
Bonjour,

Je vous remercie de vos commentaires et vos indications, mais
malheureusement, les changements proposés n'ont rien changé au problème. Je
ne suis toujours pas capable de démarrer l'ordinateur avec 4GB installés.
Peut-être avez-vous d'autres trucs?.

Merci.
Clément


"Clément" news:
Bonjour,
J'ai acquis un nouveau mobo de marque Asus avec un cpu Core 2 Quad ainsi
que
4 x 1 GB de mémoire et Windows XP sp2 Pro. Lorsque j'installe 3 x 1GB de
mémoire, il n'y a pas de problème et tout fonctionne bien, mais lorsque je
mets le 4e module, rien ne se passe au démarrge. J'ai lu dans le livre du
mobo que si on installe 4 x 1GB, le systeme pouvait ne pas fonctionner,
mais
j'ai aussi entendu que l'on pouvait modifier le boot.ini, le système
pourrait
l'accepter. Est-ce quelqu'un parmi vous sait comment on peut procéder à ce
changement.



(copier-coller d'une de mes réponses précédentes à ce sujet)

Tout système 32 bits peut adresser juqu'à 2^32 octets, soit 4 Go.

Cependant, Windows NT 32 bits (toute version standard de NT4, W2K, XP,
W2K3, Vista) gère ces 4 Go de façon un peu spéciale, à savoir qu'une partie
est réservé au système (par défaut 2 Go) et une autre aux applications
utilisateur (par défaut 2 Go)

Le switch /3GB utilisé dans la ligne de commande du fichier boot.ini permet
de répartir ces 4 Go en
3 Go pour les programmes
1 Go pour le système.

P.ex.
multi(0)disk(0)rdisk(1)partition(3)windows="Windows 2003" /fastdetect
/3GB
multi(0)disk(0)rdisk(0)partiton(1)windows="Windows XP" /3GB /fastdetect
/NoExecute=AlwaysOff

Mais il ne faut pas croire que ce commutateur partage la RAM physique comme
un gateau avec une part de 3Go pour le mode user et une part de 1Go pour le
mode kernel.
C'est beaucoup plus complexe que çà !
cf. :
http://msdn2.microsoft.com/en-us/library/aa366912.aspx + les autres
chapitres ...

Cela signifie que le mode user PEUT adresser jusqu'à 3 Go, (mais non pas
qu'on réserve 3 Go obligatoirement) et que mode kernel PEUT adresser jusqu'à
1 Go.


PS: le switch /3GB ne fonctionne pas sous W2K PRO, ni W2K SRV "lambda", ni
XP Home
Il n'est utilisable qu'avec :
Windows NT Server 4.0, Enterprise Edition
Windows 2000 Advanced Server
Windows 2000 Datacenter Server
Windows XP Pro
Windows Server 2003
Windows Server 2003, Enterprise Edition
Windows Server 2003, Datacenter Edition


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org




yannou75
Le #1112147
"Clément" wrote:

Bonjour,
J'ai acquis un nouveau mobo de marque Asus avec un cpu Core 2 Quad ainsi que
4 x 1 GB de mémoire et Windows XP sp2 Pro. Lorsque j'installe 3 x 1GB de
mémoire, il n'y a pas de problème et tout fonctionne bien, mais lorsque je
mets le 4e module, rien ne se passe au démarrge. J'ai lu dans le livre du
mobo que si on installe 4 x 1GB, le systeme pouvait ne pas fonctionner, mais
j'ai aussi entendu que l'on pouvait modifier le boot.ini, le système pourrait
l'accepter. Est-ce quelqu'un parmi vous sait comment on peut procéder à ce
changement.

Merci.

Clément


bonjour,
essais de demarrer avec 3GB et fais mise a jour de ton BIOS apres tu ajoutes
la 4eme barrette .
ca doit marcher,
en tt cas pour mon asus p5b premium vista ,4GB RAM ,QUADcore 6600 2.4Ghz
yannou

Publicité
Poster une réponse
Anonyme