"Mémoire insuffisante pour afficher en entier" sous Excel 2007

Le
HD
Bonjour,

J'ai un collègue qui a constamment le message "Mémoire insuffisante pour
afficher en entier". Il est sous Excel 2007. Il travaille sous Vista avec
2Go de mémoire.

J'ai lut que ce bug pouvait venir d'un problème de police de caractère (en
trop grand nombre) c'est dû moins ce qui provoquait ce message sur les
autres versions d'Excel.

Mais il est le seul à avoir ces messages d'erreurs alors qu'il utilise
les mêmes fichiers que les autres. J'ai réinitialisé son Excel :
- en renommant le répertoire XLSTART ainsi que le fichier Excel12.xlb sur
son répertoire %APPDATA%MicrosoftExcel
- en lançant les commandes << excel.exe /unregserver >> puis << excel.exe
/regserver >>
Mais le problème se produit toujours

Avez vous une idée d'où cela peut il venir ? Et surtout comment résoudre le
problème ?

Merci d'avance pour votre aide
--
@+
HD
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #22629821
bonjour HD,

y a t'il un fichier dans le répertoire XLSTART (perso.xls) ?

isabelle

Le 2010-09-29 06:42, HD a écrit :
Bonjour,

J'ai un collègue qui a constamment le message "Mémoire insuffisante pour
afficher en entier". Il est sous Excel 2007. Il travaille sous Vista avec
2Go de mémoire.

J'ai lut que ce bug pouvait venir d'un problème de police de caractère (en
trop grand nombre)... c'est dû moins ce qui provoquait ce message sur les
autres versions d'Excel.

Mais... il est le seul à avoir ces messages d'erreurs alors qu'il utilise
les mêmes fichiers que les autres. J'ai réinitialisé son Excel :
- en renommant le répertoire XLSTART ainsi que le fichier Excel12.xlb sur
son répertoire %APPDATA%MicrosoftExcel
- en lançant les commandes /regserver>>
Mais le problème se produit toujours...

Avez vous une idée d'où cela peut il venir ? Et surtout comment résoudre le
problème ?

Merci d'avance pour votre aide
HD
Le #22629941
Bonjour Isabelle,

y a t'il un fichier dans le répertoire XLSTART (perso.xls) ?


J'ai renommé le répertoire XLSTART... mais rien n'y change.

Entre temps, ce matin, j'ai :
- Mis de côté des fichiers Fonts du répertoire c:windowsfonts car j'ai lut
sur le net que le bug en question peut avoir rapport avec les polices de
caractères... et le poste en question ayant été anciennement utilisé par un
collègue arabe, j'ai supprimé les polices de caractères non standard que
j'ai put trouver.
- J'ai supprimé à nouveau le répertoire XLSTART de
%AppData%MicrosoftExcel
- J'ai lancé un excel.exe /unregserver puis un excel.exe /regserver
- J'ai désactivé tous les compléments (il y'avait un complément "Send to
BlueTooth" qui était dans les compléments Excel)
- J'ai téléchargement des mises à jour + Service Pack 2 de Microsoft Office
2007

Depuis ce matin, ma collègue n'a pas eu de plantage... à voir dans le temps
ce que cela va donner...

En tout cas, j'ai vu qu'il était difficile de réinitialiser les paramètres
d'Excel car même en supprimant XLSTART et en lançant excel.exe /unregserver
lorsque l'on relance Excel on a encore tout un tas de paramètres qui ont été
conservés... :-/
Il faudrait carrément trifouiller la base de registre pour nettoyer tout
ça...

Je vous tiens au courant de la suite de l'affaire... J'espère résoudre le
problème... sans être obligé de formater le pc pour réinstaller Office...
;-)
--
@+
HD
isabelle
Le #22629981
HD, merci pour ce retour,

isabelle


Le 2010-09-30 09:16, HD a écrit :
Bonjour Isabelle,

y a t'il un fichier dans le répertoire XLSTART (perso.xls) ?


J'ai renommé le répertoire XLSTART... mais rien n'y change.

Entre temps, ce matin, j'ai :
- Mis de côté des fichiers Fonts du répertoire c:windowsfonts car j'ai lut
sur le net que le bug en question peut avoir rapport avec les polices de
caractères... et le poste en question ayant été anciennement utilisé par un
collègue arabe, j'ai supprimé les polices de caractères non standard que
j'ai put trouver.
- J'ai supprimé à nouveau le répertoire XLSTART de
%AppData%MicrosoftExcel
- J'ai lancé un excel.exe /unregserver puis un excel.exe /regserver
- J'ai désactivé tous les compléments (il y'avait un complément "Send to
BlueTooth" qui était dans les compléments Excel)
- J'ai téléchargement des mises à jour + Service Pack 2 de Microsoft Office
2007

Depuis ce matin, ma collègue n'a pas eu de plantage... à voir dans le temps
ce que cela va donner...

En tout cas, j'ai vu qu'il était difficile de réinitialiser les paramètres
d'Excel car même en supprimant XLSTART et en lançant excel.exe /unregserver
lorsque l'on relance Excel on a encore tout un tas de paramètres qui ont été
conservés... :-/
Il faudrait carrément trifouiller la base de registre pour nettoyer tout
ça...

Je vous tiens au courant de la suite de l'affaire... J'espère résoudre le
problème... sans être obligé de formater le pc pour réinstaller Office...
;-)
HD
Le #22633431
Pour information le problème semble être maintenant résolu... ma collègue
qui avait plusieurs plantages de ce type par jour n'en a plus depuis hier...

--
@+
HD
Publicité
Poster une réponse
Anonyme