Memorisation de mot de passe en Workgroup sous Xp

Le
Bonjour,

En attendant le basculement en domaine qui demande une certaine organisation
j'ai un problème handicapant sur un poste où a été mémorisé un mot de passe
de connexion sur les ressources partagées du serveur, ce qui fait que
l'utilisateur n'a qu'un accès très restreint sous son nom d'utilisateur
Windows où sont installé et configuré tout ses fichiers et programmes.

En workgroup lors de la connexion à une ressource partagé au serveur, ce
dernier demande un nom d'utilisateur et un mot de passe.
Dans cette fenêtre il y a une coche mémorisation du mot de passe.
Où le système stocke t il cette information, plus dans les fichiers pwl, je
n'ai pas trouvé dans la base de registre.

En cherchant sur internet j'ai pensé connecté un lecteur réseau à la
ressource la plus important, là il y a une coche se connecter sous un nom
différent, houra me suis je dis ! Ben non messages d'erreur :
1) le dossier réseau spécifié est actuellement mappé avec un nom
d'utilisateur et un mot de passe différents. Supprimez toutes les connexions
précèdentes au serveur ou à la ressource partagée et recommencez
puis
2) plusieurs connexions à un serveur ou à une ressource partagée par le même
utilisateur

j'ai tenté sur de bons conseil aussi NET USE * /ALL

le matériel que constitue les messages d'erreur m'ont envoyé sur une liste
de note de la kb :
http://support.microsoft.com/kb/938120/fr
http://support.microsoft.com/kb/812793/fr
http://support.microsoft.com/kb/106211/
http://support.microsoft.com/kb/173199/
http://support.microsoft.com/kb/173011/fr
http://support.microsoft.com/kb/183366/
http://support.microsoft.com/kb/824198/
Peine perdue je n'entrevois toujours pas de solution pour me libérer du
cochage intempestif !

Merci de toute contribution.
Merci d'avoir lu jusque là.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Claude BELLAMY
Le #17813091
<@pollo> a écrit dans le message de
news:%
Bonjour,

En attendant le basculement en domaine qui demande une certaine
organisation
j'ai un problème handicapant sur un poste où a été mémorisé un mot de
passe
de connexion sur les ressources partagées du serveur, ce qui fait que
l'utilisateur n'a qu'un accès très restreint sous son nom d'utilisateur
Windows où sont installé et configuré tout ses fichiers et programmes.

En workgroup lors de la connexion à une ressource partagé au serveur, ce
dernier demande un nom d'utilisateur et un mot de passe.
Dans cette fenêtre il y a une coche mémorisation du mot de passe.
Où le système stocke t il cette information, plus dans les fichiers pwl,
je
n'ai pas trouvé dans la base de registre.



C'est (en partie) dans la clef
HKCUNetworkX
"X" étant la lettre locale du montage réseau concerné

L'entrée "RemotePath", de type REG_SZ contient le chemin UNC du montage
(p.ex. \GRANDBASSAMM)

L'entrée "ConnectionType" de type REG_DWORD contient le type de connexion
0x1 -> disque
0x2 -> imprimante

L'entrée "DeferFlags" de type REG_DWORD définit la "persistence" de la
connexion
(La connexion est rétablie lors du démarrage ou seulement à la demande)
Je n'ai pas trouvé de doc là dessus.
A priori (à vérifier, car ce sont des déductions expérimentales) :
0x0 -> connexion non persistente
0x1 -> connexion persistente avec nom de compte différent
0x4 -> connexion persistente avec même nom de compte

L'entrée "ProviderName" de type REG_SZ contient le nom du fournisseur réseau
(en principe "Réseau Microsoft Windows")

L'entrée "ProviderType" de type REG_DWORD contient le type de fournisseur
réseau
Je ne connais que 0x20000 pour "Réseau Microsoft Windows"

Si la connexion se fait avec le compte en cours (même username et password),
l'entrée "UserName" est de type REG_DWORD et vaut 0

Si la connexion se fait avec un autre compte
l'entrée "UserName" est de type REG_SZ et contient le nom de ce compte
Quant au password, il est ... ailleurs !


En cherchant sur internet j'ai pensé connecté un lecteur réseau à la
ressource la plus important, là il y a une coche se connecter sous un nom
différent, houra me suis je dis ! Ben non messages d'erreur :
1) le dossier réseau spécifié est actuellement mappé avec un nom
d'utilisateur et un mot de passe différents. Supprimez toutes les
connexions
précèdentes au serveur ou à la ressource partagée et recommencez
puis
2) plusieurs connexions à un serveur ou à une ressource partagée par le
même
utilisateur



Et oui !
C'est comme çà, c'est d'ailleurs très facilitant le transit intestinal,
Windows (toutes versions) REFUSE d'établir 2 connexions simultanées entre
deux ordinateurs avec des noms de compte différents !


Peine perdue je n'entrevois toujours pas de solution pour me libérer du
cochage intempestif !



Je ne comprends pas bien ton problème ...
Tu veux supprimer la "persistence" de connexion avec le compte et password
actuel ?
C'est cela ?
Si oui, la solution est très simple !

Il suffit de supprimer la dite connexion par une commande :
NET USE x: /DELETE
"X:" étant le nom du montage
ou
NET USE \nom-du-serveurnom-du-partage /DELETE

puis recréer éventuellement cette connexion avec un autre compte ...


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org
Le #17815401
Bonsoir à tous, bonsoir et merci à toi Jean-Claude BELLAMY,

Tu veux supprimer la "persistence" de connexion avec le compte et password
actuel ?


Oui parce que la solution que j'ai trouvé pour l'utilisateur c'est justement
d'en créer un autre d'utilisateur "utilisateur2" pour qu'il aille se
connecter sur son appli sur le serveur. Mais le problème c'est que toute sa
config autre de travail est dans "utilisateur1". Bien sur on pourrait tout
reconfigurer sous "utilisateur1" mais bon beaucoup de travail pour une
malheureuse coche non ? et en plus en attendant de repasser pour le domaine.


NET USE x: /DELETE


j'ai essayé pas mal de combinaison de net use ... /DELETE mais aucune ne
fonctionne c'est peut être d'ailleurs parce que l'utilisateur enregistré n'a
sans doute droit à presque rien !
De plus il n'y a pas de mapping sur le serveur (pas de domaine donc pas de
palluchage de mapping à la main sur chaque poste, heureusement que les
utilisateurs n'en ont pas créé à leur imagination des différentes !!).

C'est juste que la connexion à \SERVEURREPERTOIRE1 à été connecté la
première fois avec UtilisateurPeuDePouvoir et SonMotDePasse et surtout coché
de conserver ce f.. choix.

Opération sans doute répété sur \SERVEURREPERTOIRE2 ... ou alors une seul
connexion mémorise le profil de l'utilisateur pour la connexion à SERVEUR !?

Mais bref demain je regarde la clé HKCUNetwork mais comme je n'ai pas de
lettre de connexion je ne vois pas comment ça va se présenter.

En tout cas je te remercie et tiendrais au courant de cette exploration même
si je crains que je ne reviendrais donc pas avec la solution définitive.

Merci d'avoir lu jusque là.








"Jean-Claude BELLAMY" message de news:
<@pollo> a écrit dans le message de
news:%
Bonjour,

En attendant le basculement en domaine qui demande une certaine
organisation
j'ai un problème handicapant sur un poste où a été mémorisé un mot de
passe
de connexion sur les ressources partagées du serveur, ce qui fait que
l'utilisateur n'a qu'un accès très restreint sous son nom d'utilisateur
Windows où sont installé et configuré tout ses fichiers et programmes.

En workgroup lors de la connexion à une ressource partagé au serveur, ce
dernier demande un nom d'utilisateur et un mot de passe.
Dans cette fenêtre il y a une coche mémorisation du mot de passe.
Où le système stocke t il cette information, plus dans les fichiers pwl,
je
n'ai pas trouvé dans la base de registre.



C'est (en partie) dans la clef
HKCUNetworkX
"X" étant la lettre locale du montage réseau concerné

L'entrée "RemotePath", de type REG_SZ contient le chemin UNC du montage
(p.ex. \GRANDBASSAMM)

L'entrée "ConnectionType" de type REG_DWORD contient le type de connexion
0x1 -> disque
0x2 -> imprimante

L'entrée "DeferFlags" de type REG_DWORD définit la "persistence" de la
connexion
(La connexion est rétablie lors du démarrage ou seulement à la demande)
Je n'ai pas trouvé de doc là dessus.
A priori (à vérifier, car ce sont des déductions expérimentales) :
0x0 -> connexion non persistente
0x1 -> connexion persistente avec nom de compte différent
0x4 -> connexion persistente avec même nom de compte

L'entrée "ProviderName" de type REG_SZ contient le nom du fournisseur
réseau
(en principe "Réseau Microsoft Windows")

L'entrée "ProviderType" de type REG_DWORD contient le type de fournisseur
réseau
Je ne connais que 0x20000 pour "Réseau Microsoft Windows"

Si la connexion se fait avec le compte en cours (même username et
password),
l'entrée "UserName" est de type REG_DWORD et vaut 0

Si la connexion se fait avec un autre compte
l'entrée "UserName" est de type REG_SZ et contient le nom de ce compte
Quant au password, il est ... ailleurs !


En cherchant sur internet j'ai pensé connecté un lecteur réseau à la
ressource la plus important, là il y a une coche se connecter sous un nom
différent, houra me suis je dis ! Ben non messages d'erreur :
1) le dossier réseau spécifié est actuellement mappé avec un nom
d'utilisateur et un mot de passe différents. Supprimez toutes les
connexions
précèdentes au serveur ou à la ressource partagée et recommencez
puis
2) plusieurs connexions à un serveur ou à une ressource partagée par le
même
utilisateur



Et oui !
C'est comme çà, c'est d'ailleurs très facilitant le transit intestinal,
Windows (toutes versions) REFUSE d'établir 2 connexions simultanées entre
deux ordinateurs avec des noms de compte différents !


Peine perdue je n'entrevois toujours pas de solution pour me libérer du
cochage intempestif !



Je ne comprends pas bien ton problème ...
Tu veux supprimer la "persistence" de connexion avec le compte et password
actuel ?
C'est cela ?
Si oui, la solution est très simple !

Il suffit de supprimer la dite connexion par une commande :
NET USE x: /DELETE
"X:" étant le nom du montage
ou
NET USE \nom-du-serveurnom-du-partage /DELETE

puis recréer éventuellement cette connexion avec un autre compte ...


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org


Jean-Claude BELLAMY
Le #17817081
<@pollo> a écrit dans le message de
news:
Bonsoir à tous, bonsoir et merci à toi Jean-Claude BELLAMY,

Tu veux supprimer la "persistence" de connexion avec le compte et
password actuel ?


Oui parce que la solution que j'ai trouvé pour l'utilisateur c'est
justement d'en créer un autre d'utilisateur "utilisateur2" pour qu'il
aille se connecter sur son appli sur le serveur. Mais le problème c'est
que toute sa config autre de travail est dans "utilisateur1". Bien sur on
pourrait tout reconfigurer sous "utilisateur1" mais bon beaucoup de
travail pour une malheureuse coche non ? et en plus en attendant de
repasser pour le domaine.


NET USE x: /DELETE


j'ai essayé pas mal de combinaison de net use ... /DELETE mais aucune ne
fonctionne c'est peut être d'ailleurs parce que l'utilisateur enregistré
n'a sans doute droit à presque rien !


Quelle erreur as-tu ?
"Acces denied" ou équivalent ?
Il faut exécuter cette commande sous un compte admin !
Passe par un "runas" avec le paramètre "/env" (pour conserver
l'environnement de l'utilisateur initial)

De plus il n'y a pas de mapping sur le serveur (pas de domaine donc pas de
palluchage de mapping à la main sur chaque poste, heureusement que les
utilisateurs n'en ont pas créé à leur imagination des différentes !!).

C'est juste que la connexion à \SERVEURREPERTOIRE1 à été connecté la
première fois avec UtilisateurPeuDePouvoir et SonMotDePasse et surtout
coché de conserver ce f.. choix.



Je t'ai indiqué que la syntaxe pouvait être également
NET USE \nom-du-serveurnom-du-partage /DELETE

Donc sous le compte en question, exécute cette commande :
RUNAS /env /user:Administrateur "NET USE \SERVEURREPERTOIRE1 /DELETE"

--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org
Le #17824061
Bonsoir à tous, bonsoir et merci à toi Jean-Claude BELLAMY,

Alors, la clé HKCUNetwork est effectivement vide sur le poste en question
!

Quelle erreur as-tu ?
"Acces denied" ou équivalent ?


Non pas de message d'erreur, juste un message (je ne sais plus lequel en
détail) indiquant que la commande c'est terminée normalement...
D'ailleurs en relançant le système dit que la liste est vide sur un "NET USE
* /DELETE"

Je t'ai indiqué que la syntaxe pouvait être également
NET USE \nom-du-serveurnom-du-partage /DELETE


Oui, il me semble que dans le cadre de ce que je disais précèdement
j'ai essayé pas mal de combinaison de net use ... /DELETE




j'avais aussi essayé cette combinaison mais je reregarde demain.


Il faut exécuter cette commande sous un compte admin !


Oui il me semble que le compte en question est administrateur de son
poste...

Donc sous le compte en question, exécute cette commande :
RUNAS /env /user:Administrateur "NET USE \SERVEURREPERTOIRE1
/DELETE"


Ce cumul de commande est très impressionnant et je viens de la tester sur un
poste à la maison et le message d'erreur me donne des idées,
Je teste donc aussi demain.

Merci beaucoup encore !
Merci d'avoir lu jusque là.




"Jean-Claude BELLAMY" message de news: %
<@pollo> a écrit dans le message de
news:
Bonsoir à tous, bonsoir et merci à toi Jean-Claude BELLAMY,

Tu veux supprimer la "persistence" de connexion avec le compte et
password actuel ?


Oui parce que la solution que j'ai trouvé pour l'utilisateur c'est
justement d'en créer un autre d'utilisateur "utilisateur2" pour qu'il
aille se connecter sur son appli sur le serveur. Mais le problème c'est
que toute sa config autre de travail est dans "utilisateur1". Bien sur on
pourrait tout reconfigurer sous "utilisateur1" mais bon beaucoup de
travail pour une malheureuse coche non ? et en plus en attendant de
repasser pour le domaine.


NET USE x: /DELETE


j'ai essayé pas mal de combinaison de net use ... /DELETE mais aucune ne
fonctionne c'est peut être d'ailleurs parce que l'utilisateur enregistré
n'a sans doute droit à presque rien !


Quelle erreur as-tu ?
"Acces denied" ou équivalent ?
Il faut exécuter cette commande sous un compte admin !
Passe par un "runas" avec le paramètre "/env" (pour conserver
l'environnement de l'utilisateur initial)

De plus il n'y a pas de mapping sur le serveur (pas de domaine donc pas
de palluchage de mapping à la main sur chaque poste, heureusement que les
utilisateurs n'en ont pas créé à leur imagination des différentes !!).

C'est juste que la connexion à \SERVEURREPERTOIRE1 à été connecté la
première fois avec UtilisateurPeuDePouvoir et SonMotDePasse et surtout
coché de conserver ce f.. choix.



Je t'ai indiqué que la syntaxe pouvait être également
NET USE \nom-du-serveurnom-du-partage /DELETE

Donc sous le compte en question, exécute cette commande :
RUNAS /env /user:Administrateur "NET USE \SERVEURREPERTOIRE1
/DELETE"

--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org



Le #17835411
Bonsoir à tous,

J'avais promis un retour.

Bon j'avoue que je ne comprends pas très bien, j'ai fait de nombreux tests
et j'ai l'intime conviction que tous les NET USE que je peux faire ne sont
que sur les objets mappés si j'utilise le bon terme, c'est à dire j: =
\SERVEURREPERTOIRE1

Or sur le poste en question, et sous le nom d'utilisateur avec le problème,
il n'y a pas de disque mapper.

Seulement il a stocké un nom d'utilisateur du serveur et non de la cession
quelque part avec son mot de passe ce qui fait que dans la cession d
l'utilisateur a été stocké ce mauvais profil à cause de la fameuse
proposition de coche.

Mais bon je me trompe peut être. En tout cas j'ai même essayé de copier
coller la partie de HKCUNetwork de l'utilisateur pour qui la connexion au
serveur est bonne, avec un lecteur G: que j'avais créer pour test. J'étais
pas très convaincu, mais bon, j'ai bien récupérer le lecteur G: sous
l'utilisateur à problème, mais.... je n'avais pas le droit de consulter son
contenu accès refusé voir l'adminstrateur réseau...
Là le NET USE /DELETE (*/ou spécifique g:) fonctionne à merveille ils
m'indiquent que j'ai un lecteur G: et qu'ils vont me le supprimer et me le
supprime ! Ce qui renforce ma conviction.

Mais bon... je crois que j'ai, ou mal expliqué, ou suis incapable
d'appliquer ce que je crois avoir compris.
En tout cas merci.

Merci d'avoir lu jusque là.


<@pollo> a écrit dans le message de news:
%
Bonsoir à tous, bonsoir et merci à toi Jean-Claude BELLAMY,

Alors, la clé HKCUNetwork est effectivement vide sur le poste en
question !

Quelle erreur as-tu ?
"Acces denied" ou équivalent ?


Non pas de message d'erreur, juste un message (je ne sais plus lequel en
détail) indiquant que la commande c'est terminée normalement...
D'ailleurs en relançant le système dit que la liste est vide sur un "NET
USE * /DELETE"

Je t'ai indiqué que la syntaxe pouvait être également
NET USE \nom-du-serveurnom-du-partage /DELETE


Oui, il me semble que dans le cadre de ce que je disais précèdement
j'ai essayé pas mal de combinaison de net use ... /DELETE




j'avais aussi essayé cette combinaison mais je reregarde demain.


Il faut exécuter cette commande sous un compte admin !


Oui il me semble que le compte en question est administrateur de son
poste...

Donc sous le compte en question, exécute cette commande :
RUNAS /env /user:Administrateur "NET USE \SERVEURREPERTOIRE1
/DELETE"


Ce cumul de commande est très impressionnant et je viens de la tester sur
un poste à la maison et le message d'erreur me donne des idées,
Je teste donc aussi demain.

Merci beaucoup encore !
Merci d'avoir lu jusque là.




"Jean-Claude BELLAMY" message de news: %
<@pollo> a écrit dans le message de
news:
Bonsoir à tous, bonsoir et merci à toi Jean-Claude BELLAMY,

Tu veux supprimer la "persistence" de connexion avec le compte et
password actuel ?


Oui parce que la solution que j'ai trouvé pour l'utilisateur c'est
justement d'en créer un autre d'utilisateur "utilisateur2" pour qu'il
aille se connecter sur son appli sur le serveur. Mais le problème c'est
que toute sa config autre de travail est dans "utilisateur1". Bien sur
on pourrait tout reconfigurer sous "utilisateur1" mais bon beaucoup de
travail pour une malheureuse coche non ? et en plus en attendant de
repasser pour le domaine.


NET USE x: /DELETE


j'ai essayé pas mal de combinaison de net use ... /DELETE mais aucune ne
fonctionne c'est peut être d'ailleurs parce que l'utilisateur enregistré
n'a sans doute droit à presque rien !


Quelle erreur as-tu ?
"Acces denied" ou équivalent ?
Il faut exécuter cette commande sous un compte admin !
Passe par un "runas" avec le paramètre "/env" (pour conserver
l'environnement de l'utilisateur initial)

De plus il n'y a pas de mapping sur le serveur (pas de domaine donc pas
de palluchage de mapping à la main sur chaque poste, heureusement que
les utilisateurs n'en ont pas créé à leur imagination des différentes
!!).

C'est juste que la connexion à \SERVEURREPERTOIRE1 à été connecté la
première fois avec UtilisateurPeuDePouvoir et SonMotDePasse et surtout
coché de conserver ce f.. choix.



Je t'ai indiqué que la syntaxe pouvait être également
NET USE \nom-du-serveurnom-du-partage /DELETE

Donc sous le compte en question, exécute cette commande :
RUNAS /env /user:Administrateur "NET USE \SERVEURREPERTOIRE1
/DELETE"

--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org







Publicité
Poster une réponse
Anonyme