Message d'erreur en lançant un état.

Le
Richard_35
Bonjour à tous,

Sous Access 2000 (Office 2000 SP3), lors du lancement d'un état, un seul
utilisateur voit apparaître le message suivant :
"L'expression "Sur Click" entrée comme paramètre de la propriété de type
événelent est à l'origine d'une erreur. Fonction non disponible dans les
expressions dans l'expression 'IIf(Right([champ],19)="xxx","yyy","zzz")'.
* Le résultat de l'expression n'est pas le nom d'une macro, le nom d'une
fonction définie par l'utilisateur ou [Event Procedure].
* Une erreur a peut-être été commise lors de l'évaluation d'une fonction,
d'un événement ou d'une macro."

Je précise qu'il s'agit d'une base .mde appelée par l'ensemble des
utilisateurs, mais seul celui-ci voit apparaître ce message et, donc,
impossible, pour lui, de générer son état (il est obligé de le faire sur un
autre PC).

J'ai désinstallé Access sur le PC à problème (vu que la base est .mde) :
toujours le même résultat.

Je vous remercie d'avance de vos conseils,
Richard.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fabien
Le #19018841
Richard_35 a écrit :
Bonjour à tous,

Sous Access 2000 (Office 2000 SP3), lors du lancement d'un état, un seul
utilisateur voit apparaître le message suivant :
"L'expression "Sur Click" entrée comme paramètre de la propriété de type
événelent est à l'origine d'une erreur. Fonction non disponible dans les
expressions dans l'expression 'IIf(Right([champ],19)="xxx","yyy","zzz")'.
* Le résultat de l'expression n'est pas le nom d'une macro, le nom d'une
fonction définie par l'utilisateur ou [Event Procedure].
* Une erreur a peut-être été commise lors de l'évaluation d'une fonction,
d'un événement ou d'une macro."

Je précise qu'il s'agit d'une base .mde appelée par l'ensemble des
utilisateurs, mais seul celui-ci voit apparaître ce message et, donc,
impossible, pour lui, de générer son état (il est obligé de le faire sur un
autre PC).

J'ai désinstallé Access sur le PC à problème (vu que la base est .mde) :
toujours le même résultat.

Je vous remercie d'avance de vos conseils,
Richard.


Salut Richard,
Ca ressemble à une bibliothéque manquante ... mais normalement dans un
MDE le code étant 'compilé'.. Voir peut-être au niveau de la MDB d'origine.
@+
Richard_35
Le #19019491
Bonjour Fabien,

Merci de ta réponse.

Je ne comprends pas : le .mdb d'origine est le même pour tous ceux qui
utilisent le .mde (qui est sur un serveur). Et seul cet utilisateur est
concerné par ce problème.

Si tu as une autre piste, c'est avec plaisir...
Merci d'avance de tes conseils,
Richard.

"Fabien" a écrit :

Richard_35 a écrit :
> Bonjour à tous,
>
> Sous Access 2000 (Office 2000 SP3), lors du lancement d'un état, un seul
> utilisateur voit apparaître le message suivant :
> "L'expression "Sur Click" entrée comme paramètre de la propriété de type
> événelent est à l'origine d'une erreur. Fonction non disponible dans les
> expressions dans l'expression 'IIf(Right([champ],19)="xxx","yyy","zzz")'.
> * Le résultat de l'expression n'est pas le nom d'une macro, le nom d'une
> fonction définie par l'utilisateur ou [Event Procedure].
> * Une erreur a peut-être été commise lors de l'évaluation d'une fonction,
> d'un événement ou d'une macro."
>
> Je précise qu'il s'agit d'une base .mde appelée par l'ensemble des
> utilisateurs, mais seul celui-ci voit apparaître ce message et, donc,
> impossible, pour lui, de générer son état (il est obligé de le faire sur un
> autre PC).
>
> J'ai désinstallé Access sur le PC à problème (vu que la base est .mde) :
> toujours le même résultat.
>
> Je vous remercie d'avance de vos conseils,
> Richard.
Salut Richard,
Ca ressemble à une bibliothéque manquante ... mais normalement dans un
MDE le code étant 'compilé'.. Voir peut-être au niveau de la MDB d'origine.
@+



Michel__D
Le #19022881
Bonjour,

Je pense qu'il faudrait oeuvrer sur la configuration du micro qui ne
fonctionne pas.

Tu signale que tu as désinstallé Access, réinstalle Access pour voir
si cela régle le problème et si c'est le cas cela pourrait vouloir
dire que certains composant/dll sont déenregistré lors de la
désinstallation d'access.

PS:Si la base fonctionne sur tous les autres postes, moi je ne
toucherais pas à la base.

Richard_35 a écrit :
Bonjour Pierre,

Non, pas tous : les anciens PC avaient Access, et depuis que nous utilisons
le run time, les nouveaux PC n'ont plus Access. Le PC à problème est un
ancien PC, mais j'ai désinstallé Access pour le rendre comme les nouveaux.
C'est pour cela que je ne m'explique pas pourquoi il continue à planter.

Je pensais ré-installer Access sur ce PC, appeler la base .mdb en
développement (shift), vérifier les références et décocher les éventuelles
manquantes. Mais si je le fais, cela ne posera-t-il pas de problème sur les
autres PC qui fonctionnent correctement ?

Merci de vos conseils,
Richard.

Merci de vos conseils,
Richard.

"Pierre CFI" a écrit :

bonjour
tes pc sont tous configurés de la meme maniére ??
Pierre


"Richard_35" de news:
Bonjour Fabien,

Merci de ta réponse.

Je ne comprends pas : le .mdb d'origine est le même pour tous ceux qui
utilisent le .mde (qui est sur un serveur). Et seul cet utilisateur est
concerné par ce problème.

Si tu as une autre piste, c'est avec plaisir...
Merci d'avance de tes conseils,
Richard.

"Fabien" a écrit :

Richard_35 a écrit :
Bonjour à tous,

Sous Access 2000 (Office 2000 SP3), lors du lancement d'un état, un
seul
utilisateur voit apparaître le message suivant :
"L'expression "Sur Click" entrée comme paramètre de la propriété de
type
événelent est à l'origine d'une erreur. Fonction non disponible dans
les
expressions dans l'expression
'IIf(Right([champ],19)="xxx","yyy","zzz")'.
* Le résultat de l'expression n'est pas le nom d'une macro, le nom
d'une
fonction définie par l'utilisateur ou [Event Procedure].
* Une erreur a peut-être été commise lors de l'évaluation d'une
fonction,
d'un événement ou d'une macro."

Je précise qu'il s'agit d'une base .mde appelée par l'ensemble des
utilisateurs, mais seul celui-ci voit apparaître ce message et, donc,
impossible, pour lui, de générer son état (il est obligé de le faire
sur un
autre PC).

J'ai désinstallé Access sur le PC à problème (vu que la base est .mde)
:
toujours le même résultat.

Je vous remercie d'avance de vos conseils,
Richard.


Salut Richard,
Ca ressemble à une bibliothéque manquante ... mais normalement dans un
MDE le code étant 'compilé'.. Voir peut-être au niveau de la MDB
d'origine.
@+










Richard_35
Le #19043081
Bonjour Michel,

C'était bien un problème de référence manquante uniquement sur le PC en
question.
Merci à tous.

Richard.

"Michel__D" a écrit :

Bonjour,

Je pense qu'il faudrait oeuvrer sur la configuration du micro qui ne
fonctionne pas.

Tu signale que tu as désinstallé Access, réinstalle Access pour voir
si cela régle le problème et si c'est le cas cela pourrait vouloir
dire que certains composant/dll sont déenregistré lors de la
désinstallation d'access.

PS:Si la base fonctionne sur tous les autres postes, moi je ne
toucherais pas à la base.

Richard_35 a écrit :
> Bonjour Pierre,
>
> Non, pas tous : les anciens PC avaient Access, et depuis que nous utilisons
> le run time, les nouveaux PC n'ont plus Access. Le PC à problème est un
> ancien PC, mais j'ai désinstallé Access pour le rendre comme les nouveaux.
> C'est pour cela que je ne m'explique pas pourquoi il continue à planter.
>
> Je pensais ré-installer Access sur ce PC, appeler la base .mdb en
> développement (shift), vérifier les références et décocher les éventuelles
> manquantes. Mais si je le fais, cela ne posera-t-il pas de problème sur les
> autres PC qui fonctionnent correctement ?
>
> Merci de vos conseils,
> Richard.
>
> Merci de vos conseils,
> Richard.
>
> "Pierre CFI" a écrit :
>
>> bonjour
>> tes pc sont tous configurés de la meme maniére ??
>> Pierre
>>
>>
>> "Richard_35" >> de news:
>>> Bonjour Fabien,
>>>
>>> Merci de ta réponse.
>>>
>>> Je ne comprends pas : le .mdb d'origine est le même pour tous ceux qui
>>> utilisent le .mde (qui est sur un serveur). Et seul cet utilisateur est
>>> concerné par ce problème.
>>>
>>> Si tu as une autre piste, c'est avec plaisir...
>>> Merci d'avance de tes conseils,
>>> Richard.
>>>
>>> "Fabien" a écrit :
>>>
>>>> Richard_35 a écrit :
>>>>> Bonjour à tous,
>>>>>
>>>>> Sous Access 2000 (Office 2000 SP3), lors du lancement d'un état, un
>>>>> seul
>>>>> utilisateur voit apparaître le message suivant :
>>>>> "L'expression "Sur Click" entrée comme paramètre de la propriété de
>>>>> type
>>>>> événelent est à l'origine d'une erreur. Fonction non disponible dans
>>>>> les
>>>>> expressions dans l'expression
>>>>> 'IIf(Right([champ],19)="xxx","yyy","zzz")'.
>>>>> * Le résultat de l'expression n'est pas le nom d'une macro, le nom
>>>>> d'une
>>>>> fonction définie par l'utilisateur ou [Event Procedure].
>>>>> * Une erreur a peut-être été commise lors de l'évaluation d'une
>>>>> fonction,
>>>>> d'un événement ou d'une macro."
>>>>>
>>>>> Je précise qu'il s'agit d'une base .mde appelée par l'ensemble des
>>>>> utilisateurs, mais seul celui-ci voit apparaître ce message et, donc,
>>>>> impossible, pour lui, de générer son état (il est obligé de le faire
>>>>> sur un
>>>>> autre PC).
>>>>>
>>>>> J'ai désinstallé Access sur le PC à problème (vu que la base est .mde)
>>>>> :
>>>>> toujours le même résultat.
>>>>>
>>>>> Je vous remercie d'avance de vos conseils,
>>>>> Richard.
>>>> Salut Richard,
>>>> Ca ressemble à une bibliothéque manquante ... mais normalement dans un
>>>> MDE le code étant 'compilé'.. Voir peut-être au niveau de la MDB
>>>> d'origine.
>>>> @+
>>>>
>>



Richard_35
Le #19043071
Bonjour à tous,

C'était bien un problème de référence uniquement sur le PC en question...
bizarre.

Merci à tous.
Richard.


"Michel__D" a écrit :

Bonjour,

Je pense qu'il faudrait oeuvrer sur la configuration du micro qui ne
fonctionne pas.

Tu signale que tu as désinstallé Access, réinstalle Access pour voir
si cela régle le problème et si c'est le cas cela pourrait vouloir
dire que certains composant/dll sont déenregistré lors de la
désinstallation d'access.

PS:Si la base fonctionne sur tous les autres postes, moi je ne
toucherais pas à la base.

Richard_35 a écrit :
> Bonjour Pierre,
>
> Non, pas tous : les anciens PC avaient Access, et depuis que nous utilisons
> le run time, les nouveaux PC n'ont plus Access. Le PC à problème est un
> ancien PC, mais j'ai désinstallé Access pour le rendre comme les nouveaux.
> C'est pour cela que je ne m'explique pas pourquoi il continue à planter.
>
> Je pensais ré-installer Access sur ce PC, appeler la base .mdb en
> développement (shift), vérifier les références et décocher les éventuelles
> manquantes. Mais si je le fais, cela ne posera-t-il pas de problème sur les
> autres PC qui fonctionnent correctement ?
>
> Merci de vos conseils,
> Richard.
>
> Merci de vos conseils,
> Richard.
>
> "Pierre CFI" a écrit :
>
>> bonjour
>> tes pc sont tous configurés de la meme maniére ??
>> Pierre
>>
>>
>> "Richard_35" >> de news:
>>> Bonjour Fabien,
>>>
>>> Merci de ta réponse.
>>>
>>> Je ne comprends pas : le .mdb d'origine est le même pour tous ceux qui
>>> utilisent le .mde (qui est sur un serveur). Et seul cet utilisateur est
>>> concerné par ce problème.
>>>
>>> Si tu as une autre piste, c'est avec plaisir...
>>> Merci d'avance de tes conseils,
>>> Richard.
>>>
>>> "Fabien" a écrit :
>>>
>>>> Richard_35 a écrit :
>>>>> Bonjour à tous,
>>>>>
>>>>> Sous Access 2000 (Office 2000 SP3), lors du lancement d'un état, un
>>>>> seul
>>>>> utilisateur voit apparaître le message suivant :
>>>>> "L'expression "Sur Click" entrée comme paramètre de la propriété de
>>>>> type
>>>>> événelent est à l'origine d'une erreur. Fonction non disponible dans
>>>>> les
>>>>> expressions dans l'expression
>>>>> 'IIf(Right([champ],19)="xxx","yyy","zzz")'.
>>>>> * Le résultat de l'expression n'est pas le nom d'une macro, le nom
>>>>> d'une
>>>>> fonction définie par l'utilisateur ou [Event Procedure].
>>>>> * Une erreur a peut-être été commise lors de l'évaluation d'une
>>>>> fonction,
>>>>> d'un événement ou d'une macro."
>>>>>
>>>>> Je précise qu'il s'agit d'une base .mde appelée par l'ensemble des
>>>>> utilisateurs, mais seul celui-ci voit apparaître ce message et, donc,
>>>>> impossible, pour lui, de générer son état (il est obligé de le faire
>>>>> sur un
>>>>> autre PC).
>>>>>
>>>>> J'ai désinstallé Access sur le PC à problème (vu que la base est .mde)
>>>>> :
>>>>> toujours le même résultat.
>>>>>
>>>>> Je vous remercie d'avance de vos conseils,
>>>>> Richard.
>>>> Salut Richard,
>>>> Ca ressemble à une bibliothéque manquante ... mais normalement dans un
>>>> MDE le code étant 'compilé'.. Voir peut-être au niveau de la MDB
>>>> d'origine.
>>>> @+
>>>>
>>



Publicité
Poster une réponse
Anonyme