Message systeme requete creation de table

Le
cadouxmi
Bonsoir ,

Sous access 2003, lorsque je lancais des requêtes de création de tables via
un Bouton , je codifiais au niveau de celui-ci :

"DoCmd.setwarnings False" afin de ne pas afficher le message système me
demandant confirmation de la table .
Puis ensuite

ma commande "DoCmd.runmacro "nom.macro" ou "DoCmd.openQuery "nom.requete".

Mais sous Access 2007 je ne peux plus codifier "DoCmd.setwarnings False" ,
les instructions de traitement via un bouton passent par une marco intégrée .
J'ai essayé de trouver une solution avant de faire appel à votre aide , mais
en vain.

Merci par avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
cadouxmi
Le #20006681
Merci de ne pas tenir compte de cette demande d'aide.
J'ai trouvé la solution , j'ai créé une base vide en access 2007 et importé
mes tables - requêtes et macros depuis access 2003 . Ensuite j'ai testé tous
mes boutons et cela fonctionne correctement .
Précédemment j'avais converti ma base 2003 en base 2007 .

Allez donc comprendre .... moi je renonce ....pour le moment

"cadouxmi" a écrit :

Bonsoir ,

Sous access 2003, lorsque je lancais des requêtes de création de tables via
un Bouton , je codifiais au niveau de celui-ci :

"DoCmd.setwarnings False" afin de ne pas afficher le message système me
demandant confirmation de la table .
Puis ensuite

ma commande "DoCmd.runmacro "nom.macro" ou "DoCmd.openQuery "nom.requete".

Mais sous Access 2007 je ne peux plus codifier "DoCmd.setwarnings False" ,
les instructions de traitement via un bouton passent par une marco intégrée .
J'ai essayé de trouver une solution avant de faire appel à votre aide , mais
en vain.

Merci par avance


Publicité
Poster une réponse
Anonyme