Migration de DC. Qu'est-ce qui cloche dans la procédure...

Le
llopht
Bonjour,

J'essaye de migrer un DC vers une nouvelle machine. J'ai donc effectuer
les tâches suivantes :

- J'ai installé le DNS sur mon nouveau DC et un serveur DHCP avec la
même configuration après l'avoir ajouté au domaine.
- J'ai ensuite fait un DCPromo et je l'ai ajouté un nouveau membre à la
forêt (après avoir mis à niveau le schéma, le précédent est en 2003).
- Puis par un NTSUtil je lui ai transféré tous les rôles FSMO.
- Je l'ai mis catalogue global via Sites et services Active Direcory et
je l'ai définit comme machine d'administration des licences. (faut il
enlever le catalogue global sur l'autre DC ?)
- J'ai ensuite vérifié que la réplication passait en effectuant un
répliqué maintenant, tout est ok.
- Enfin j'ai modifié le serveur DNS des connexions de mes deux serveurs
pour qu'ils pointent vers le nouveau DC.

Je renouvelle le bail d'une ou deux machines, parfait ça s'enregistre
sur le nouveau DHCP.

Je me dis donc que tout est bon. Je coupe donc (heureusement de nuit) le
précédent DC pour tester mais là les machines m'indiquent qu'elles ne
trouve pas le domaine

Qu'est ce qui ne va pas ? J'ai oublié quoi ?

Si je fais un replmon j'ai bien mes deux serveurs :

Mon ancien DC à TAPI3Directory que mon nouveau DC n'a pas (je suppose
que c'est lié au problème que j'ai plus bas).
Il y a une croix au niveau du serveur is the PDC for the domain.

Sur mon second DC j'ai bien tout les rôles FSMO.
J'ai aussi une croix au niveau du serveur is the PDC (est-ce normal ?)

Autre bizarrerie, le sysvol n'est pas partagé et il contient aucune
donnée J'ai trouvé un article en rapport que je pense utiliser pour
déterminer l'origine du problème mais si vous avez une explication
radicale je suis preneur.

Je ne sais pas si ça a un impact mais une des machines est en 2003x86
l'autre en 2008x64.

Merci pour vos conseils.

Jérôme
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry DEMAN [MVP]
Le #19869061
Bonsoir,

tant que le SYSVOL n'est pas partagé et avec un contenu correct, le 2ème DC
n'est pas fonctionnel !
=> Redémarrer le service NTFRS

Le mode 32/64 n'a aucune incidence.
Le catalogue global ne devrait pas avoir d'incidence (le positionner sur les
2 serveurs).

Il s'agirait plutôt d'un problème de résolution DNS, de zone non intégrée à
AD, etc... d'une mauvaise configuration TCPIP à ce niveau.

A+
--
Thierry DEMAN-BARCELÒ
http://www.faqexchange.info
Exchange MVP, MCITP Windows 2008, Exchange 2007, SQL 2008 (60 MCPs)
news:
Bonjour,

J'essaye de migrer un DC vers une nouvelle machine. J'ai donc effectuer
les tâches suivantes :

- J'ai installé le DNS sur mon nouveau DC et un serveur DHCP avec la même
configuration après l'avoir ajouté au domaine.
- J'ai ensuite fait un DCPromo et je l'ai ajouté un nouveau membre à la
forêt (après avoir mis à niveau le schéma, le précédent est en 2003).
- Puis par un NTSUtil je lui ai transféré tous les rôles FSMO.
- Je l'ai mis catalogue global via Sites et services Active Direcory et je
l'ai définit comme machine d'administration des licences. (faut il enlever
le catalogue global sur l'autre DC ?)
- J'ai ensuite vérifié que la réplication passait en effectuant un
répliqué maintenant, tout est ok.
- Enfin j'ai modifié le serveur DNS des connexions de mes deux serveurs
pour qu'ils pointent vers le nouveau DC.

Je renouvelle le bail d'une ou deux machines, parfait ça s'enregistre sur
le nouveau DHCP.

Je me dis donc que tout est bon. Je coupe donc (heureusement de nuit) le
précédent DC pour tester... mais là les machines m'indiquent qu'elles ne
trouve pas le domaine...

Qu'est ce qui ne va pas ? J'ai oublié quoi ?

Si je fais un replmon j'ai bien mes deux serveurs :

Mon ancien DC à TAPI3Directory que mon nouveau DC n'a pas (je suppose que
c'est lié au problème que j'ai plus bas).
Il y a une croix au niveau du serveur is the PDC for the domain.

Sur mon second DC j'ai bien tout les rôles FSMO.
J'ai aussi une croix au niveau du serveur is the PDC... (est-ce normal ?)

Autre bizarrerie, le sysvol n'est pas partagé... et il contient aucune
donnée... J'ai trouvé un article en rapport que je pense utiliser pour
déterminer l'origine du problème mais si vous avez une explication
radicale... je suis preneur.

Je ne sais pas si ça a un impact mais une des machines est en 2003x86
l'autre en 2008x64.

Merci pour vos conseils.

Jérôme


llopht
Le #19873721
> tant que le SYSVOL n'est pas partagé et avec un contenu correct, le 2ème DC
n'est pas fonctionnel !
=> Redémarrer le service NTFRS



Merci thierry je check donc le problème avec sysvol.

Le mode 32/64 n'a aucune incidence.



C'était plutôt le 2003 / 2008 mais vu qu'ils sont au même niveau
fonctionnel...

Le catalogue global ne devrait pas avoir d'incidence (le positionner sur les
2 serveurs).



C'est le cas.

Il s'agirait plutôt d'un problème de résolution DNS, de zone non intégrée à
AD, etc... d'une mauvaise configuration TCPIP à ce niveau.



Je pense pas, j'arrive à faire toutes les résolutions DNS par un lookup.

Je regarde et je viens dire ce qu'il en est...
llopht
Le #19874011
Donc j'ai redémarré NTFRS et je suis allé voir vois les évènements. J'ai
le message suivant :

Le service de réplication de fichiers (FRS) rencontre des problèmes lors
de l’activation de la réplication de anciendc.mondomaine.com vers
nouveaudc.mondomaine.com pour c:windowssysvoldomain en utilisant le
nom DNS anciendc.mondomaine.com. FRS va essayer à nouveau.
Voici quelques-unes des raisons de cet avertissement :

[1] FRS ne peut pas résoudre le nom DNS anciendc.mondomaine.com
correctement à partir de cet ordinateur.

---> J'arrive à le résoudre par un nslookup.

[2] FRS n’est pas en cours d’exécution sur anciendc.mondomaine.com.

---> Le service est bien en exécution.

[3] Les informations de topologie dans Active Directory pour ce
réplica n’ont pas été répliquées vers tous les contrôleurs de domaine.

---> J'ai exécuté la réplication avec succès à la main dés deux côtés et
relancé FRS même message. Une idée ?
Thierry DEMAN [MVP]
Le #19880371
Bonjour,

on en revient au problème initial... la résolution DNS!

Encore une fois, Nslookup n'est pas un élément suffisant/déterminant pour
dire que la résolution DNS est correcte pour AD.
Le fait que l'utilisateur connecté (avec ses droits), ne signifie pas
forcément que la machine (avec ses propres droits) peut résoudre
correctement les zones DNS spécifiques AD nécessaires (_msdcs,...)!

Sinon, tu peux charger l'utilitaire "FRSDIAG" pour obtenir plus
d'informations sur les problèmes rencontrés par ce service.

A+

--
Thierry DEMAN-BARCELÒ
http://www.faqexchange.info
Exchange MVP, MCITP Windows 2008, Exchange 2007, SQL 2008 (60 MCPs)
"llopht" news:
Donc j'ai redémarré NTFRS et je suis allé voir vois les évènements. J'ai
le message suivant :

Le service de réplication de fichiers (FRS) rencontre des problèmes lors
de l’activation de la réplication de anciendc.mondomaine.com vers
nouveaudc.mondomaine.com pour c:windowssysvoldomain en utilisant le nom
DNS anciendc.mondomaine.com. FRS va essayer à nouveau.
Voici quelques-unes des raisons de cet avertissement :

[1] FRS ne peut pas résoudre le nom DNS anciendc.mondomaine.com
correctement à partir de cet ordinateur.

---> J'arrive à le résoudre par un nslookup.

[2] FRS n’est pas en cours d’exécution sur anciendc.mondomaine.com.

---> Le service est bien en exécution.

[3] Les informations de topologie dans Active Directory pour ce réplica n’ont
pas été répliquées vers tous les contrôleurs de domaine.

---> J'ai exécuté la réplication avec succès à la main dés deux côtés et
relancé FRS même message. Une idée ?


llopht
Le #19880461
A titre d'info, maintenant les utilisateurs ne peuvent même plus se
logguer. Existe t'il une façon de transférer le catalogue glogal sur le
nouveau DC au moins pour pouvoir accéder au domaine ?

Visiblement après redémarrage de l'ancien DC, DNS ne trouve pas les
zones dans AD, il m'indique qu'il n'arrive pas à s'y connecter.
llopht
Le #19882371
Bon j'ai trancher dans le vif. J'ai copié le sysvol de l'ancien DC que
j'ai collé sur le nouveau, puis j'ai coupé l'ancienne machine et passé
la nouvelle en D4. A part des erreurs liés au fait qu'il y a toujours
l'ancien DC de référencé pas de problèmes...

Est-ce que je peux depromovoir l'ancien DC sans risquer de nouveaux
problèmes ?!
Publicité
Poster une réponse
Anonyme