Migration etch vers lenny

Le
Vincent H.
Bonjour la liste.

Je suis en train de migrer mon serveur sous etch vers lenny.

J'ai effectué un premier aptitude upgrade avec succès.
Le problème se pose maintenant avec le aptitude dist-upgrade :

[root][0]/boot/grub$ aptitude dist-upgrade
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets Fait
Lecture des descriptions de tâches Fait
Construction de la base de données des étiquettes Fait
Les paquets suivants sont CASSÉS :
libssp0
Les paquets suivants ne sont pas utilisés et vont être ENLEVÉS :
liba52-0.7.4 libart-2.0-2 libavcodec0d libavformat0d
libboost-regex1.33.1 libcrypto++5.2c2a libct3 libdc1394-13
libdirectfb-0.9-25 libflac7 libicu36 libjasper-1.701-1 libmagick9
libneon25 liboggflac3 libopenssl-ruby1.8 libperl5.8 librrd2
libtorrent9 libxss1 python-clearsilver ruby ruby1.8-dev
Les NOUVEAUX paquets suivants vont être automatiquement installés :
avahi-daemon avahi-utils bsd-mailx cpp-4.3 cups cups-bsd cups-client
cups-common cups-driver-gutenprint db4.6-util

sane-utils ttf-dejavu-core ttf-dejavu-extra wwwconfig-common
x-ttcidfont-conf x11-apps x11-session-utils x11-utils
x11-xfs-utils x11-xkb-utils x11-xserver-utils xauth xinit
Les paquets suivants seront automatiquement ENLEVÉS :
libarchive-tar-perl libdiscover1 libgems-ruby1.8 libgssapi2 libpci2
librpm4 linux-kernel-headers modutils php4-mysql
Les NOUVEAUX paquets suivants vont être installés :
avahi-daemon avahi-utils bsd-mailx cpp-4.3 cups cups-bsd cups-client
cups-common cups-driver-gutenprint db4.6-util

sane-utils ttf-dejavu-core ttf-dejavu-extra wwwconfig-common
x-ttcidfont-conf x11-apps x11-session-utils x11-utils
x11-xfs-utils x11-xkb-utils x11-xserver-utils xauth xinit
Les paquets suivants seront ENLEVÉS :
libarchive-tar-perl libdiscover1 libgems-ruby1.8 libgssapi2 libpci2
librpm4 linux-kernel-headers modutils php4-mysql
Les paquets suivants seront mis à jour :
apache2 apache2-mpm-prefork apache2-utils apache2.2-common apcupsd
apcupsd-cgi apt apt-utils aptitude aspell at base-passwd

xutils-dev zlib1g zlib1g-dev
Les paquets suivants sont RECOMMANDÉS mais ne seront pas installés :
aptitude-doc-cs aptitude-doc-en aptitude-doc-fi aptitude-doc-fr
aptitude-doc-ja bash-completion camlp4 dbus-x11 enscript

python-yenc resolvconf ttf-liberation uuid-runtime xml-core
464 paquets mis à jour, 173 nouvellement installés, 32 à enlever et 0
non mis à jour.
Il est nécessaire de télécharger 351Mo d'archives. Après dépaquet=
age,
228Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
libssp0: Dépend: gcc-4.1-base (= 4.1.1-21) mais 4.1.2-25 doit être =
installé.
Resolving dependencies
Les actions suivantes permettront de résoudre ces dépendances :

Supprimer les paquets suivants :
libssp0

Installer les paquets suivants :
enscript [1.6.4-13 (stable)]
ledit [2.00-4 (stable)]
libapache2-reload-perl [0.10-2 (stable)]
libbsd-resource-perl [1.28-1+b1 (stable)]
libterm-readkey-perl [2.30-4 (stable)]
openssh-blacklist-extra [0.4.1 (stable)]
python-tz [2008c-2 (stable)]
ttf-liberation [1.04.93-1 (stable)]

Conserver les paquets suivants dans leur version actuelle :
bash [3.1dfsg-8 (now)]
dbus [1.0.2-1+etch2 (now)]
hellanzb [0.10-1 (now)]
libuuid1 [1.39+1.40-WIP-2006.11.14+dfsg-2etch1 (now)]
ntpdate [1:4.2.2.p4+dfsg-2etch1 (now)]
nvi [1.79-25 (now)]

Laisser les dépendances suivantes non satisfaites :
hplip recommande hplip-gui
Le score est de -1357

Accepter cette solution ? [Y/n/q/?]


Donc j'ai un problème avec libssp0
Si j'essaye un :

[root][0]/boot/grub$ aptitude purge libssp0
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets Fait
Lecture des descriptions de tâches Fait
Construction de la base de données des étiquettes Fait
Les paquets suivants sont CASSÉS :
gcc-4.1

Le score est de -1001

Accepter cette solution ? [Y/n/q/?] q

J'ai farfouillé un peu partout et j'ai parcouru les notes de
publication (http://www.debian.org/releases/lenny/i386/release-notes/)
mais je n'ai pas trouvé de solution à mon problème…

Quelqu'un aurait-il une piste s'il vous plait?

Merci!

--
Vincent

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Vincent H.
Le #18885101
J'oubliais, mon sources.list :

deb http://security.debian.org/ lenny/updates main contrib non-free
deb http://ftp.de.debian.org/debian/ lenny main non-free
deb-src http://ftp.de.debian.org/debian/ lenny main non-free

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #18886191
Vincent H., jeudi 12 mars 2009, 12:35:44 CET

Bonjour la liste.



’jour,

[…]
[root][0]/boot/grub$ aptitude dist-upgrade
[…]
Les paquets suivants sont CASSÉS :
libssp0
[…]
Les actions suivantes permettront de résoudre ces dépendances  :

Supprimer les paquets suivants :
libssp0
[…]

Donc j'ai un problème avec libssp0
Si j'essaye un :

[root][0]/boot/grub$ aptitude purge libssp0
[…]
Les paquets suivants sont CASSÉS :
gcc-4.1
[…]
Quelqu'un aurait-il une piste s'il vous plait?



La version Etch de gcc-4.1 dépend de libssp0.
La version Lenny de gcc-4.1 n’en dépend plus.

Donc, quand tu essaies d'enlever libssp0 tout seul, ça casse le
gcc-4.1 installé, c’est-à-dire celui de Etch. En revanch e,
aptitude te propose une solution dans laquelle il enlève libssp0
et conserve gcc-4.1.

Tu as plusieurs solutions :
— accepter la solution d’aptitude (je n’ai pas bien compris
pourquoi tu ne l’as pas fait) ;
— mettre à jour gcc4.1 et enlever libssp0 dans la même op ération
(il y aura peut-être d’autres mises à jour nécessa ires…).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent H.
Le #18886511
> La version Etch de gcc-4.1 dépend de libssp0.
La version Lenny de gcc-4.1 n’en dépend plus.




Oui j'ai pu voir ça après mon mail.

Donc, quand tu essaies d'enlever libssp0 tout seul, ça casse le
gcc-4.1 installé, c’est-à-dire celui de Etch. En revanche,
aptitude te propose une solution dans laquelle il enlève libssp0
et conserve gcc-4.1.

Tu as plusieurs solutions :
— accepter la solution d’aptitude (je n’ai pas bien compris
pourquoi tu ne l’as pas fait) ;



J'ai eu peur.

— mettre à jour gcc4.1 et enlever libssp0 dans la même opération
(il y aura peut-être d’autres mises à jour nécessaires…).



Au final, j'ai pris mes cow powers et j'ai fini par suivre la solution
proposée par aptitude (après avoir regardé ce que donnait un aptitude
-s dist-upgrade) il y a maintenant quelques heures. On dirait que ça
roule pour gcc-4.1. En revanche je ne m'attendais pas à tant de
fichiers de configuration à vérifier. J'ai un peu perdu la connexion
vers mon mysql mais bon l'installation n'étant pas terminée je ne vais
pas tout de suite m'alarmer.

Merci pour ces informations!

Bonne soirée.
--
Vincent

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #18886881
Vincent H., jeudi 12 mars 2009, 17:31:12 CET
[…]
En revanche je ne m'attendais pas à tant de
fichiers de configuration à vérifier. […]



Un truc : conserver (papier, fichier, manger du poisson…) la
liste de fichiers de conf. qu’on a modifiés ou les paquets qu ’on
a trifouillé (et les raisons). Comme ça, une bonne partie de
ces vérifications est vite faite (= « vas-y, écrase  » :o).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme