Miltiples conditions

Le
ISOARD
Bonjour,

Comment compléter les conditions suivantes:
=SI(A29<>0;F28;SI(F29=0;F28;)) et ajouter SIF29ò8 alors afficher F28 si
B29 n'est pas vide (de texte).

Et deuxièmement si ce n'est pas trop abuser, je réitère une question déjà
posée:
Comment mettre en forme conditionnelle une ligne (A4G4) si la cellule de la
colonne G de cette ligne est non nulle et ce pour chaque ligne dont la
cellule G est non nulle

merci d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #22117981
Bonsoir,
ò8*((A29<>0)+(F29=0)+((F29ò8)*(B29<>"")))
devrait pouvoir convenir
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"ISOARD" news:
Bonjour,

Comment compléter les conditions suivantes:
=SI(A29<>0;F28;SI(F29=0;F28;)) et ajouter SIF29ò8 alors afficher F28 si
B29 n'est pas vide (de texte).

Et deuxièmement si ce n'est pas trop abuser, je réitère une question déjà
posée:
Comment mettre en forme conditionnelle une ligne (A4G4) si la cellule de
la
colonne G de cette ligne est non nulle et ce pour chaque ligne dont la
cellule G est non nulle

merci d'avance
Sam
Le #22118161
Bonjour,
=SI(F29=0;$F$28;SI(ET(F29=$F$28;ESTTEXTE(B29));$F$28;SI(A29<>0;$F$28;"")))
ou
=SI(ET(ESTTEXTE(B29);F29=$F$28);$F$28;SI(ET(A29=0;F29<>0);"";$F$28))
Cordialement
Michel dit "Sam"

"ISOARD"
Bonjour,

Comment compléter les conditions suivantes:
=SI(A29<>0;F28;SI(F29=0;F28;)) et ajouter SIF29ò8 alors afficher F28 si
B29 n'est pas vide (de texte).

Et deuxièmement si ce n'est pas trop abuser, je réitère une question déjà
posée:
Comment mettre en forme conditionnelle une ligne (A4G4) si la cellule de
la
colonne G de cette ligne est non nulle et ce pour chaque ligne dont la
cellule G est non nulle

merci d'avance
Sam
Le #22118151
Bonjour,
Quand 2 conditions sont réunies, tu vas avoir 2 x F28 !

Cordialement
Michel dit "Sam"

"Philippe.R"
Bonsoir,
ò8*((A29<>0)+(F29=0)+((F29ò8)*(B29<>"")))
devrait pouvoir convenir
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"ISOARD" news:
Bonjour,

Comment compléter les conditions suivantes:
=SI(A29<>0;F28;SI(F29=0;F28;)) et ajouter SIF29ò8 alors afficher F28 si
B29 n'est pas vide (de texte).

Et deuxièmement si ce n'est pas trop abuser, je réitère une question déjà
posée:
Comment mettre en forme conditionnelle une ligne (A4G4) si la cellule de
la
colonne G de cette ligne est non nulle et ce pour chaque ligne dont la
cellule G est non nulle

merci d'avance



Sam
Le #22118131
oups !
c'était pour Philippe

Cordialement
Michel dit "Sam"

"Sam" 4bed9142$0$2980$


Bonjour,
Quand 2 conditions sont réunies, tu vas avoir 2 x F28 !

Cordialement
Michel dit "Sam"

"Philippe.R"
Bonsoir,
ò8*((A29<>0)+(F29=0)+((F29ò8)*(B29<>"")))
devrait pouvoir convenir
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"ISOARD" news:
Bonjour,

Comment compléter les conditions suivantes:
=SI(A29<>0;F28;SI(F29=0;F28;)) et ajouter SIF29ò8 alors afficher F28
si
B29 n'est pas vide (de texte).

Et deuxièmement si ce n'est pas trop abuser, je réitère une question
déjà
posée:
Comment mettre en forme conditionnelle une ligne (A4G4) si la cellule de
la
colonne G de cette ligne est non nulle et ce pour chaque ligne dont la
cellule G est non nulle

merci d'avance







Philippe.R
Le #22118191
Bonsoir,

Petite correction :

ò8*(((A29<>0)*(F29<>F28))+((F29=0)*(F28<>0))+((F29ò8)*(B29<>"")))
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"Sam" news:4bed9142$0$2980$


Bonjour,
Quand 2 conditions sont réunies, tu vas avoir 2 x F28 !

Cordialement
Michel dit "Sam"

"Philippe.R"
Bonsoir,
ò8*((A29<>0)+(F29=0)+((F29ò8)*(B29<>"")))
devrait pouvoir convenir
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"ISOARD" news:
Bonjour,

Comment compléter les conditions suivantes:
=SI(A29<>0;F28;SI(F29=0;F28;)) et ajouter SIF29ò8 alors afficher F28
si
B29 n'est pas vide (de texte).

Et deuxièmement si ce n'est pas trop abuser, je réitère une question
déjà
posée:
Comment mettre en forme conditionnelle une ligne (A4G4) si la cellule de
la
colonne G de cette ligne est non nulle et ce pour chaque ligne dont la
cellule G est non nulle

merci d'avance







Philippe.R
Le #22118361
A nouveau :

ò8*(((A29<>0)*(F29<>F28))+((F29=0)*(A29=0)*(F28<>0))+((F29ò8)*(B29<>"")))

--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"Philippe.R" news:
Bonsoir,

Petite correction :

ò8*(((A29<>0)*(F29<>F28))+((F29=0)*(F28<>0))+((F29ò8)*(B29<>"")))
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"Sam" news:4bed9142$0$2980$


Bonjour,
Quand 2 conditions sont réunies, tu vas avoir 2 x F28 !

Cordialement
Michel dit "Sam"

"Philippe.R" news:
Bonsoir,
ò8*((A29<>0)+(F29=0)+((F29ò8)*(B29<>"")))
devrait pouvoir convenir
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"ISOARD" news:
Bonjour,

Comment compléter les conditions suivantes:
=SI(A29<>0;F28;SI(F29=0;F28;)) et ajouter SIF29ò8 alors afficher F28
si
B29 n'est pas vide (de texte).

Et deuxièmement si ce n'est pas trop abuser, je réitère une question
déjà
posée:
Comment mettre en forme conditionnelle une ligne (A4G4) si la cellule
de la
colonne G de cette ligne est non nulle et ce pour chaque ligne dont la
cellule G est non nulle

merci d'avance










Sam
Le #22118461
Bonjour Philippe,
je crois qu'il y a encore un pb mais c'est à ISOARD à repréciser les
conditions ou priorités

si A29<>0, il faudrait à mon avis F28 comme résultat

or dans le cas où F29 = F28 et B29 vide tu auras
F28 *(0 + 0 + 0) soit 0

Cordialement
Michel dit "Sam"

"Philippe.R" %
A nouveau :

ò8*(((A29<>0)*(F29<>F28))+((F29=0)*(A29=0)*(F28<>0))+((F29ò8)*(B29<>"")))

--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"Philippe.R" news:
Bonsoir,

Petite correction :

ò8*(((A29<>0)*(F29<>F28))+((F29=0)*(F28<>0))+((F29ò8)*(B29<>"")))
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"Sam" news:4bed9142$0$2980$


Bonjour,
Quand 2 conditions sont réunies, tu vas avoir 2 x F28 !

Cordialement
Michel dit "Sam"

"Philippe.R" news:
Bonsoir,
ò8*((A29<>0)+(F29=0)+((F29ò8)*(B29<>"")))
devrait pouvoir convenir
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"ISOARD" news:
Bonjour,

Comment compléter les conditions suivantes:
=SI(A29<>0;F28;SI(F29=0;F28;)) et ajouter SIF29ò8 alors afficher F28
si
B29 n'est pas vide (de texte).

Et deuxièmement si ce n'est pas trop abuser, je réitère une question
déjà
posée:
Comment mettre en forme conditionnelle une ligne (A4G4) si la cellule
de la
colonne G de cette ligne est non nulle et ce pour chaque ligne dont la
cellule G est non nulle

merci d'avance













Sam
Le #22118451
Bonjour, en faisant un petit ajout :
=$F$28*MIN(1;((A9<>0)+(F9=0)+((F9=$F$28)*(B9<>""))))
ça marcherait

nota : on obtient 0 et non "" quand les conditions ne sont pas remplies

Cordialement
Michel dit "Sam"

"Philippe.R"
Bonsoir,
ò8*((A29<>0)+(F29=0)+((F29ò8)*(B29<>"")))
devrait pouvoir convenir
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"ISOARD" news:
Bonjour,

Comment compléter les conditions suivantes:
=SI(A29<>0;F28;SI(F29=0;F28;)) et ajouter SIF29ò8 alors afficher F28 si
B29 n'est pas vide (de texte).

Et deuxièmement si ce n'est pas trop abuser, je réitère une question déjà
posée:
Comment mettre en forme conditionnelle une ligne (A4G4) si la cellule de
la
colonne G de cette ligne est non nulle et ce pour chaque ligne dont la
cellule G est non nulle

merci d'avance



ISOARD
Le #22119371
Bonjour à tous,

Désolé, j'ai du m'absenter hier.
Les formules ne marchent pas.
En réalité les conditions sont les suivantes:
Pour une ligne donnée 28 par exemple, la cellule G28 ne peut s'afficher que
si A29 est différent de 0 + si A29 à G29 = rien alors afficher également F28.
Mais si F29 = F28 n'afficher que F28 en G28 et pas plus bas(G29) car F29,
F30, etc. pourraient êtres identiques et leur correspondance en G29, G30,
etc. ne doit pas s'afficher

J'espère m'être fait comprendre...



"Sam" a écrit :


Bonjour,
=SI(F29=0;$F$28;SI(ET(F29=$F$28;ESTTEXTE(B29));$F$28;SI(A29<>0;$F$28;"")))
ou
=SI(ET(ESTTEXTE(B29);F29=$F$28);$F$28;SI(ET(A29=0;F29<>0);"";$F$28))
Cordialement
Michel dit "Sam"

"ISOARD"
> Bonjour,
>
> Comment compléter les conditions suivantes:
> =SI(A29<>0;F28;SI(F29=0;F28;)) et ajouter SIF29ò8 alors afficher F28 si
> B29 n'est pas vide (de texte).
>
> Et deuxièmement si ce n'est pas trop abuser, je réitère une question déjà
> posée:
> Comment mettre en forme conditionnelle une ligne (A4G4) si la cellule de
> la
> colonne G de cette ligne est non nulle et ce pour chaque ligne dont la
> cellule G est non nulle
>
> merci d'avance


.

Sam
Le #22119551
Bonjour,
je vais essayer de reformuler ce que je comprends :

a) la formule à trouver doit se mettre dans toutes les cellules de la
colonne G
b) si A(n+1) différent de 0 , G(n)=F(n)
c) si toutes les cellules de A(n+1) à G(n+1) sont vides , G(n)=F(n)
d) si F(n) = F(n+1) et F(n) différent de F(n-1), G(n) = F(n)
e) si F(n)=F(n+1)=F(n-1) , G(n) =""
f) dans tous les autres cas G(n)=""

à confirmer :
A(n+1) peut être vide, contenir 0, contenir un autre nombre
La condition b) ne s'applique que si A(n+1) contient un nombre différent de
0

préciser les priorités :
la condition e) est elle prioritaire sur les conditions b) et c)?

Pour l'instant j'ai trouvé ceci pour G3
=SI(F3ô;SI(F3<>F2;F3;"");SI(A4<>0;F3;SI(NB.VIDE(A4:F4)=6;F3;"")))
mais il y a une anomalie si F = 0 suivi d'une ligne vide

Cordialement
Michel dit "Sam"

"ISOARD"
Bonjour à tous,

Désolé, j'ai du m'absenter hier.
Les formules ne marchent pas.
En réalité les conditions sont les suivantes:
Pour une ligne donnée 28 par exemple, la cellule G28 ne peut s'afficher
que
si A29 est différent de 0 + si A29 à G29 = rien alors afficher également
F28.
Mais si F29 = F28 n'afficher que F28 en G28 et pas plus bas(G29) car F29,
F30, etc. pourraient êtres identiques et leur correspondance en G29, G30,
etc. ne doit pas s'afficher

J'espère m'être fait comprendre...



"Sam" a écrit :


Bonjour,
=SI(F29=0;$F$28;SI(ET(F29=$F$28;ESTTEXTE(B29));$F$28;SI(A29<>0;$F$28;"")))
ou
=SI(ET(ESTTEXTE(B29);F29=$F$28);$F$28;SI(ET(A29=0;F29<>0);"";$F$28))
Cordialement
Michel dit "Sam"

"ISOARD" news:

> Bonjour,
>
> Comment compléter les conditions suivantes:
> =SI(A29<>0;F28;SI(F29=0;F28;)) et ajouter SIF29ò8 alors afficher F28
> si
> B29 n'est pas vide (de texte).
>
> Et deuxièmement si ce n'est pas trop abuser, je réitère une question
> déjà
> posée:
> Comment mettre en forme conditionnelle une ligne (A4G4) si la cellule
> de
> la
> colonne G de cette ligne est non nulle et ce pour chaque ligne dont la
> cellule G est non nulle
>
> merci d'avance


.

Publicité
Poster une réponse
Anonyme