Mise en Forme

Le
Guy72
Bonjour,
J'ai mis comme formule dans ma MFC pour avoir la couleur désirée :

= SI(B33<0)

ou

=SI(ESTVIDE(B33)



Ni l'une, ni l'autre fonctionne.

Qu'ai-je omis ?

--
Cordialement
Guy
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #5234731
Bonjour,

³3<0

=ESTVIDE(B33)

JB


On 6 mar, 07:59, "Guy72"
Bonjour,
J'ai mis comme formule dans ma MFC pour avoir la couleur désirée :

= SI(B33<0)

ou

=SI(ESTVIDE(B33)

Ni l'une, ni l'autre fonctionne.

Qu'ai-je omis ?

--
Cordialement
Guy


Guy72
Le #5234721
Bonjour JB et merci de ton aide.
J'ai encore voulu mettre ça comme une formule de cellule, j'ai du mal à m'y
faire ........
--
Cordialement
Guy

"JB"
Bonjour,

³3<0

=ESTVIDE(B33)

JB


On 6 mar, 07:59, "Guy72"
Bonjour,
J'ai mis comme formule dans ma MFC pour avoir la couleur désirée :

= SI(B33<0)

ou

=SI(ESTVIDE(B33)

Ni l'une, ni l'autre fonctionne.

Qu'ai-je omis ?

--
Cordialement
Guy


bcar
Le #5234701
Remarque que tu aurais pu faire

=SI(B33<0;vrai;faux)
ou
=SI(ESTVIDE(B33);vrai;faux)

il faut juste que ton expression retourne une valeur booléenne

Bonjour JB et merci de ton aide.
J'ai encore voulu mettre ça comme une formule de cellule, j'ai du mal à m'y
faire ........


Guy72
Le #5234431
ça ne fonctionne pas pour une MFC
--
Cordialement
Guy

"bcar" fqo9fg$gde$
Remarque que tu aurais pu faire

=SI(B33<0;vrai;faux)
ou
=SI(ESTVIDE(B33);vrai;faux)

il faut juste que ton expression retourne une valeur booléenne

Bonjour JB et merci de ton aide.
J'ai encore voulu mettre ça comme une formule de cellule, j'ai du mal à
m'y faire ........




bcar
Le #5234381
Bine sûr que si ça fonctionne, en tout cas au moins sous excel 2003 et
2007. je n'ai pas essayé là sous 2000 mais suis quasiment persuadé que
ca fonctionne aussi.

bien sûr il ne faut pas oublier le "=" avant le si :
=SI(LC<0;VRAI;FAUX)

ça ne fonctionne pas pour une MFC


Guy72
Le #5234331
Avec ESTVIDE ça va.
Bizarre, j'ai Excel 2003
Avec =SI(ESTVIDE(B33);vrai;faux) ça fonctionne, le texte change de couleur.
Avec =SI(B33<0;vrai;faux) le texte ne change pas de couleur.
--
Cordialement
Guy

"bcar" fqovgn$jb5$
Bine sûr que si ça fonctionne, en tout cas au moins sous excel 2003 et
2007. je n'ai pas essayé là sous 2000 mais suis quasiment persuadé que ca
fonctionne aussi.

bien sûr il ne faut pas oublier le "=" avant le si :
=SI(LC<0;VRAI;FAUX)

ça ne fonctionne pas pour une MFC




bcar
Le #5234311
Tout dépend de la valeur que tu as en B33, vu que tu teste avec estvide,
je pense qu'au lieu de "B33<0", ce que tu veux est "B33=0"

Essaye de mettre "-5" dans la cellule B33, tu verras que la mise en
forme s'applique avec ta deuxième formule.

Avec ESTVIDE ça va.
Bizarre, j'ai Excel 2003
Avec =SI(ESTVIDE(B33);vrai;faux) ça fonctionne, le texte change de couleur.
Avec =SI(B33<0;vrai;faux) le texte ne change pas de couleur.


Guy72
Le #5234241
Ok c'est en effet B33=0 que je veux, et la ça fonctionne.
Merci de ton explication.
--
Cordialement
Guy

"bcar" fqp2fm$jnu$
Tout dépend de la valeur que tu as en B33, vu que tu teste avec estvide,
je pense qu'au lieu de "B33<0", ce que tu veux est "B33=0"

Essaye de mettre "-5" dans la cellule B33, tu verras que la mise en forme
s'applique avec ta deuxième formule.

Avec ESTVIDE ça va.
Bizarre, j'ai Excel 2003
Avec =SI(ESTVIDE(B33);vrai;faux) ça fonctionne, le texte change de
couleur.
Avec =SI(B33<0;vrai;faux) le texte ne change pas de couleur.




Publicité
Poster une réponse
Anonyme