Mise à jour de Debian

Le
Denis Beauregard
Bonjour,

Cela fait longtemps que je n'arrive plus à faire une mise à
jour de Debian Etch sur mon autre PC.

Avec apt-get update et apt-upgrade, j'ai un grand nombre d'erreurs
comme des paquets non trouvés ou non vérifiés.

J'utilisais auparavant le serveur de l'Univ. de Sherbrooke puis
quand j'ai commencé à avoir des problèmes, je suis passé au
serveur de Debian.org.

J'utilise ce PC de façon occasionnelle, donc ce n'est pas trop
grave, mais j'aimerais bien retomber sur mes pieds et avoir
quelque chose à jour.

Quelle serait la meilleure configuration de serveurs que je
devrais avoir pour apt et est-ce que ce sera suffisant pour que
mon PC soit capable de faire des apt-get update sans se faire
interrompre ?


Denis

--
0 Denis Beauregard -
// Les Français d'Amérique du Nord - www.francogene.com/genealogie--quebec/
| French in North America before 1722 - www.francogene.com/quebec--genealogy/
/ | Maintenant sur cédérom, début à 1770 (Version 2008)
oo oo Now on CD-ROM, beginnings to 1770 (2008 Release)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #1912420
Denis Beauregard wrote in message
Avec apt-get update et apt-upgrade, j'ai un grand nombre d'erreurs
comme des paquets non trouvés ou non vérifiés.


Lire avec soin les messages d'erreur serait un bon début.

Samuel Colin
Le #1912419
Dixit Denis Beauregard :
Bonjour,

Bonsoir,


Avec apt-get update et apt-upgrade, j'ai un grand nombre d'erreurs
comme des paquets non trouvés ou non vérifiés.

Messages d'erreurs ?


Quelle serait la meilleure configuration de serveurs que je
devrais avoir pour apt et est-ce que ce sera suffisant pour que
mon PC soit capable de faire des apt-get update sans se faire
interrompre ?

A priori pour toi, ftp.ca.debian.org

Ou tester quelques miroirs trouvés là :
http://www.debian.org/mirror/list
avec netselect
Voire utiliser directement netselect-apt

Denis Beauregard
Le #1912373
Le 09 Feb 2008 23:05:10 GMT, Samuel Colin
fr.comp.os.linux.configuration:

Dixit Denis Beauregard :
Bonjour,

Bonsoir,


Avec apt-get update et apt-upgrade, j'ai un grand nombre d'erreurs
comme des paquets non trouvés ou non vérifiés.

Messages d'erreurs ?





apt-get update
Réception de : 1 http://non-us.debian.org stable/non-US Release.gpg
[197B]
Réception de : 2 http://http.us.debian.org stable Release.gpg [378B]
Atteint http://non-us.debian.org stable/non-US Release
Réception de : 3 http://security.debian.org stable/updates Release.gpg
[189B]
Ign http://security.debian.org stable Release.gpg
Atteint http://http.us.debian.org stable Release
Atteint http://security.debian.org stable/updates Release
Err http://http.us.debian.org stable Release

Ign http://security.debian.org stable Release
Réception de : 4 http://http.us.debian.org stable Release [58,2kB]
Ign http://non-us.debian.org stable/non-US/main Packages/DiffIndex
Réception de : 5 http://security.debian.org stable/updates Release
[37,6kB]
Ign http://non-us.debian.org stable/non-US/contrib Packages/DiffIndex
Ign http://non-us.debian.org stable/non-US/non-free Packages/DiffIndex
Ign http://non-us.debian.org stable/non-US/main Packages
Ign http://non-us.debian.org stable/non-US/contrib Packages
Ign http://security.debian.org stable/updates Release
Ign http://non-us.debian.org stable/non-US/non-free Packages
Ign http://http.us.debian.org stable Release
Ign http://security.debian.org stable/main Packages
Ign http://http.us.debian.org stable/main Packages/DiffIndex
Ign http://security.debian.org stable/updates/main Packages/DiffIndex
Ign http://security.debian.org stable/updates/main Packages/DiffIndex
Ign http://security.debian.org stable/updates/contrib
Packages/DiffIndex
Ign http://security.debian.org stable/updates/non-free
Packages/DiffIndex
Atteint http://non-us.debian.org stable/non-US/main Packages
Ign http://http.us.debian.org stable/contrib Packages/DiffIndex
Ign http://http.us.debian.org stable/non-free Packages/DiffIndex
Atteint http://non-us.debian.org stable/non-US/contrib Packages
Err http://security.debian.org stable/main Packages
404 Not Found [IP : 128.31.0.36 80]
Atteint http://security.debian.org stable/updates/main Packages
Atteint http://security.debian.org stable/updates/main Packages
Atteint http://security.debian.org stable/updates/contrib Packages
Atteint http://http.us.debian.org stable/main Packages
Atteint http://http.us.debian.org stable/contrib Packages
Atteint http://security.debian.org stable/updates/non-free Packages
Atteint http://non-us.debian.org stable/non-US/non-free Packages
Atteint http://http.us.debian.org stable/non-free Packages
96,4ko réceptionnés en 1s (48,8ko/s)
Impossible de récupérer
http://security.debian.org/dists/stable/main/binary-i386/Packages.gz
404 Not Found [IP : 128.31.0.36 80]
Lecture des listes de paquets... Fait
W: GPG error: http://security.debian.org stable/updates Release: Les
signatures suivantes n'ont pas pu être vérifiées car la clé publique
n'est pas disponible : NO_PUBKEY A70DAF536070D3A1
W: GPG error: http://http.us.debian.org stable Release: Les signatures
suivantes n'ont pas pu être vérifiées car la clé publique n'est pas
disponible : NO_PUBKEY A70DAF536070D3A1 NO_PUBKEY B5D0C804ADB11277
W: Impossible de localiser la liste des paquets sources
http://security.debian.org stable/main Packages
(/var/lib/apt/lists/security.debian.org_dists_stable_main_binary-i386_Packages)
- stat (2 Aucun fichier ou répertoire de ce type)
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
E: Le téléchargement de quelques fichiers d'index a échoué, ils ont
été ignorés, ou les anciens ont été utilisés à la place.






apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
samba: Dépend: samba-common (= 3.0.23d-2+b1) mais 3.0.24-6etch4 est
installé
swat: Dépend: samba (= 3.0.24-6etch4) mais 3.0.23d-2+b1 est installé
W: Impossible de localiser la liste des paquets sources
http://security.debian.org stable/main Packages
(/var/lib/apt/lists/security.debian.org_dists_stable_main_binary-i386_Packages)
- stat (2 Aucun fichier ou répertoire de ce type)
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
E: Dépendances manquantes. Essayez d'utiliser l'option -f.




Quelle serait la meilleure configuration de serveurs que je
devrais avoir pour apt et est-ce que ce sera suffisant pour que
mon PC soit capable de faire des apt-get update sans se faire
interrompre ?

A priori pour toi, ftp.ca.debian.org

Ou tester quelques miroirs trouvés là :
http://www.debian.org/mirror/list
avec netselect
Voire utiliser directement netselect-apt



J'utilisais gulus (groupe des usagers Linux à l'université
de Sherbrooke), mais j'ai l'impression que tout est embrouillé
là-bas.

Puis, dans kpackage, j'ai remplacé gulus par quelques autres
sites Debian US (je n'avais pas vu qu'il y avait des .ca).

Je n'ose plus avancer trop loin. J'ai l'impression que je me
suis retrouvé avec des générations d'index incompatibles et que
apt ne sait plus quoi faire pour retomber sur ses pattes.



Denis

--
0 Denis Beauregard -
// Les Français d'Amérique du Nord - www.francogene.com/genealogie--quebec/
| French in North America before 1722 - www.francogene.com/quebec--genealogy/
/ | Maintenant sur cédérom, début à 1770 (Version 2008)
oo oo Now on CD-ROM, beginnings to 1770 (2008 Release)


Samuel Colin
Le #1912371
Dixit Denis Beauregard :
apt-get update
Réception de : 1 http://non-us.debian.org stable/non-US Release.gpg
[197B]

Les entrées non-US sont caduques à partir de la sarge (la 3.1) donc tu

peux les effacer.

Réception de : 3 http://security.debian.org stable/updates Release.gpg

Je te suggèrerais de remplacer les «stable» par des «etch».


Atteint http://http.us.debian.org stable Release

Un miroir sur kernel.org, ça devrait a priori aller. Remplacer «stable»

par «etch» partout.


96,4ko réceptionnés en 1s (48,8ko/s)
Impossible de récupérer
http://security.debian.org/dists/stable/main/binary-i386/Packages.gz
404 Not Found [IP : 128.31.0.36 80]

Cette erreur-là vient du fait qu'il y a une entrée security stable au

lieu de stable/updates.

Lecture des listes de paquets... Fait
W: GPG error: http://security.debian.org stable/updates Release: Les
signatures suivantes n'ont pas pu être vérifiées car la clé publique
n'est pas disponible : NO_PUBKEY A70DAF536070D3A1
W: GPG error: http://http.us.debian.org stable Release: Les signatures
suivantes n'ont pas pu être vérifiées car la clé publique n'est pas
disponible : NO_PUBKEY A70DAF536070D3A1 NO_PUBKEY B5D0C804ADB11277
W: Impossible de localiser la liste des paquets sources

Installer les paquets debian-archive-keyring et possiblement

debian-keyring.

apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
samba: Dépend: samba-common (= 3.0.23d-2+b1) mais 3.0.24-6etch4 est
installé
swat: Dépend: samba (= 3.0.24-6etch4) mais 3.0.23d-2+b1 est installé
W: Impossible de localiser la liste des paquets sources
http://security.debian.org stable/main Packages
(/var/lib/apt/lists/security.debian.org_dists_stable_main_binary-i386_Packages)
- stat (2 Aucun fichier ou répertoire de ce type)
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

Que contient /etc/sources/apt.conf ?

Si le «upgrade» s'est bien passé, tu auras à utiliser «dist-upgrade»
pour véritablement être en Etch. Il te faudra regarder les notes de
mises à jour au cas où tu aurais des configurations particulières sur ta
machine.

Denis Beauregard
Le #1912370
Le 12 Feb 2008 15:51:07 GMT, Samuel Colin
fr.comp.os.linux.configuration:

Dixit Denis Beauregard :
apt-get update
Réception de : 1 http://non-us.debian.org stable/non-US Release.gpg
[197B]

Les entrées non-US sont caduques à partir de la sarge (la 3.1) donc tu

peux les effacer.


Fait

Réception de : 3 http://security.debian.org stable/updates Release.gpg

Je te suggèrerais de remplacer les «stable» par des «etch».



Fait, mais cela ne semble rien changer.

Atteint http://http.us.debian.org stable Release

Un miroir sur kernel.org, ça devrait a priori aller. Remplacer «stable»

par «etch» partout.


96,4ko réceptionnés en 1s (48,8ko/s)
Impossible de récupérer
http://security.debian.org/dists/stable/main/binary-i386/Packages.gz
404 Not Found [IP : 128.31.0.36 80]

Cette erreur-là vient du fait qu'il y a une entrée security stable au

lieu de stable/updates.

Lecture des listes de paquets... Fait
W: GPG error: http://security.debian.org stable/updates Release: Les
signatures suivantes n'ont pas pu être vérifiées car la clé publique
n'est pas disponible : NO_PUBKEY A70DAF536070D3A1
W: GPG error: http://http.us.debian.org stable Release: Les signatures
suivantes n'ont pas pu être vérifiées car la clé publique n'est pas
disponible : NO_PUBKEY A70DAF536070D3A1 NO_PUBKEY B5D0C804ADB11277
W: Impossible de localiser la liste des paquets sources

Installer les paquets debian-archive-keyring et possiblement

debian-keyring.


Les deux exigent que je corrige le problème avec samba et awat.
Pourtant, samba fonctionne (j'échange des fichiers avec des PC
windows).


apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
samba: Dépend: samba-common (= 3.0.23d-2+b1) mais 3.0.24-6etch4 est
installé
swat: Dépend: samba (= 3.0.24-6etch4) mais 3.0.23d-2+b1 est installé
W: Impossible de localiser la liste des paquets sources
http://security.debian.org stable/main Packages
(/var/lib/apt/lists/security.debian.org_dists_stable_main_binary-i386_Packages)
- stat (2 Aucun fichier ou répertoire de ce type)
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

Que contient /etc/sources/apt.conf ?



/etc/sources n'existe pas.


Si le «upgrade» s'est bien passé, tu auras à utiliser «dist-upgrade»
pour véritablement être en Etch. Il te faudra regarder les notes de
mises à jour au cas où tu aurais des configurations particulières sur ta
machine.


Ni upgrade ni update ne passent pour le moment. J'ai l'impression
que je devrais tout ré-installer. Pourtant, il me semblait avoir
etch initialement quand j'ai remplacé le disque dur de ce PC.
À moins que ce soit sarge ?

Dans la liste des serveurs pour kpackage, ce sont des URL comme
http:// et non des ftp qui sont utilisés. Il y a une liste des
adresses en http quelque part ? Je réussis à en trouver des morceaux
sur www.debian.org mais pas de liste pouvant servir de point de
départ. À un endroit, il y a un modèle et ailleurs, des lignes à
ajouter pour plus de sécurité.

Ceci dit, je me suis dit que toute ma configuration était sans doute
à refaire au complet. J'ai donc effacé complètement la liste des
http:// dans kpackage - configuration - configurer kpackage mais je
ne vois pas de liste sur le site de www.debian.org pour m'en servir
comme exemple et reconstruire la liste au complet. J'espère que je
n'ai pas tout détruit. Il y a aussi le message disant que je dois
ré-installer samba alors que c'est mon seul lien entre ce PC et celui
avec Linux et qu'il marche bien (en tous cas, je vois la liste des
fichiers sur l'autre PC).

/etc/apt/sources.list est maintenant vide. Je pense qu'il faudrait
que j'y copie un fichier complet au lieu de tenter de réparer à
l'aveuglette pour relancer ce PC.


Denis

--
0 Denis Beauregard -
// Les Français d'Amérique du Nord - www.francogene.com/genealogie--quebec/
| French in North America before 1722 - www.francogene.com/quebec--genealogy/
/ | Maintenant sur cédérom, début à 1770 (Version 2008)
oo oo Now on CD-ROM, beginnings to 1770 (2008 Release)


Samuel Colin
Le #1912369
Dixit Denis Beauregard :

Installer les paquets debian-archive-keyring et possiblement

debian-keyring.


Les deux exigent que je corrige le problème avec samba et awat.
Pourtant, samba fonctionne (j'échange des fichiers avec des PC
windows).

Le système de paquets et les applis installées sont deux choses

différentes. Pour le moment la nouvelle version de samba n'est pas
installable, mais l'ancienne est toujours installée en attendant.


Que contient /etc/sources/apt.conf ?



/etc/sources n'existe pas.

Au temps pour moi: /etc/apt/apt.conf ?


que je devrais tout ré-installer. Pourtant, il me semblait avoir
etch initialement quand j'ai remplacé le disque dur de ce PC.
À moins que ce soit sarge ?

Pas impossible, ça expliquerait les problèmes.

Note que tu peux essayer de forcer l'installation de la nouvelle version
de samba via:
apt-get install samba=numéro_de_version_voulu
voire en spécifiant tous les paquets d'un seul coup
apt-get install samba=version_voulue swat=version_voulue samba-common=version_voulue
Si je demandais le contenu de /etc/apt/apt.conf, c'est parce qu'il y a
peut-être une ligne dedans qui empêche d'utiliser etch comme source de
paquets.

/etc/apt/sources.list est maintenant vide. Je pense qu'il faudrait
que j'y copie un fichier complet au lieu de tenter de réparer à
l'aveuglette pour relancer ce PC.

Essaie déjà avec cette ligne-là, entre "####"


############
deb http://ftp.us.debian.org/debian etch main contrib non-free
############
Si ça marche on pourra compléter après.



Denis Beauregard
Le #1912367
Le 12 Feb 2008 17:28:01 GMT, Samuel Colin
fr.comp.os.linux.configuration:

Dixit Denis Beauregard :

Installer les paquets debian-archive-keyring et possiblement

debian-keyring.


Les deux exigent que je corrige le problème avec samba et awat.
Pourtant, samba fonctionne (j'échange des fichiers avec des PC
windows).

Le système de paquets et les applis installées sont deux choses

différentes. Pour le moment la nouvelle version de samba n'est pas
installable, mais l'ancienne est toujours installée en attendant.


Que contient /etc/sources/apt.conf ?



/etc/sources n'existe pas.

Au temps pour moi: /etc/apt/apt.conf ?



Il n'y a que

APT::Cache-Limit "141943904";


que je devrais tout ré-installer. Pourtant, il me semblait avoir
etch initialement quand j'ai remplacé le disque dur de ce PC.
À moins que ce soit sarge ?

Pas impossible, ça expliquerait les problèmes.

Note que tu peux essayer de forcer l'installation de la nouvelle version
de samba via:
apt-get install samba=numéro_de_version_voulu
voire en spécifiant tous les paquets d'un seul coup
apt-get install samba=version_voulue swat=version_voulue samba-common=version_voulue
Si je demandais le contenu de /etc/apt/apt.conf, c'est parce qu'il y a
peut-être une ligne dedans qui empêche d'utiliser etch comme source de
paquets.

/etc/apt/sources.list est maintenant vide. Je pense qu'il faudrait
que j'y copie un fichier complet au lieu de tenter de réparer à
l'aveuglette pour relancer ce PC.

Essaie déjà avec cette ligne-là, entre "####"


############
deb http://ftp.us.debian.org/debian etch main contrib non-free
############
Si ça marche on pourra compléter après.


Suivi d'un apt-get update, j'ai de nouveau une liste de nouveaux
paquets. Pas moyen d'installer keyring, toujours le problème avec
samba. Librairie non compatible. Quel est le numéro de version si
je veux faire cela ?

apt-get install samba=numéro_de_version_voulu

Et dois-je désinstaller auparavant ?

bzip2 causait aussi des problèmes, mais je ne le vois plus dans
les messages d'erreur.


Denis

--
0 Denis Beauregard -
// Les Français d'Amérique du Nord - www.francogene.com/genealogie--quebec/
| French in North America before 1722 - www.francogene.com/quebec--genealogy/
/ | Maintenant sur cédérom, début à 1770 (Version 2008)
oo oo Now on CD-ROM, beginnings to 1770 (2008 Release)




Samuel Colin
Le #1912366
Dixit Denis Beauregard :

Au temps pour moi: /etc/apt/apt.conf ?



Il n'y a que

APT::Cache-Limit "141943904";


Bon, pas gênant, mais pas nécessaire non plus (au moins dans Lenny, je

ne suis pas aussi sûr pour Etch)
Il n'y a rien non plus dans /etc/apt/preferences ?

############
deb http://ftp.us.debian.org/debian etch main contrib non-free
############
Si ça marche on pourra compléter après.


Suivi d'un apt-get update, j'ai de nouveau une liste de nouveaux
paquets. Pas moyen d'installer keyring, toujours le problème avec
samba. Librairie non compatible. Quel est le numéro de version si
je veux faire cela ?

D'après mon chroot Etch, c'est:

apt-get install samba=3.0.24-6etch9 samba-common=3.0.24-6etch9 swat=3.0.24-6etch9
Regarde d'abord les indications que je donne plus bas avant de forcer
apt.
Tu peux voir l'état d'un paquet (installé ou pas, numéros de versions
disponibles, etc) via «apt-cache policy nom_du_paquet»

apt-get install samba=numéro_de_version_voulu

Et dois-je désinstaller auparavant ?

Commence par:

apt-get -f install
De cette manière apt essaiera de se remettre dans un état cohérent.
Après tu peux retenter l'upgrade.
S'il y a toujours des erreurs, essaie d'enlever les paquets qui posent
problème. Si ça ne marche toujours pas, il y aura encore moyen
d'utiliser la tronçonneuse dpkg.

En tout état de cause, si tu as un samba déjà fonctionnel (apparemment)
et que tu veux le conserver, je ne saurai trop conseiller de faire une
sauvegarde de /etc/samba (enfin, le truc où il garde sa configuration).



Publicité
Poster une réponse
Anonyme