Mise à jour wheezy -> jessie

Le
Jack.R
Bonjour,

J'en suis à ma 3ème migration wheezy -> jessie et à la 3Ã=
¨me qui se
passe mal. Il faut dire qu'à chaque fois c'est sur du matériel an=
cien.

Pour le premier un IBM X30, soucis de LKMS solutionné en rajoutant des
paramètres de boot du noyau dans /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet i915.modeset=0 vga=791"

Pour le deuxième grub n'arrivait pas à démarrer le noyau. Ap=
rès moult
essais et échecs (et en ayant cassé pas mal de truc), je m'en suis
sorti en installant lilo (via un démarrage en mode rescue depuis la
netinstall jessie et shell sur /). Je suis un dégonflé, je n'ai p=
as
encore tenté de réinstaller grub maintenant que cela fonctionne.

Pour le 3ème (carte Supermicro X7SPA-HF ATOM D510), en cours de mise =
à
jour, impossible d'installer le nouveau kernel, pas assez de place
sur /lib. Le disque est partitionné comme suit (installation de squeeze
mise à jour en wheezy puis changement de carte mère si je me souv=
iens
bien):
/sda1 /
/sda5 /usr
/sda6 /var
/sda7 swap
/sda8 /tmp
/sda9 /home


Qu'à cela ne tienne, il y a plein de lace sur /home, je déplace /=
lib
dans /home et crée un lien symbolique de /lib vers /home/lib.
Je relance apt-get dist-upgrade et tout roule.
Je reboot et là:
Kernel panic - not syncing: Attempted to kill init!

Un boot sur le CD netinstall de jessie me mélange toutes les interfaces
réseau et ne me permet pas d'ouvrir un shell sur /dev/sda1

A noter que firmware-linux-nonfree n'est pas installé, c'est peut-Ã=
ªtre
là que j'ai fait une autre erreur.

Des suggestions avant que je ne fasse façon bourrin ?
sortie du disque de la machine, copie le contenu de sda5 à 9 ailleurs,
supprime /sda5 à 9,agrandissement /sda1, recrée les partitions /s=
da5 à
9, recopie le contenu de sda5 à 9, suppression du lien
symbolique /lib, transfert de /home/lib dans /lib, réinstallation du
disque dans la machine, prières, reboot

Merci d'avance pour vos lumières.

--
Jack.R
http://jack.r.free.fr

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/20150807183159.50164c16@traveller.ajs.home
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Francois Lafont
Le #26362705
Bonjour,

On 07/08/2015 18:31, Jack.R wrote:

Des suggestions avant que je ne fasse façon bourrin ?



Bon, ça va sûrement pas t'aider des masses mais, personnellement,
le peu de fois où j'ai tenté des upgrades de distributions, ça
c'est toujours mal passé (peut-être que j'ai pas eu de chances,
je ne sais pas). Du coup, depuis maintenant un certains temps,
je réinstalle toujours intégralement le système de zéro avec un
home séparé que je conserve bien sûr. Ensuite, je réinstalle les
paquets dont j'ai besoin et je retrouve un environnement fonctionnel
assez rapidement. En tout cas, ça m'a toujours pris moins de temps
que des faire des migrations (qui foirent dans mon cas)...

Bon, désolé c'est pas très constructif pour toi.
Bon courage.

--
François Lafont

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/mq2nng$9nb$
moi-meme
Le #26362754
Le Fri, 07 Aug 2015 19:00:02 +0200, Francois Lafont a écrit :

Du coup, depuis maintenant un certains temps,
je réinstalle toujours intégralement le système de zéro avec un home
séparé que je conserve bien sûr.



en ce qui me concerne je garde aussi le /etc et la liste des paquets
installés même si les paquets ont changé

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/55c512f8$0$3064$
Charles Plessy
Le #26362762
Le Fri, Aug 07, 2015 at 08:20:08PM +0000, moi-meme a écrit :

en ce qui me concerne je garde aussi le /etc et la liste des paquets
installés même si les paquets ont changé



À ce sujet, je recommande le paquet « etckeeper », qui transforme /etc en un
repositoire Git et enregistre les changements à chaque fois que Apt y installe
ou change des fichiers.

Bonne fin de semaine,

--
Charles Plessy
Tsurumi, Kanagawa, Japan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Jack.R
Le #26362880
Le Sat, 8 Aug 2015 06:38:46 +0900,
Charles Plessy
Le Fri, Aug 07, 2015 at 08:20:08PM +0000, moi-meme a écrit :
>
> en ce qui me concerne je garde aussi le /etc et la liste des
> paquets installés même si les paquets ont changé

À ce sujet, je recommande le paquet « etckeeper  », qui
transforme /etc en un repositoire Git et enregistre les changements à
chaque fois que Apt y installe ou change des fichiers.

Bonne fin de semaine,




Bonjour,

Pas de soucis, avant la mise à jour j'avais sauvegardé /etc ainsi que
la liste des paquets, comme indiqué dans les notes de publication.

Ce qui m'embête plus pour une réinstallation complète, ce so nt les
bases Mysql (qui sont dans /var/lib et que je ne vois pas comment
réimporter). Il aurait fallu que je fasse un dump avant la mise à jour.

A noter que ce n'est pas ma première mis à jour de version Debian (j'ai
du commencer à la Potato) et que c'est la première fois que je
rencontre de vrai soucis, lié à l'age qu'à pris mon matà ©riel (moi je
n'ai pas bougé d'un pouce ;-))

Merci

--
Jack.R
http://jack.r.free.fr

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
andre_debian
Le #26362885
On Saturday 08 August 2015 19:14:19 Jack.R wrote:
Pas de soucis, avant la mise à jour j'avais sauvegardé /etc ain si que
la liste des paquets, comme indiqué dans les notes de publication.
Ce qui m'embête plus pour une réinstallation complète, ce sont les
bases Mysql (qui sont dans /var/lib et que je ne vois pas comment
réimporter). Il aurait fallu que je fasse un dump avant la mise à   jour.
A noter que ce n'est pas ma première mis à jour de version Debi an(j'ai
du commencer à la Potato) et que c'est la première fois que je
rencontre de vrai soucis, lié à l'age qu'à pris mon matà ©riel (moi je
n'ai pas bougé d'un pouce ;-))
Jack.R



Une solution que je pratique,

j'ai quatre PC, je fais un upgrade sur un seul PC,
c'est vrai parfois assez laborieux.
Une fois que l'upgrade est digéré, le système devenu enfin s table,
j'efface sur les trois autres PC les partitions contenant l'ancienne versio n.
Avec "rsync", je clone le système complet du premier PC vers chacun d' eux.

Ensuite, je reboote chacun des PC clonés, quelques micro bugs à r égler,
encore un reboot, et tout baigne !

C'est aussi un gros gain de temps, puisque on upgrade qu'un seul PC
et on ne perd pas ses données.

Si évidemment ça coince avec le premier PC, alors il faut choisi r
celui qui semble le plus propice aux upgrade.

Un upgrade peut mal se passer si le PC est trop ancien.

Bonne soirée.

André


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
mireero
Le #26362938
On 08/07/2015 06:40 PM, Jack.R wrote:
Bonjour,

J'en suis à ma 3ème migration wheezy -> jessie et à la 3ème qui se
passe mal. Il faut dire qu'à chaque fois c'est sur du matériel ancien.

Pour le premier un IBM X30, soucis de LKMS solutionné en rajoutant des
paramètres de boot du noyau dans /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet i915.modeset=0 vgay1"

Pour le deuxième grub n'arrivait pas à démarrer le noyau. Après moult
essais et échecs (et en ayant cassé pas mal de truc), je m'en suis
sorti en installant lilo (via un démarrage en mode rescue depuis la
netinstall jessie et shell sur /). Je suis un dégonflé, je n'ai pas
encore tenté de réinstaller grub maintenant que cela fonctionne.

Pour le 3ème (carte Supermicro X7SPA-HF ATOM D510), en cours de mise à
jour, impossible d'installer le nouveau kernel, pas assez de place
sur /lib. Le disque est partitionné comme suit (installation de squeeze
mise à jour en wheezy puis changement de carte mère si je me souviens
bien):
/sda1 /
/sda5 /usr
/sda6 /var
/sda7 swap
/sda8 /tmp
/sda9 /home


Qu'à cela ne tienne, il y a plein de lace sur /home, je déplace /lib
dans /home et crée un lien symbolique de /lib vers /home/lib.
Je relance apt-get dist-upgrade et tout roule.
Je reboot et là:
Kernel panic - not syncing: Attempted to kill init!

Un boot sur le CD netinstall de jessie me mélange toutes les interfaces
réseau et ne me permet pas d'ouvrir un shell sur /dev/sda1

A noter que firmware-linux-nonfree n'est pas installé, c'est peut-être
là que j'ai fait une autre erreur.

Des suggestions avant que je ne fasse façon bourrin ?
sortie du disque de la machine, copie le contenu de sda5 à 9 ailleurs,
supprime /sda5 à 9,agrandissement /sda1, recrée les partitions /sda5 à
9, recopie le contenu de sda5 à 9, suppression du lien
symbolique /lib, transfert de /home/lib dans /lib, réinstallation du
disque dans la machine, prières, reboot

Merci d'avance pour vos lumières.




Salut,
Ici, si j'ai bien compris, quand tu parles de /lib, c'est de /usr/lib
qu'il s'agit?
Ou alors plutôt, /lib est monté sur sda5 au lieu de /usr?

Bref, 2 remarques:

× La méthode bourrin me semble plus propre, ça ne casse pas la
"compartimentation" qu'apporte des partitions séparées et les avantages
recherchés (genre aide à la sauvegarde, options de montage distinctes...).

× Y'aurait pas un souci lorsque certain exécutables accèdent à des
librairies dans [/usr]/lib, sachant que certains outils ne déréférencent
pas les liens symboliques et s'attendent donc à trouver leur librairie
(par ex) dans un [/usr]/lib "dur".
Peut-être que le système a continué à fonctionner après ton /lib dans
/home parce que certaines librairies "clef" comme la libc par exemple
étaient déjà en mémoire lors du déplacement et donc toujours accessible.
Mais plus lors d'un reboot.


Pour finir, si tu as plein de place dans /home, tu peux peut-être y
placer directement /lib en coupant la partition en 2, ce serait plus
rapide que de chercher à redimensionner /sda5.

Bon courage...

--
mireero

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/55c6f715$0$3293$
Jack.R
Le #26362974
Le Sun, 09 Aug 2015 08:45:41 +0200,
mireero
On 08/07/2015 06:40 PM, Jack.R wrote:
> Bonjour,
>
> J'en suis à ma 3ème migration wheezy -> jessie et à la 3 ème qui se
> passe mal. Il faut dire qu'à chaque fois c'est sur du matériel
> ancien.
>
> Pour le premier un IBM X30, soucis de LKMS solutionné en rajoutant
> des paramètres de boot du noyau dans /etc/default/grub
> GRUB_CMDLINE_LINUX_DEFAULT="quiet i915.modeset=0 vgay1"
>
> Pour le deuxième grub n'arrivait pas à démarrer le noyau . Après
> moult essais et échecs (et en ayant cassé pas mal de truc), j e m'en
> suis sorti en installant lilo (via un démarrage en mode rescue
> depuis la netinstall jessie et shell sur /). Je suis un dégonflà ©,
> je n'ai pas encore tenté de réinstaller grub maintenant que c ela
> fonctionne.
>
> Pour le 3ème (carte Supermicro X7SPA-HF ATOM D510), en cours de
> mise à jour, impossible d'installer le nouveau kernel, pas assez de
> place sur /lib. Le disque est partitionné comme suit (installation
> de squeeze mise à jour en wheezy puis changement de carte mèr e si
> je me souviens bien):
> /sda1 /
> /sda5 /usr
> /sda6 /var
> /sda7 swap
> /sda8 /tmp
> /sda9 /home
>
>
> Qu'à cela ne tienne, il y a plein de lace sur /home, je dépla ce /lib
> dans /home et crée un lien symbolique de /lib vers /home/lib.
> Je relance apt-get dist-upgrade et tout roule.
> Je reboot et là:
> Kernel panic - not syncing: Attempted to kill init!
>
> Un boot sur le CD netinstall de jessie me mélange toutes les
> interfaces réseau et ne me permet pas d'ouvrir un shell
> sur /dev/sda1
>
> A noter que firmware-linux-nonfree n'est pas installé, c'est
> peut-être là que j'ai fait une autre erreur.
>
> Des suggestions avant que je ne fasse façon bourrin ?
> sortie du disque de la machine, copie le contenu de sda5 à 9
> ailleurs, supprime /sda5 à 9,agrandissement /sda1, recrée les
> partitions /sda5 à 9, recopie le contenu de sda5 à 9, suppres sion
> du lien symbolique /lib, transfert de /home/lib dans /lib,
> réinstallation du disque dans la machine, prières, reboot
>
> Merci d'avance pour vos lumières.
>

Salut,
Ici, si j'ai bien compris, quand tu parles de /lib, c'est de /usr/lib
qu'il s'agit?
Ou alors plutôt, /lib est monté sur sda5 au lieu de /usr?

Bref, 2 remarques:

× La méthode bourrin me semble plus propre, ça ne casse pa s la
"compartimentation" qu'apporte des partitions séparées et les
avantages recherchés (genre aide à la sauvegarde, options de mo ntage
distinctes...).

× Y'aurait pas un souci lorsque certain exécutables accède nt à des
librairies dans [/usr]/lib, sachant que certains outils ne
déréférencent pas les liens symboliques et s'attendent don c à trouver
leur librairie (par ex) dans un [/usr]/lib "dur".
Peut-être que le système a continué à fonctionner apr ès ton /lib dans
/home parce que certaines librairies "clef" comme la libc par exemple
étaient déjà en mémoire lors du déplacement et d onc toujours
accessible. Mais plus lors d'un reboot.


Pour finir, si tu as plein de place dans /home, tu peux peut-être y
placer directement /lib en coupant la partition en 2, ce serait plus
rapide que de chercher à redimensionner /sda5.

Bon courage...




Bonjour,

Je parlais bien de /lib et non de /usr/lib.

La méthode "bourrin" a parfaitement fonctionné, c'était donc bien ma
magouille de lien symbolique /lib vers /home/lib qui avait mis le bazar.

Il est possible que /home soit monté trop tard et que le lien ne soit
pas encore valide lorsque le noyau essaye d'accéder à certains éléments
de /lib.

M'enfin, / qui faisait 337Mo est maintenant à 1Go, je ne devrais plus
être embêté par cela lors des prochaines mises à jour.

Il me reste encore un serveur à mettre à jour (un celeron qui doit
avoir 10 ans) et auquel je n'ai pas un accès physique à la machin e ...
Je vérifierais la place dispo sur chaque partition (en particulier /)
avant de commencer. Je ne me souviens plus s'il est en lvm. Pourvu que
ce soit le cas.

--
Jack.R
http://jack.r.free.fr

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Publicité
Poster une réponse
Anonyme