Mode graphique de la ligne de commande

Le
JUPIN Alain
Bonsoir la liste,

Je viens d'installer une Wheezy toute fraîche sur une vieille machine
(Athlon XP 1800+ et carte graphique intégrée au chipset nForce)

Quand je boot, je vois le kernel qui commence a se charger puis mon
écran me dit au bout de quelques secondes : "Frequency out of range.
Recommended settings : 1680x1050 60Hz".

Si je mets l'option vgay4 en éditant la ligne de boot de grub -> Idem

A noter que lors de l'install je n'ai pas sélectionné d'interface
graphique, juste le système de base et un serveur SSH !
Impossible de me connecter en SSH, l'interface semble montée car
j'arrive à la pinguer, mais impossible de m'y connecter en SSH.

Avant toute chose, j'aimerais avoir un mode graphique "de base" pour la
ligne de commande.

Merci pour votre aide

--
Alain JUPIN

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/51A392E0.8020304@jupin.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Klaus Becker
Le #25435982
Le lundi 27 mai 2013 17:07:44, JUPIN Alain a écrit :
Bonsoir la liste,

Je viens d'installer une Wheezy toute fraîche sur une vieille machine
(Athlon XP 1800+ et carte graphique intégrée au chipset nForce)

Quand je boot, je vois le kernel qui commence a se charger puis mon
écran me dit au bout de quelques secondes : "Frequency out of range.
Recommended settings : 1680x1050 60Hz".

Si je mets l'option vgay4 en éditant la ligne de boot de grub -> Id em

A noter que lors de l'install je n'ai pas sélectionné d'interface
graphique, juste le système de base et un serveur SSH !
Impossible de me connecter en SSH, l'interface semble montée car
j'arrive à la pinguer, mais impossible de m'y connecter en SSH.

Avant toute chose, j'aimerais avoir un mode graphique "de base" pour la
ligne de commande.

Merci pour votre aide




Salut ,

installer xserver-xorg-video-nvidia?

apt-cache search nforce sort une longue liste de packetages, entre autres c elui-là.

Il y a certainement une solution + légère.

Tu peux chercher sur le web avec ton message d'erreur et ta carte graphique.

librement

Klaus

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain L. Sauvage
Le #25436252
Le lundi 27 mai 2013 à 21:21:38, Sylvain L. Sauvage a écrit :
[…]
C’est maintenant de la forme (pour faire simple)
'video=XxY-F' ('video80x1050-60' pour ton exemple).



Oups, c’est @ pas - pour le rafraîchissement :

[…]
Alors fais des recherches sur les modes vidéo du _noyau_,
de son _framebuffer_ pour ton GPU (pas de Grub2, puisque tu
vois bien le menu de Grub (le mode graphique utilisé par
Grub pouvant être différent de celui de la console et de
X)).



Ou enlève le KMS avec l’option 'nomodeset'.

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain L. Sauvage
Le #25436262
Le lundi 27 mai 2013 à 19:07:44, JUPIN Alain a écrit :
Bonsoir la liste,



Bonsoir,

Je viens d'installer une Wheezy toute fraîche sur une vieille
machine (Athlon XP 1800+ et carte graphique intégrée au
chipset nForce)

Quand je boot, je vois le kernel qui commence a se charger
puis mon écran me dit au bout de quelques secondes :
"Frequency out of range. Recommended settings : 1680x1050
60Hz".

Si je mets l'option vgay4 en éditant la ligne de boot de
grub -> Idem



L’option 'vga' est obsolète depuis un moment, surtout avec K MS
(qui est censé fonctionner correctement tout seul…).

C’est maintenant de la forme (pour faire simple) 'video=XxY-F'
('video80x1050-60' pour ton exemple).

A noter que lors de l'install je n'ai pas sélectionné
d'interface graphique, juste le système de base et un
serveur SSH !



Le mode graphique de la console ne concerne pas l’interface
graphique (X), juste la console / le framebuffer.

Impossible de me connecter en SSH, l'interface
semble montée car j'arrive à la pinguer, mais impossible de
m'y connecter en SSH.



Quelles erreurs ?

Avant toute chose, j'aimerais avoir un mode graphique "de
base" pour la ligne de commande.



Alors fais des recherches sur les modes vidéo du _noyau_, de
son _framebuffer_ pour ton GPU (pas de Grub2, puisque tu vois
bien le menu de Grub (le mode graphique utilisé par Grub pouvant
être différent de celui de la console et de X)).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
JUPIN Alain
Le #25437692
Bonjour

Le 27/05/2013 21:21, Sylvain L. Sauvage a écrit :
L’option 'vga' est obsolète depuis un moment, surtout avec KMS
(qui est censé fonctionner correctement tout seul…).

C’est maintenant de la forme (pour faire simple) 'video=XxY-F'
('video80x1050-60' pour ton exemple).


Merci, avec cette option, cela fonctionne :D


Impossible de me connecter en SSH, l'interface
semble montée car j'arrive à la pinguer, mais impossible de
m'y connecter en SSH.


Quelles erreurs ?


J'avais un :
ssh: connect to host 192.168.0.10 port 22: Connection refused

Depuis que la console fonctionne normalement, je vais jusqu'au login et
le serveur SSH fonctionne (connexion depuis une autre machine OK).
Avant toute chose, j'aimerais avoir un mode graphique "de
base" pour la ligne de commande.


Alors fais des recherches sur les modes vidéo du _noyau_, de
son _framebuffer_ pour ton GPU (pas de Grub2, puisque tu vois
bien le menu de Grub (le mode graphique utilisé par Grub pouvant
être différent de celui de la console et de X)).




Entre temps, j'avais tenté un nomodeset comme option pour le kernel. Mon
affichage reste OK plus longtemps puis patatra même problème :(
"Frequency out of range ..."
J'étais capable d'apercevoir "Configuring network interfaces ... done"
plus une ou deux ligne que je n'ai pas le temps de lire puis "blackout" !

Je suspecte un problème avec KMS et la détection du mode graphique.
Mais point grave, l'essentiel étant que cela soit résolu ;)

Merci la liste et à Sylvain

Alain

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme