Modification mystérieuse (pour moi)

Le
LeBuss
Salut, à tous, j'ai des cellules qui contiennent une formule avec des si
imbriqués. Comme suit :

=SI(W125="";"";SI(X125="G10/10";(Y125+0,02)*Z125/1000*AA125/1000*7,85/AB125;SI(X125="G7/7";(Y125+0,014)*Z125/1000*AA125/1000*7,85/AB125;SI(X125="Sans";Y125*Z125/1000*AA125/1000*7,85/AB125;SI(X125="Nu";Y125*Z125/1000*AA125/1000*7,85/AB125)))))

Je me suis aperçu quand rechargeant mon fichier, excel se plante à la
sauvegarde. J'ai donc constater que sur plusieurs cellules de ma
colonne, la grosse formule ci dessus se transforme en :

=COLONNE(W134="";"";SI(X134="G10/10";(Y134+0,02)*Z134/1000*AA134/1000*7,85/AB134;SI(X134="G7/7";(Y134+0,014)*Z134/1000*AA134/1000*7,85/AB134;SI(X134="Sans";Y134*Z134/1000*AA134/1000*7,85/AB134;SI(X134="Nu";Y134*Z134/1000*AA134/1000*7,85/AB134)))))

Le SI est devenu COLONNE ??

Si qqun a une idée ??

Merci d'avance

lebuss@yahoo.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5182651
Bonjour.
Une macro à l'ouverture du classeur, peut-être ?
Cordialement.
Daniel
"LeBuss" 47d8edac$0$22588$
Salut, à tous, j'ai des cellules qui contiennent une formule avec des si
imbriqués. Comme suit :

=SI(W125="";"";SI(X125="G10/10";(Y125+0,02)*Z125/1000*AA125/1000*7,85/AB125;SI(X125="G7/7";(Y125+0,014)*Z125/1000*AA125/1000*7,85/AB125;SI(X125="Sans";Y125*Z125/1000*AA125/1000*7,85/AB125;SI(X125="Nu";Y125*Z125/1000*AA125/1000*7,85/AB125)))))

Je me suis aperçu quand rechargeant mon fichier, excel se plante à la
sauvegarde. J'ai donc constater que sur plusieurs cellules de ma colonne,
la grosse formule ci dessus se transforme en :

=COLONNE(W134="";"";SI(X134="G10/10";(Y134+0,02)*Z134/1000*AA134/1000*7,85/AB134;SI(X134="G7/7";(Y134+0,014)*Z134/1000*AA134/1000*7,85/AB134;SI(X134="Sans";Y134*Z134/1000*AA134/1000*7,85/AB134;SI(X134="Nu";Y134*Z134/1000*AA134/1000*7,85/AB134)))))

Le SI est devenu COLONNE ??

Si qqun a une idée ??

Merci d'avance




LeBuss
Le #5230491
Bonjour.
Une macro à l'ouverture du classeur, peut-être ?
Cordialement.
Daniel
"LeBuss" 47d8edac$0$22588$
Salut, à tous, j'ai des cellules qui contiennent une formule avec des si
imbriqués. Comme suit :

=SI(W125="";"";SI(X125="G10/10";(Y125+0,02)*Z125/1000*AA125/1000*7,85/AB125;SI(X125="G7/7";(Y125+0,014)*Z125/1000*AA125/1000*7,85/AB125;SI(X125="Sans";Y125*Z125/1000*AA125/1000*7,85/AB125;SI(X125="Nu";Y125*Z125/1000*AA125/1000*7,85/AB125)))))

Je me suis aperçu quand rechargeant mon fichier, excel se plante à la
sauvegarde. J'ai donc constater que sur plusieurs cellules de ma colonne,
la grosse formule ci dessus se transforme en :

=COLONNE(W134="";"";SI(X134="G10/10";(Y134+0,02)*Z134/1000*AA134/1000*7,85/AB134;SI(X134="G7/7";(Y134+0,014)*Z134/1000*AA134/1000*7,85/AB134;SI(X134="Sans";Y134*Z134/1000*AA134/1000*7,85/AB134;SI(X134="Nu";Y134*Z134/1000*AA134/1000*7,85/AB134)))))

Le SI est devenu COLONNE ??

Si qqun a une idée ??

Merci d'avance





NON, j'ai vérifié



Jacky
Le #5230461
Bonsoir,

Teste en copiant cette feuille dans un fichier tout neuf.

--
Salutations
JJ


"LeBuss" 47d8edac$0$22588$
Salut, à tous, j'ai des cellules qui contiennent une formule avec des si
imbriqués. Comme suit :

=SI(W125="";"";SI(X125="G10/10";(Y125+0,02)*Z125/1000*AA125/1000*7,85/AB125;SI(X125="G7/7";(Y125+0,014)*Z125/1000*AA125/1000*7,85/AB125;SI(X125="Sans";Y125*Z125/1000*AA125/1000*7,85/AB125;SI(X125="Nu";Y125*Z125/1000*AA125/1000*7,85/AB125)))))

Je me suis aperçu quand rechargeant mon fichier, excel se plante à la
sauvegarde. J'ai donc constater que sur plusieurs cellules de ma colonne,
la grosse formule ci dessus se transforme en :

=COLONNE(W134="";"";SI(X134="G10/10";(Y134+0,02)*Z134/1000*AA134/1000*7,85/AB134;SI(X134="G7/7";(Y134+0,014)*Z134/1000*AA134/1000*7,85/AB134;SI(X134="Sans";Y134*Z134/1000*AA134/1000*7,85/AB134;SI(X134="Nu";Y134*Z134/1000*AA134/1000*7,85/AB134)))))

Le SI est devenu COLONNE ??

Si qqun a une idée ??

Merci d'avance




Publicité
Poster une réponse
Anonyme