mois > 6 cellule = 0

Le
Sitting Hoax
Bonjour,
je n'arrive pas à résoudre un problème, le voici :
En A1, j'ai une date,
en dessous, cellule A2 j'ai une formule
que j'incrémente sur 300 lignes colonne A
en format date jjj-jj/mm/aaaa
(cela n'a pas d'importance, le problème persiste avec n'importe quel format
de date)

=SI(MOIS(A1+1)>6;0;A1+1)

cette formule est sensée mettre 0 dans la cellule
lorsque le mois de la date de la cellule est supérieur à 6
Or, le problème rencontré est que lorsque la formule renvoie 0,
la cellule en dessous reprend la date à partir du 1 janvier 1900,
ce qui se comprend vu la formule = 0.
Comment faire ? j'ai testé avec apostrophe, "", à la place du 0,
mais rien à faire.
A votre bon coeur M'sieurs Dames !
Amicalement
Siesting Hoax

Je voudrais arriver
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Michel Samoey
Le #5442101
Bonjour,
une question : si en A1 tu as 25/12/07, en A2 avec ta formule tu obtiens 0,
que désire tu obtenir en A3 ?
Cordialement
Michel
"Sitting Hoax" le message de news:
Bonjour,
je n'arrive pas à résoudre un problème, le voici :
En A1, j'ai une date,
en dessous, cellule A2 j'ai une formule
que j'incrémente sur 300 lignes colonne A
en format date jjj-jj/mm/aaaa
(cela n'a pas d'importance, le problème persiste avec n'importe quel
format de date)

=SI(MOIS(A1+1)>6;0;A1+1)

cette formule est sensée mettre 0 dans la cellule
lorsque le mois de la date de la cellule est supérieur à 6
Or, le problème rencontré est que lorsque la formule renvoie 0,
la cellule en dessous reprend la date à partir du 1 janvier 1900,
ce qui se comprend vu la formule = 0.
Comment faire ? j'ai testé avec apostrophe, "", à la place du 0,
mais rien à faire.
A votre bon coeur M'sieurs Dames !
Amicalement
Siesting Hoax

Je voudrais arriver




Sitting Hoax
Le #5441991
Bonjour,
0 bien sûr
en principe, la date en A1 démarre en janvier , ou autre mois, avant juin,
de façon à avoir une liste de dates qui s'arrête en juin.
Le reste de la liste sera rempli de 0
Un simple outil/Option/affichage/décocher valeur 0 me remet le calendrier au
propre.
Voili voilou ;-)
Amicalement
Siesting Hoax

"Michel Samoey" 4803680e$0$900$

Bonjour,
une question : si en A1 tu as 25/12/07, en A2 avec ta formule tu obtiens
0, que désire tu obtenir en A3 ?
Cordialement
Michel
"Sitting Hoax" dans le message de news:
Bonjour,
je n'arrive pas à résoudre un problème, le voici :
En A1, j'ai une date,
en dessous, cellule A2 j'ai une formule
que j'incrémente sur 300 lignes colonne A
en format date jjj-jj/mm/aaaa
(cela n'a pas d'importance, le problème persiste avec n'importe quel
format de date)

=SI(MOIS(A1+1)>6;0;A1+1)

cette formule est sensée mettre 0 dans la cellule
lorsque le mois de la date de la cellule est supérieur à 6
Or, le problème rencontré est que lorsque la formule renvoie 0,
la cellule en dessous reprend la date à partir du 1 janvier 1900,
ce qui se comprend vu la formule = 0.
Comment faire ? j'ai testé avec apostrophe, "", à la place du 0,
mais rien à faire.
A votre bon coeur M'sieurs Dames !
Amicalement
Siesting Hoax

Je voudrais arriver








Michel Samoey
Le #5441931
Bonjour,
=SI(OU(MOIS(A1+1)>6;JOUR(A1)=0);0;A1+1)
Cordialement
Michel

"Sitting Hoax" le message de news:
Bonjour,
0 bien sûr
en principe, la date en A1 démarre en janvier , ou autre mois, avant
juin,
de façon à avoir une liste de dates qui s'arrête en juin.
Le reste de la liste sera rempli de 0
Un simple outil/Option/affichage/décocher valeur 0 me remet le calendrier
au propre.
Voili voilou ;-)
Amicalement
Siesting Hoax

"Michel Samoey" 4803680e$0$900$

Bonjour,
une question : si en A1 tu as 25/12/07, en A2 avec ta formule tu obtiens
0, que désire tu obtenir en A3 ?
Cordialement
Michel
"Sitting Hoax" dans le message de news:
Bonjour,
je n'arrive pas à résoudre un problème, le voici :
En A1, j'ai une date,
en dessous, cellule A2 j'ai une formule
que j'incrémente sur 300 lignes colonne A
en format date jjj-jj/mm/aaaa
(cela n'a pas d'importance, le problème persiste avec n'importe quel
format de date)

=SI(MOIS(A1+1)>6;0;A1+1)

cette formule est sensée mettre 0 dans la cellule
lorsque le mois de la date de la cellule est supérieur à 6
Or, le problème rencontré est que lorsque la formule renvoie 0,
la cellule en dessous reprend la date à partir du 1 janvier 1900,
ce qui se comprend vu la formule = 0.
Comment faire ? j'ai testé avec apostrophe, "", à la place du 0,
mais rien à faire.
A votre bon coeur M'sieurs Dames !
Amicalement
Siesting Hoax

Je voudrais arriver












Sitting Hoax
Le #5441911
merci, effectivement,
ça marche bien, la valeur est bien 0
cependant, comment faire pour que cela ne marque plus une date, mais une
valeur "0" ou "" ?
regarde dans le fichier ci joint,
après le 1er juin
http://cjoint.com/?eosEJqxQWP

Amicalement
Siesting Hoax
"Michel Samoey" 48037d76$0$845$


Bonjour,
=SI(OU(MOIS(A1+1)>6;JOUR(A1)=0);0;A1+1)
Cordialement
Michel

"Sitting Hoax" dans le message de news:
Bonjour,
0 bien sûr
en principe, la date en A1 démarre en janvier , ou autre mois, avant
juin,
de façon à avoir une liste de dates qui s'arrête en juin.
Le reste de la liste sera rempli de 0
Un simple outil/Option/affichage/décocher valeur 0 me remet le calendrier
au propre.
Voili voilou ;-)
Amicalement
Siesting Hoax

"Michel Samoey" news: 4803680e$0$900$

Bonjour,
une question : si en A1 tu as 25/12/07, en A2 avec ta formule tu obtiens
0, que désire tu obtenir en A3 ?
Cordialement
Michel
"Sitting Hoax" dans le message de news:
Bonjour,
je n'arrive pas à résoudre un problème, le voici :
En A1, j'ai une date,
en dessous, cellule A2 j'ai une formule
que j'incrémente sur 300 lignes colonne A
en format date jjj-jj/mm/aaaa
(cela n'a pas d'importance, le problème persiste avec n'importe quel
format de date)

=SI(MOIS(A1+1)>6;0;A1+1)

cette formule est sensée mettre 0 dans la cellule
lorsque le mois de la date de la cellule est supérieur à 6
Or, le problème rencontré est que lorsque la formule renvoie 0,
la cellule en dessous reprend la date à partir du 1 janvier 1900,
ce qui se comprend vu la formule = 0.
Comment faire ? j'ai testé avec apostrophe, "", à la place du 0,
mais rien à faire.
A votre bon coeur M'sieurs Dames !
Amicalement
Siesting Hoax

Je voudrais arriver
















Patrick BASTARD
Le #5441901
Bonjour, *Sitting Hoax*

En A1 : 14/04/2008
Mois (A1+1) te donnera 4
Mois(A1)+1 te donnera 5

Cela répond-il à ta question ?

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.


Bonjour,
je n'arrive pas à résoudre un problème, le voici :
En A1, j'ai une date,
en dessous, cellule A2 j'ai une formule
que j'incrémente sur 300 lignes colonne A
en format date jjj-jj/mm/aaaa
(cela n'a pas d'importance, le problème persiste avec n'importe quel
format de date)

=SI(MOIS(A1+1)>6;0;A1+1)

cette formule est sensée mettre 0 dans la cellule
lorsque le mois de la date de la cellule est supérieur à 6
Or, le problème rencontré est que lorsque la formule renvoie 0,
la cellule en dessous reprend la date à partir du 1 janvier 1900,
ce qui se comprend vu la formule = 0.
Comment faire ? j'ai testé avec apostrophe, "", à la place du 0,
mais rien à faire.
A votre bon coeur M'sieurs Dames !
Amicalement
Siesting Hoax

Je voudrais arriver


Michel Samoey
Le #5441881
Bonjour,
=SI(C1="";"";SI(MOIS(C1+1)>6;"";C1+1))
Cordialement
Michel

"Sitting Hoax" le message de news: umw$
merci, effectivement,
ça marche bien, la valeur est bien 0
cependant, comment faire pour que cela ne marque plus une date, mais une
valeur "0" ou "" ?
regarde dans le fichier ci joint,
après le 1er juin
http://cjoint.com/?eosEJqxQWP

Amicalement
Siesting Hoax
"Michel Samoey" 48037d76$0$845$


Bonjour,
=SI(OU(MOIS(A1+1)>6;JOUR(A1)=0);0;A1+1)
Cordialement
Michel

"Sitting Hoax" dans le message de news:
Bonjour,
0 bien sûr
en principe, la date en A1 démarre en janvier , ou autre mois, avant
juin,
de façon à avoir une liste de dates qui s'arrête en juin.
Le reste de la liste sera rempli de 0
Un simple outil/Option/affichage/décocher valeur 0 me remet le
calendrier au propre.
Voili voilou ;-)
Amicalement
Siesting Hoax

"Michel Samoey" news: 4803680e$0$900$

Bonjour,
une question : si en A1 tu as 25/12/07, en A2 avec ta formule tu
obtiens 0, que désire tu obtenir en A3 ?
Cordialement
Michel
"Sitting Hoax" dans le message de news:
Bonjour,
je n'arrive pas à résoudre un problème, le voici :
En A1, j'ai une date,
en dessous, cellule A2 j'ai une formule
que j'incrémente sur 300 lignes colonne A
en format date jjj-jj/mm/aaaa
(cela n'a pas d'importance, le problème persiste avec n'importe quel
format de date)

=SI(MOIS(A1+1)>6;0;A1+1)

cette formule est sensée mettre 0 dans la cellule
lorsque le mois de la date de la cellule est supérieur à 6
Or, le problème rencontré est que lorsque la formule renvoie 0,
la cellule en dessous reprend la date à partir du 1 janvier 1900,
ce qui se comprend vu la formule = 0.
Comment faire ? j'ai testé avec apostrophe, "", à la place du 0,
mais rien à faire.
A votre bon coeur M'sieurs Dames !
Amicalement
Siesting Hoax

Je voudrais arriver




















Sitting Hoax
Le #5441871
non,
merci Patrick,
je n'ai pas mis =MOIS(A1+1),
j'ai mis =SI(MOISA1+1>6;0;A1+1)

le but est d'obtenir qu'à partir du 31 juin, la colonne ne contienne plus
que des 0
29 juin2008
30 juin2008
31 juin 2008
0
0
0
etc
ici, 31 juin+1= 1er juillet, donc, 0 dans la cellule

http://cjoint.com/?eosEJqxQWP

Pas si facile à obtenir hélas.
Siesting Hoax (beau soleil ce soir)

"Patrick BASTARD" message de news: %
Bonjour, *Sitting Hoax*

En A1 : 14/04/2008
Mois (A1+1) te donnera 4
Mois(A1)+1 te donnera 5

Cela répond-il à ta question ?

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.


Bonjour,
je n'arrive pas à résoudre un problème, le voici :
En A1, j'ai une date,
en dessous, cellule A2 j'ai une formule
que j'incrémente sur 300 lignes colonne A
en format date jjj-jj/mm/aaaa
(cela n'a pas d'importance, le problème persiste avec n'importe quel
format de date)

=SI(MOIS(A1+1)>6;0;A1+1)

cette formule est sensée mettre 0 dans la cellule
lorsque le mois de la date de la cellule est supérieur à 6
Or, le problème rencontré est que lorsque la formule renvoie 0,
la cellule en dessous reprend la date à partir du 1 janvier 1900,
ce qui se comprend vu la formule = 0.
Comment faire ? j'ai testé avec apostrophe, "", à la place du 0,
mais rien à faire.
A votre bon coeur M'sieurs Dames !
Amicalement
Siesting Hoax

Je voudrais arriver






Sitting Hoax
Le #5441841
Super,
exactement ce qu'il fallait,
bravo!
Il "suffisait" de trouver l'ordre des conditions,
C1="" manquait,
encore merci
Amicalement
Siesting Hoax

"Michel Samoey" 480391f1$0$881$

Bonjour,
=SI(C1="";"";SI(MOIS(C1+1)>6;"";C1+1))
Cordialement
Michel

"Sitting Hoax" dans le message de news: umw$
merci, effectivement,
ça marche bien, la valeur est bien 0
cependant, comment faire pour que cela ne marque plus une date, mais une
valeur "0" ou "" ?
regarde dans le fichier ci joint,
après le 1er juin
http://cjoint.com/?eosEJqxQWP

Amicalement
Siesting Hoax
"Michel Samoey" news: 48037d76$0$845$


Bonjour,
=SI(OU(MOIS(A1+1)>6;JOUR(A1)=0);0;A1+1)
Cordialement
Michel

"Sitting Hoax" dans le message de news:
Bonjour,
0 bien sûr
en principe, la date en A1 démarre en janvier , ou autre mois, avant
juin,
de façon à avoir une liste de dates qui s'arrête en juin.
Le reste de la liste sera rempli de 0
Un simple outil/Option/affichage/décocher valeur 0 me remet le
calendrier au propre.
Voili voilou ;-)
Amicalement
Siesting Hoax

"Michel Samoey" news: 4803680e$0$900$

Bonjour,
une question : si en A1 tu as 25/12/07, en A2 avec ta formule tu
obtiens 0, que désire tu obtenir en A3 ?
Cordialement
Michel
"Sitting Hoax" écrit dans le message de news:

Bonjour,
je n'arrive pas à résoudre un problème, le voici :
En A1, j'ai une date,
en dessous, cellule A2 j'ai une formule
que j'incrémente sur 300 lignes colonne A
en format date jjj-jj/mm/aaaa
(cela n'a pas d'importance, le problème persiste avec n'importe quel
format de date)

=SI(MOIS(A1+1)>6;0;A1+1)

cette formule est sensée mettre 0 dans la cellule
lorsque le mois de la date de la cellule est supérieur à 6
Or, le problème rencontré est que lorsque la formule renvoie 0,
la cellule en dessous reprend la date à partir du 1 janvier 1900,
ce qui se comprend vu la formule = 0.
Comment faire ? j'ai testé avec apostrophe, "", à la place du 0,
mais rien à faire.
A votre bon coeur M'sieurs Dames !
Amicalement
Siesting Hoax

Je voudrais arriver
























Patrick BASTARD
Le #5441821
Bonjour, *Sitting Hoax*

Ceci, peut-être :
http://cjoint.com/?eotSvOfOUL

Première date en E2
=SI(ESTERREUR(E2+1);"";SI(MIN(E2+1;H$2)>9630;"";MIN(E2+1;39630)))
39630 est la valeur du 1/7/2008 (format, nombre, standard).

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.

non,
merci Patrick,
je n'ai pas mis =MOIS(A1+1),
j'ai mis =SI(MOISA1+1>6;0;A1+1)

le but est d'obtenir qu'à partir du 31 juin, la colonne ne contienne
plus que des 0
29 juin2008
30 juin2008
31 juin 2008
0
0
0
etc
ici, 31 juin+1= 1er juillet, donc, 0 dans la cellule

http://cjoint.com/?eosEJqxQWP

Pas si facile à obtenir hélas.
Siesting Hoax (beau soleil ce soir)

"Patrick BASTARD" message de news: %
Bonjour, *Sitting Hoax*

En A1 : 14/04/2008
Mois (A1+1) te donnera 4
Mois(A1)+1 te donnera 5

Cela répond-il à ta question ?

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.


Bonjour,
je n'arrive pas à résoudre un problème, le voici :
En A1, j'ai une date,
en dessous, cellule A2 j'ai une formule
que j'incrémente sur 300 lignes colonne A
en format date jjj-jj/mm/aaaa
(cela n'a pas d'importance, le problème persiste avec n'importe quel
format de date)

=SI(MOIS(A1+1)>6;0;A1+1)

cette formule est sensée mettre 0 dans la cellule
lorsque le mois de la date de la cellule est supérieur à 6
Or, le problème rencontré est que lorsque la formule renvoie 0,
la cellule en dessous reprend la date à partir du 1 janvier 1900,
ce qui se comprend vu la formule = 0.
Comment faire ? j'ai testé avec apostrophe, "", à la place du 0,
mais rien à faire.
A votre bon coeur M'sieurs Dames !
Amicalement
Siesting Hoax

Je voudrais arriver






Sitting Hoax
Le #5441761
merci à toi aussi Patrick !:-)
ta formule marche aussi très bien, mais
=SI(C1="";"";SI(MOIS(C1+1)>6;"";C1+1))
me semble plus courte quand même.
De même, la formule ne marche plus si on modifie la
date en mettant par exemple 15/4/1953
Le fait d'employer un nombre en "dur" est assez délicat
(ce qui n'arrivera pas sur ce fichier de toute façon,
mais l'an prochain, il faudra encore modifier ce nombre)
A plus
merci encore
Amicalement
Siesting Hoax

"Patrick BASTARD" message de news: %
Bonjour, *Sitting Hoax*

Ceci, peut-être :
http://cjoint.com/?eotSvOfOUL

Première date en E2
=SI(ESTERREUR(E2+1);"";SI(MIN(E2+1;H$2)>9630;"";MIN(E2+1;39630)))
39630 est la valeur du 1/7/2008 (format, nombre, standard).

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.

non,
merci Patrick,
je n'ai pas mis =MOIS(A1+1),
j'ai mis =SI(MOISA1+1>6;0;A1+1)

le but est d'obtenir qu'à partir du 31 juin, la colonne ne contienne
plus que des 0
29 juin2008
30 juin2008
31 juin 2008
0
0
0
etc
ici, 31 juin+1= 1er juillet, donc, 0 dans la cellule

http://cjoint.com/?eosEJqxQWP

Pas si facile à obtenir hélas.
Siesting Hoax (beau soleil ce soir)

"Patrick BASTARD" message de news: %
Bonjour, *Sitting Hoax*

En A1 : 14/04/2008
Mois (A1+1) te donnera 4
Mois(A1)+1 te donnera 5

Cela répond-il à ta question ?

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.


Bonjour,
je n'arrive pas à résoudre un problème, le voici :
En A1, j'ai une date,
en dessous, cellule A2 j'ai une formule
que j'incrémente sur 300 lignes colonne A
en format date jjj-jj/mm/aaaa
(cela n'a pas d'importance, le problème persiste avec n'importe quel
format de date)

=SI(MOIS(A1+1)>6;0;A1+1)

cette formule est sensée mettre 0 dans la cellule
lorsque le mois de la date de la cellule est supérieur à 6
Or, le problème rencontré est que lorsque la formule renvoie 0,
la cellule en dessous reprend la date à partir du 1 janvier 1900,
ce qui se comprend vu la formule = 0.
Comment faire ? j'ai testé avec apostrophe, "", à la place du 0,
mais rien à faire.
A votre bon coeur M'sieurs Dames !
Amicalement
Siesting Hoax

Je voudrais arriver










Publicité
Poster une réponse
Anonyme