Mon hébergeur m'inquiète...

Le
Gerardel
Bonjour,
Je reçois de mon hébergeur OVH ce mail inquiétant :
=
Bonjour,
Vous avez actuellement un ou plusieurs Hébergement(s) Web qui
utilise(nt) le langage PHP pour des pages web.

Dans un souci d'amélioration et de sécurisation des services OVH, nous
sensibilisons nos clients sur l'abandon des anciennes
versions de PHP, qui ne sont plus maintenues par l'éditeur.

Cela concerne actuellement les versions PHP 4 ainsi que 5.3 et
inférieures.

Il est possible que, dans le futur, nous soyons contraints de ne plus
supporter ces versions obsolètes. Ainsi, il est recommandé
de veiller à la mise à jour régulière de vos pages.

Vous pourrez suivre la planification d'éventuelles actions via la tâche
travaux : http://travaux.ovh.net/?doÞtails&id455

Certains de vos sites utilisent une version obsolète de PHP. Nous vous
conseillons donc de migrer vers une version plus récente,
idéalement PHP 5.5 ou 5.6.

Vous trouverez ci-dessous le(s) site(s) concerné(s) :

- gerard-delassus.com utilise actuellement:
- PHP 4

Le support OVH ne pourra pas effectuer les opérations nécessaires sur
votre site, du fait du caractère unique de chaque

configuration.

Pour vous aider dans la vérification de votre configuration PHP, et sa
mise à jour au besoin, un guide est à votre disposition :

https://www.ovh.com/fr/g1207.php-ovh

Par ailleurs, l'utilisation d'une version PHP à jour vous permettra de
profiter pleinement des dernières innovations, comme

l'optimisation PHP-FPM : https://www.ovh.com/fr/g1175.php-fpm

Merci de votre compréhension.


Les explications d'OVH laissent penser que la migration pourrait être
compliquée.
Je n'ai plus trop envie de mettre les mains dans le cambouis, et j'ai
peur de tout casser si j'entre dans des procédures que je ne maîtrise
pas vraiment.
Peut-être faudrait-il que je reparte sur des bases entièrement
nouvelles ?
Y'a pas un truc préfabriqué qui pourrait le faire ?
Merci !

--

GD
https://soundcloud.com/g-rard-delassus/sets
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Otomatic
Le #26346909
Gerardel
Les explications d'OVH laissent penser que la migration pourrait être
compliquée.


Vous installez un serveur local et vous regardez ce qui se passe si vous
utilisez une version PHP >= 5.3.0, l'idéal serait 5.5.23 et/ou 5.6.7.
--
Ce n'est pas parce qu'ils sont nombreux à avoir tort
qu'ils ont forcément raison. Coluche
SAM
Le #26346914
Le 31/03/15 18:32, Otomatic a écrit :
Gerardel
Les explications d'OVH laissent penser que la migration pourrait être
compliquée.


Vous installez un serveur local et vous regardez ce qui se passe si vous
utilisez une version PHP >= 5.3.0, l'idéal serait 5.5.23 et/ou 5.6.7.




Je me demande si OVH ne veux pas se débarrasser de ses "petits" clients ?

J'ai un ami qui y a un site (en simple html) qui n'y fonctionne plus
(il faut des plombes pour en obtenir une simple page)
OVH propose là aussi de migrer vers ... un serveur bien mystérieux


Cordialement,
--
Stéphane Moriaux avec/with iMac-intel 27" & Mac OS X 10.6.8
Sergio
Le #26346913
Le 31/03/2015 18:26, Gerardel a écrit :
Bonjour,
Je reçois de mon hébergeur OVH ce mail inquiétant :
================================= > Bonjour,
Vous avez actuellement un ou plusieurs Hébergement(s) Web qui utilise(nt) le langage PHP pour des pages web.

Dans un souci d'amélioration et de sécurisation des services OVH, nous sensibilisons nos clients sur l'abandon des anciennes
versions de PHP, qui ne sont plus maintenues par l'éditeur.

Cela concerne actuellement les versions PHP 4 ainsi que 5.3 et inférieures.

Il est possible que, dans le futur, nous soyons contraints de ne plus supporter ces versions obsolètes. Ainsi, il est recommandé
de veiller à la mise à jour régulière de vos pages.

Vous pourrez suivre la planification d'éventuelles actions via la tâche travaux : http://travaux.ovh.net/?doÞtails&id455

Certains de vos sites utilisent une version obsolète de PHP. Nous vous conseillons donc de migrer vers une version plus récente,
idéalement PHP 5.5 ou 5.6.



Bizarre, chez Free, ils ne disent rien (PHP 5.1 beta maison). :-/


--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Gerardel
Le #26346937
Otomatic a écrit :
Gerardel
Les explications d'OVH laissent penser que la migration pourrait être
compliquée.


Vous installez un serveur local et vous regardez ce qui se passe si vous
utilisez une version PHP >= 5.3.0, l'idéal serait 5.5.23 et/ou 5.6.7.



OK, merci !
Je dois avoir un vieux Wampserver 2 qui traîne dans un coin du bureau.
Il n'a pas servi depuis des années, va falloir que je m'y remette... :(

--

GD
https://soundcloud.com/g-rard-delassus/sets
Gerardel
Le #26346936
SAM a écrit :

Je me demande si OVH ne veux pas se débarrasser de ses "petits" clients ?



La petite startup roubaisienne a tellement grandi qu'ils auraient pris
la grosse tête ?

J'ai un ami qui y a un site (en simple html) qui n'y fonctionne plus
(il faut des plombes pour en obtenir une simple page)
OVH propose là aussi de migrer vers ... un serveur bien mystérieux



Ils ne me proposent pas de changer de serveur, et pour le moment mon
site - assez rudimentaire - semble encore fonctionner normalement...

--

GD
https://soundcloud.com/g-rard-delassus/sets
JC_Et
Le #26346957
*Bonjour*, Le 31/03/2015 18:57, SAM a écrit :

xxxxdelassus.com utilise actuellement:
- PHP 4



Je me demande si OVH ne veux pas se débarrasser de ses "petits" clients ?



La branche PHP 4 est morte et enterrée depuis le 08/08/2008
Faut peut être se réveiller ;)
- la branche 5.3.x est en fin de vie donc à ne plus utiliser (depuis le
14/08/2014)
les versions stables sont
- la branche 5.4.x (5.4.39) 20/03/2015
- la branche 5.5.x 5.5.23) 20/03/2015 à conseiller très sur
- la branche 5.6.x (5.6.7) 20/03/2015 à conseiller


--
JC E.
Otomatic
Le #26346986
Gerardel
Je dois avoir un vieux Wampserver 2 qui traîne dans un coin du bureau.
Il n'a pas servi depuis des années, va falloir que je m'y remette... :(


Sur un Wampserver 2.0x, vous ne pourrez pas faire tourner PHP 5.5.x ou
5.6.x.
--
Ce n'est pas parce qu'ils sont nombreux à avoir tort
qu'ils ont forcément raison. Coluche
SAM
Le #26346996
Le 01/04/15 09:32, Otomatic a écrit :
Gerardel
Je dois avoir un vieux Wampserver 2 qui traîne dans un coin du bureau.
Il n'a pas servi depuis des années, va falloir que je m'y remette... :(


Sur un Wampserver 2.0x, vous ne pourrez pas faire tourner PHP 5.5.x ou
5.6.x.



Faut-il vraiment tester chez soi ?
Il doit bien il y avoir des fonctions PHP.4 conservées dans le PHP.5.5/6
??
Ne suffit-il pas que le site n'utilise que ces fonctions pour être alors
"compatible" avec le *"nouveau"* système ?

Et pi d'abord : comment il fait OVH pour savoir quelle "version" de PHP
est utilisée par le site (mutualisé ?)

Cordialement,
--
Stéphane Moriaux avec/with iMac-intel 27" & Mac OS X 10.6.8
Otomatic
Le #26347003
SAM
Il doit bien il y avoir des fonctions PHP.4 conservées dans le PHP.5.5/6


Oui, bien sûr mais il y a aussi des fonctions qui sont supprimées et
d'autres modifiées.
Ne suffit-il pas que le site n'utilise que ces fonctions pour être alors
"compatible" avec le *"nouveau"* système ?


Mais, comment le savoir ? Sinon en effectuant des essais avant.

Et pi d'abord : comment il fait OVH pour savoir quelle "version" de PHP
est utilisée par le site (mutualisé ?)


Mutualisé = versions PHP et MySQL mises en place par l"hébergeur.
--
Envoyé depuis mon Apple ][ Europlus et
Carte Appletell en 1200/75 bauds réversible.
Denis Beauregard
Le #26347028
Le Wed, 01 Apr 2015 10:47:01 +0200, SAM
fr.comp.infosystemes.www.auteurs:

Le 01/04/15 09:32, Otomatic a écrit :
Gerardel
Je dois avoir un vieux Wampserver 2 qui traîne dans un coin du bureau.
Il n'a pas servi depuis des années, va falloir que je m'y remette... :(


Sur un Wampserver 2.0x, vous ne pourrez pas faire tourner PHP 5.5.x ou
5.6.x.



Faut-il vraiment tester chez soi ?
Il doit bien il y avoir des fonctions PHP.4 conservées dans le PHP.5.5/6
??



Le problème, ce sont les fonctions de 4 qui ne sont plus dans les 5.5
ou 5.6 !!!

Ne suffit-il pas que le site n'utilise que ces fonctions pour être alors
"compatible" avec le *"nouveau"* système ?

Et pi d'abord : comment il fait OVH pour savoir quelle "version" de PHP
est utilisée par le site (mutualisé ?)



On scanne et on trouve que telle fonction est utilisée dans le code.
Ou encore, on ne fait rien et on envoie le même message à tous ceux
qui n'ont pas modifié leur code depuis x années.


Denis
Publicité
Poster une réponse
Anonyme