montage d'un dd contenant win xp sous linux

Le
olivier
Bonjour,

Depuis 2 jours mon père n'arrive plus à utiliser son ordinateur sous xp !
Au démarrage de l'ordinateur, celui-ci boot sur xp et le logo de windows
xp apparaît bien. Donc a priori windows se charge correctement. Sauf
qu'au bout d'un moment il affiche un écran noir pendant une quinzaine de
secondes puis reboot.
Ce problème est arrivé du jour au lendemain sans qu'il n'ait rien touché
(ni installation de pilotes, ni maj du système etc). Seul win xp est
installé sur son système !

Je voudrais récupérer des données importantes sur son dd.

J'ai alors branché son disque dur sur mon ordinateur (sous debian lenny).
Je le monte dans le répertoire home/oliv/win avec la commande :
#mount -fs /dev/hdb ~/win
le montage se déroule correctement sauf que je n'ai aucun fichier dans
le répertoire cible (~/win)

Et lorsque je tape la commande dmesg j'obtiens ceci :

NTFS-fs warning (device hdb) : is_boot_sector_ntfs () : invalid boot
sector checksum
NTFS-fs error (device hdb) : read_ntfs_boot_sector () : primary boot
sector is invalid
NTFS-fs error (device hdb) : read_ntfs_boot_sector () : mount option
errors : recover not used. Aborting without trying to recover
NTFS-fs error (device hdb) : ntfs_fill_super () : not an ntfs volume

Comment faire pour avoir accès à ses fichiers ? Est-ce possible ? Le
disque dur est-il HS ?

Merci pour vos réponses

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pierre Meurisse
Le #17813981
Bonjour,

Depuis 2 jours mon père n'arrive plus à utiliser son ordinateur sous xp !
Au démarrage de l'ordinateur, celui-ci boot sur xp et le logo de windows
xp apparaît bien. Donc a priori windows se charge correctement. Sauf
qu'au bout d'un moment il affiche un écran noir pendant une quinzaine de
secondes puis reboot.
Ce problème est arrivé du jour au lendemain sans qu'il n'ait rien touché
(ni installation de pilotes, ni maj du système etc...). Seul win xp est
installé sur son système !

Je voudrais récupérer des données importantes sur son dd.

J'ai alors branché son disque dur sur mon ordinateur (sous debian lenny).
Je le monte dans le répertoire home/oliv/win avec la commande :
#mount -fs /dev/hdb ~/win
le montage se déroule correctement sauf que je n'ai aucun fichier dans
le répertoire cible (~/win)

Et lorsque je tape la commande dmesg j'obtiens ceci :

NTFS-fs warning (device hdb) : is_boot_sector_ntfs () : invalid boot
sector checksum
NTFS-fs error (device hdb) : read_ntfs_boot_sector () : primary boot
sector is invalid
NTFS-fs error (device hdb) : read_ntfs_boot_sector () : mount option
errors : recover not used. Aborting without trying to recover
NTFS-fs error (device hdb) : ntfs_fill_super () : not an ntfs volume

Comment faire pour avoir accès à ses fichiers ? Est-ce possible ? Le
disque dur est-il HS ?



d'abord il faut voir quelles partitions il y a sur le disque :

# fdisk -l /dev/hdb

Tu trouveras sans doute une ou plusieurs partition(s) NTFS sur /dev/hdb1
ou /dev/hdb2 ...

ensuite, par exemple :

# ntfsmount /dev/hdb2 /mnt

ntfsmount fait partie du paquet ntfsprogs.

Bon courage.

--
Pierre Meurisse

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
François Boisson
Le #17814301
Le Tue, 11 Nov 2008 20:45:24 +0100
olivier
Bonjour,

Depuis 2 jours mon père n'arrive plus à utiliser son ordinateur sous xp !
Au démarrage de l'ordinateur, celui-ci boot sur xp et le logo de windows
xp apparaît bien. Donc a priori windows se charge correctement. Sauf
qu'au bout d'un moment il affiche un écran noir pendant une quinzaine de
secondes puis reboot.
Ce problème est arrivé du jour au lendemain sans qu'il n'ait rien touché
(ni installation de pilotes, ni maj du système etc...). Seul win xp est
installé sur son système !

Je voudrais récupérer des données importantes sur son dd.

J'ai alors branché son disque dur sur mon ordinateur (sous debian lenny).
Je le monte dans le répertoire home/oliv/win avec la commande :
#mount -fs /dev/hdb ~/win
le montage se déroule correctement sauf que je n'ai aucun fichier dans
le répertoire cible (~/win)

Et lorsque je tape la commande dmesg j'obtiens ceci :

NTFS-fs warning (device hdb) : is_boot_sector_ntfs () : invalid boot
sector checksum
NTFS-fs error (device hdb) : read_ntfs_boot_sector () : primary boot
sector is invalid
NTFS-fs error (device hdb) : read_ntfs_boot_sector () : mount option
errors : recover not used. Aborting without trying to recover
NTFS-fs error (device hdb) : ntfs_fill_super () : not an ntfs volume

Comment faire pour avoir accès à ses fichiers ? Est-ce possible ? Le
disque dur est-il HS ?




1) Ton père utilise-t-il AVG? Si oui, une mise à jour récente considère
USER32.DLL comme un virus, c'est l'antivirus qui devient un virus, ça fait des
dégats parait-il...

2) Si tu utilises ntfs-3g, il y a des chances pour que la partition soit dans
un état second, dans un tel cas, ntfs ou ntfs-3g refusent de monter la
partition sauf avec une option -force:

# mount -t ntfs-3g -o force /dev/sda1 /mnt

François Boisson

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Grégory Bulot
Le #17816551
olivier +0100


J'ai alors branché son disque dur sur mon ordinateur (sous debian
lenny). Je le monte dans le répertoire home/oliv/win avec la
commande : #mount -fs /dev/hdb ~/win



c'est pas plutôt

mount -fs /dev/hdb1 ~/win

?

--

Cordialement
Grégory BULOT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme