montage gros disque externe USB2

Le
Akeu
Bonjour,
Je travaille sur un appareil qui utilise linux 2.6.18. L'appareil est
souvent hors de porté et on n'a donc rarement accès au port USB.
j'ai donc un disque dur externe de 700 Go USB ( partition en FAT32)
Lorsqu'on démarre l'appareil , on essaye de monter le disque mais on ne
peut pas!! Ce qui est bizarre c'est que fdisk voit bien la partition FAT
en /dev/sdb1 mais que /dev/sdb1 n'existe pas ( on a uniquement /dev/sdb)
Si je débranche le disque manuellement et que je le rebranche ça se
remet à marcher ( mais c'est long ).
Comme je n'ai pas accès au matériel normalement comment puis je
réinitialiser /dev/sdbxx
je pourrai passer par mknod /dev/sdb1 mais quoi mettre apres ?
Autrement une autre solution ?



J'ajoute que ça marche parfaitement avec une clé 2 Go .
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sergio
Le #18978571
Akeu a écrit :
Bonjour,
Je travaille sur un appareil qui utilise linux 2.6.18. L'appareil est
souvent hors de porté et on n'a donc rarement accès au port USB.
j'ai donc un disque dur externe de 700 Go USB ( partition en FAT32)
Lorsqu'on démarre l'appareil , on essaye de monter le disque mais on ne
peut pas!! Ce qui est bizarre c'est que fdisk voit bien la partition FAT
en /dev/sdb1 mais que /dev/sdb1 n'existe pas ( on a uniquement /dev/sdb)
Si je débranche le disque manuellement et que je le rebranche ça se
remet à marcher ( mais c'est long ).
Comme je n'ai pas accès au matériel normalement comment puis je
réinitialiser /dev/sdbxx
je pourrai passer par mknod /dev/sdb1 mais quoi mettre apres ?
Autrement une autre solution ?



Tiens... Problème avec les gros disques ? Ces temps-ci un gars a un
problème similaire dans fco.ms-windows avec un disque de 1 To, bien sûr
sous Windows.

Voir le thread "Terra...togène..." sur fco.ms-windows

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Akeu
Le #18979001
J'ajoute que le mknod b x y ( en utilisant les valeurs x et y adéquat ne
marche pas , on creé bien /deb/sdb1 mais impossible de monter le disque
le mieux serait de virtuellement enlever la connexion et de la remettre.

Le Wed, 25 Mar 2009 16:38:51 +0100, Akeu a écrit :

Bonjour,
Je travaille sur un appareil qui utilise linux 2.6.18. L'appareil est
souvent hors de porté et on n'a donc rarement accès au port USB. j'ai
donc un disque dur externe de 700 Go USB ( partition en FAT32) Lorsqu'on
démarre l'appareil , on essaye de monter le disque mais on ne peut pas!!
Ce qui est bizarre c'est que fdisk voit bien la partition FAT en /dev/sdb1
mais que /dev/sdb1 n'existe pas ( on a uniquement /dev/sdb) Si je
débranche le disque manuellement et que je le rebranche ça se remet à
marcher ( mais c'est long ). Comme je n'ai pas accès au matériel
normalement comment puis je réinitialiser /dev/sdbxx
je pourrai passer par mknod /dev/sdb1 mais quoi mettre apres ? Autrement
une autre solution ?



J'ajoute que ça marche parfaitement avec une clé 2 Go .


YBM
Le #18979711
Akeu a écrit :
Bonjour,
Je travaille sur un appareil qui utilise linux 2.6.18. L'appareil est
souvent hors de porté et on n'a donc rarement accès au port USB.
j'ai donc un disque dur externe de 700 Go USB ( partition en FAT32)
Lorsqu'on démarre l'appareil , on essaye de monter le disque mais on ne
peut pas!! Ce qui est bizarre c'est que fdisk voit bien la partition FAT
en /dev/sdb1 mais que /dev/sdb1 n'existe pas ( on a uniquement /dev/sdb)
Si je débranche le disque manuellement et que je le rebranche ça se
remet à marcher ( mais c'est long ).
Comme je n'ai pas accès au matériel normalement comment puis je
réinitialiser /dev/sdbxx
je pourrai passer par mknod /dev/sdb1 mais quoi mettre apres ?
Autrement une autre solution ?



À tout hasard :

partprobe /dev/sdb

(à faire en tant que root)
Doug713705
Le #18981991
Le Wed, 25 Mar 2009 17:41:49 +0100, Akeu a écrit dans
news: des mots en forme de phrase
pour nous dire :

le mieux serait de virtuellement enlever la connexion et de la remettre.



Décharger puis recharger les modules concernant l'USB ?

rmmod
--
@+
Doug - Linux user #307925 - Slamd64 roulaize ;-)
[ Plus ou moins avec une chance de peut-être ]
Akeu
Le #18992371
Je vais essayer ca.
Le Wed, 25 Mar 2009 23:30:46 +0100, Doug713705 a écrit :

Le Wed, 25 Mar 2009 17:41:49 +0100, Akeu a écrit dans
news: des mots en forme de phrase
pour nous dire :

le mieux serait de virtuellement enlever la connexion et de la remettre.



Décharger puis recharger les modules concernant l'USB ?

rmmod


Publicité
Poster une réponse
Anonyme