[MOSS 2007] - Pb d'import / export

Le
Houdini
Bonjour à toutes et à tous,

J'ai de petits soucis avec l'import / export via STSADM.

Contexte: j'ai créé une collection de sites "Semaines". Dans cette
collection, figurent un site principal et des sous-sites (ex:
http://serveur/semaines/cuisines), contenant des composants (webparts,
fichiers à télécharger)

Lorsque j'effectue un export du site principal via STSADM, tout va bien
(stsadm -o export -url http://serveur/semaines/cuisines -filename
F:bcksitescuisines.cmp -versions 1)

Je supprime le site et les sous-sites. Je fais un petit "iisreset" pour la
forme.
Je recréé un site vide (même structure que le précédent: dans site
d'entreprise, site vide) avec les information qui vont bien.

Je restore le site via stsadm -o import -url
http://serveur/semaines/cuisines -filename F:bcksitescuisines.cmp
-updateversions 1

L'import commence et m'insulte en m'indiquant qu'une feature reste
introuvable. Or, le numéro ID de cette feature ne correspond pas à rien:
impossible de la localiser sur le serveur. Extrait du message: "fatal error -
Unable to import list templates 20000".

Pour résultat: le site est indisponible et j'ai perdu tous les liens dans
les sites (bibliothèques de liens) et par conséquent, je perds l'accès aux
fichiers à télécharger.

Afin de ne pas laisser " le pot sous la vache", j'ai retenté l'opération en
supprimant au préalable les bibiothèques et les documents à télécharger et Ô
miracle, cela a parfaitement fonctionné. Pourquoi ????

Ma question est simple: comment faites-vous pour sauvegarder et restorer un
site et ses sous-sites avec du contenu à l'intérieur (bibliothèques, fichiers
divers, webparts) ? Je perds mon latin

Merci d'avance pour vos avis éclairés.
Cordialement,
Houdini
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sébastien PICAMELOT
Le #16944621
Bonjour,

la commande stsadm -o export / import provoque parfois des
dysfonctionnements lors de l'import. Celà provient du fonctionnement même de
la commande qui repose sur une sorte de scripts généré à partir du contenu du
site source (export), et qui va recréer les éléments dans le nouveau site les
uns après les autres (import). Puisque les éléments sont recrés, certaines
données sont modifiées. C'est le cas des ID d'élément de liste par exemple.
Et si les ID sont modifiés, alors d'autres colonnes sont impactées (comme les
colonnes LookUp par exemple).

Il existe des extensions pour la commande stsadm, dont une extension prenant
en compte les ID. Vous la trouverez ici :
http://stsadm.blogspot.com/2007/10/better-import.html. De manière générale,
jettez un coup d'oeil à ces extensions. Certaines commandes comme stsadm -o
moveweb pourraient vous donner des pistes de résolution. Vous trouverez
l'intégralité des commandes ici :
http://stsadm.blogspot.com/2007/08/stsadm-commands_09.html

Néanmoins, l'erreur que vous remontez me laisse penser qu'un modèle de site
personnalisé a été utilisé. Vérifiez que le ListTemplate provoquant l'erreur
n'est pas défini dans la gallerie des modèles de liste de votre site source.

J'espère que cette réponse vous aura aidé.

Cordialement,

--
Sébastien PICAMELOT
--------------------------------------
http://blogs.developpeur.org/gribouillon



"Houdini" a écrit :

Bonjour à toutes et à tous,

J'ai de petits soucis avec l'import / export via STSADM.

Contexte: j'ai créé une collection de sites "Semaines". Dans cette
collection, figurent un site principal et des sous-sites (ex:
http://serveur/semaines/cuisines), contenant des composants (webparts,
fichiers à télécharger)

Lorsque j'effectue un export du site principal via STSADM, tout va bien
(stsadm -o export -url http://serveur/semaines/cuisines -filename
F:bcksitescuisines.cmp -versions 1)

Je supprime le site et les sous-sites. Je fais un petit "iisreset" pour la
forme.
Je recréé un site vide (même structure que le précédent: dans site
d'entreprise, site vide) avec les information qui vont bien.

Je restore le site via stsadm -o import -url
http://serveur/semaines/cuisines -filename F:bcksitescuisines.cmp
-updateversions 1

L'import commence ... et m'insulte en m'indiquant qu'une feature reste
introuvable. Or, le numéro ID de cette feature ne correspond pas à rien:
impossible de la localiser sur le serveur. Extrait du message: "fatal error -
Unable to import list templates 20000".

Pour résultat: le site est indisponible et j'ai perdu tous les liens dans
les sites (bibliothèques de liens) et par conséquent, je perds l'accès aux
fichiers à télécharger.

Afin de ne pas laisser " le pot sous la vache", j'ai retenté l'opération en
supprimant au préalable les bibiothèques et les documents à télécharger et Ô
miracle, cela a parfaitement fonctionné. Pourquoi ????

Ma question est simple: comment faites-vous pour sauvegarder et restorer un
site et ses sous-sites avec du contenu à l'intérieur (bibliothèques, fichiers
divers, webparts) ? Je perds mon latin ...

Merci d'avance pour vos avis éclairés.
Cordialement,
Houdini


Houdini
Le #16944531
Bonjour Sébastien,

Merci pour ces liens que je ne connaissais pas.
Le problème, à l'heure actuelle, c'est que tous les serveurs de
développement ne sont pas tous configurés à l'identique et que chacun fait ce
qu'il veut et quand il faut basculer vers les serveurs de production ...
c'est la panique à bord. Il devait certainement rester quelque chose quelque
part, bien que sur tous les serveurs, il n'y ait aucune trace de cette
maudite list template.

Merci
Cordialement,
Houdini



"Sébastien PICAMELOT" a écrit :

Bonjour,

la commande stsadm -o export / import provoque parfois des
dysfonctionnements lors de l'import. Celà provient du fonctionnement même de
la commande qui repose sur une sorte de scripts généré à partir du contenu du
site source (export), et qui va recréer les éléments dans le nouveau site les
uns après les autres (import). Puisque les éléments sont recrés, certaines
données sont modifiées. C'est le cas des ID d'élément de liste par exemple.
Et si les ID sont modifiés, alors d'autres colonnes sont impactées (comme les
colonnes LookUp par exemple).

Il existe des extensions pour la commande stsadm, dont une extension prenant
en compte les ID. Vous la trouverez ici :
http://stsadm.blogspot.com/2007/10/better-import.html. De manière générale,
jettez un coup d'oeil à ces extensions. Certaines commandes comme stsadm -o
moveweb pourraient vous donner des pistes de résolution. Vous trouverez
l'intégralité des commandes ici :
http://stsadm.blogspot.com/2007/08/stsadm-commands_09.html

Néanmoins, l'erreur que vous remontez me laisse penser qu'un modèle de site
personnalisé a été utilisé. Vérifiez que le ListTemplate provoquant l'erreur
n'est pas défini dans la gallerie des modèles de liste de votre site source.

J'espère que cette réponse vous aura aidé.

Cordialement,

--
Sébastien PICAMELOT
--------------------------------------
http://blogs.developpeur.org/gribouillon



"Houdini" a écrit :

> Bonjour à toutes et à tous,
>
> J'ai de petits soucis avec l'import / export via STSADM.
>
> Contexte: j'ai créé une collection de sites "Semaines". Dans cette
> collection, figurent un site principal et des sous-sites (ex:
> http://serveur/semaines/cuisines), contenant des composants (webparts,
> fichiers à télécharger)
>
> Lorsque j'effectue un export du site principal via STSADM, tout va bien
> (stsadm -o export -url http://serveur/semaines/cuisines -filename
> F:bcksitescuisines.cmp -versions 1)
>
> Je supprime le site et les sous-sites. Je fais un petit "iisreset" pour la
> forme.
> Je recréé un site vide (même structure que le précédent: dans site
> d'entreprise, site vide) avec les information qui vont bien.
>
> Je restore le site via stsadm -o import -url
> http://serveur/semaines/cuisines -filename F:bcksitescuisines.cmp
> -updateversions 1
>
> L'import commence ... et m'insulte en m'indiquant qu'une feature reste
> introuvable. Or, le numéro ID de cette feature ne correspond pas à rien:
> impossible de la localiser sur le serveur. Extrait du message: "fatal error -
> Unable to import list templates 20000".
>
> Pour résultat: le site est indisponible et j'ai perdu tous les liens dans
> les sites (bibliothèques de liens) et par conséquent, je perds l'accès aux
> fichiers à télécharger.
>
> Afin de ne pas laisser " le pot sous la vache", j'ai retenté l'opération en
> supprimant au préalable les bibiothèques et les documents à télécharger et Ô
> miracle, cela a parfaitement fonctionné. Pourquoi ????
>
> Ma question est simple: comment faites-vous pour sauvegarder et restorer un
> site et ses sous-sites avec du contenu à l'intérieur (bibliothèques, fichiers
> divers, webparts) ? Je perds mon latin ...
>
> Merci d'avance pour vos avis éclairés.
> Cordialement,
> Houdini


Publicité
Poster une réponse
Anonyme