[MOSS 2007] Problème d'héritage.

Le
Houdini
Bonjour à toutes et à tous,

Je rencontre un problème étrange:

- Lorsque j'exporte un site (stsadm -o export) et que je précise le
paramètre "-includeusersecurity", ce dernier embarque les comptes et les
autorisations: ok

- Je supprime le site

Lorsque je l'importe par (stsadm -o) avec le même paramètre, cela fonctionne
et je retrouve bien les autorisations et les comptes.

Si j'omets de positionner ce paramètre à l'export comme à l'import, je
retrouve bien le site, mais les droits ont disparu et plus personne, sauf le
"farm administrateur" et l'Administrateur de la collection de sites ne
peuvent se connecter.

Normalement, le site une fois réimporté devrait récupérer ses droits par
héritage de la collection de sites. Alors comment faire pour forcer le site à
récupérer l'héritage de la collection ?

Pour bien comprendre: je créé un site, je mets des autorisations et des
groupes bidons. j'exporte sans le paramètre de sécurité. Des autorisations
existent au niveau collection, je supprime le site, je réimporte et paf, plus
personne peut se connecter sauf les admin

Si vous avez une idée
Cordialement,
Houdini.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Lognoul, Marc \(Private\)
Le #16944261
Bonjour,

Le comportement que vous décrivez me semble tout à fait normal:
Vous créez un site et briser héritage des permissions
Vous redéfinissez des permission spécifiques
Vous exportez ce site en excluant la sécurité
Vous supprimez ce site, ensuite vous le restaurez
Ce site est donc restauré avec l'héritage brisé (tel que configuré) mais
sans permission spécifique, excepté celles des administrateurs (Windows Farm
et site collection) bien entendu.

--
Marc
[Heureux celui qui a pu pénétrer les causes secrètes des choses]


"Houdini" news:
Bonjour à toutes et à tous,

Je rencontre un problème étrange:

- Lorsque j'exporte un site (stsadm -o export) et que je précise le
paramètre "-includeusersecurity", ce dernier embarque les comptes et les
autorisations: ok

- Je supprime le site

Lorsque je l'importe par (stsadm -o) avec le même paramètre, cela
fonctionne
et je retrouve bien les autorisations et les comptes.

Si j'omets de positionner ce paramètre à l'export comme à l'import, je
retrouve bien le site, mais les droits ont disparu et plus personne, sauf
le
"farm administrateur" et l'Administrateur de la collection de sites ne
peuvent se connecter.

Normalement, le site une fois réimporté devrait récupérer ses droits par
héritage de la collection de sites. Alors comment faire pour forcer le
site à
récupérer l'héritage de la collection ?

Pour bien comprendre: je créé un site, je mets des autorisations et des
groupes bidons. j'exporte sans le paramètre de sécurité. Des autorisations
existent au niveau collection, je supprime le site, je réimporte et paf,
plus
personne peut se connecter sauf les admin

Si vous avez une idée...
Cordialement,
Houdini.


Houdini
Le #16944251
Bonjour Marc,

Merci pour votre réponse, mais:

Dans une collection de site, j'ai des groupes, des users et des
autorisations. Je créé un site dans cette collection, je dois normalement
hériter des autorisations de la collection de site.

Si j'exporte le site, je dois normalement "embarquer" les autorisations
héritées, non ? Si je le réimporte, je devrais retrouver ces mêmes
autorisations, puisque le site est rattaché à la collection de site. A moins
que j'ai manqué quelque chose.

Cordialement,
Houdini

"Lognoul, Marc (Private)" a écrit :

Bonjour,

Le comportement que vous décrivez me semble tout à fait normal:
Vous créez un site et briser héritage des permissions
Vous redéfinissez des permission spécifiques
Vous exportez ce site en excluant la sécurité
Vous supprimez ce site, ensuite vous le restaurez
Ce site est donc restauré avec l'héritage brisé (tel que configuré) mais
sans permission spécifique, excepté celles des administrateurs (Windows Farm
et site collection) bien entendu.

--
Marc
[Heureux celui qui a pu pénétrer les causes secrètes des choses]


"Houdini" news:
> Bonjour à toutes et à tous,
>
> Je rencontre un problème étrange:
>
> - Lorsque j'exporte un site (stsadm -o export) et que je précise le
> paramètre "-includeusersecurity", ce dernier embarque les comptes et les
> autorisations: ok
>
> - Je supprime le site
>
> Lorsque je l'importe par (stsadm -o) avec le même paramètre, cela
> fonctionne
> et je retrouve bien les autorisations et les comptes.
>
> Si j'omets de positionner ce paramètre à l'export comme à l'import, je
> retrouve bien le site, mais les droits ont disparu et plus personne, sauf
> le
> "farm administrateur" et l'Administrateur de la collection de sites ne
> peuvent se connecter.
>
> Normalement, le site une fois réimporté devrait récupérer ses droits par
> héritage de la collection de sites. Alors comment faire pour forcer le
> site à
> récupérer l'héritage de la collection ?
>
> Pour bien comprendre: je créé un site, je mets des autorisations et des
> groupes bidons. j'exporte sans le paramètre de sécurité. Des autorisations
> existent au niveau collection, je supprime le site, je réimporte et paf,
> plus
> personne peut se connecter sauf les admin
>
> Si vous avez une idée...
> Cordialement,
> Houdini.




Lognoul, Marc \(Private\)
Le #16940541
Bonjour,


Si j'exporte le site, je dois normalement "embarquer" les autorisations
héritées, non ? Si je le réimporte, je devrais retrouver ces mêmes
autorisations, puisque le site est rattaché à la collection de site. A
moins
que j'ai manqué quelque chose.



Comme vous l'indiquiez ci dessous, à partir du moment ou vous avez, avant
exporter le site, brisé l'héritage, le permission ne seront restauré que si
vous avez pris soin d'inclure l'option "-includeusersecurity".
Si vous ne le faites pas, les permission du site collection ne vont pas se
re-propager "par magie (même si vous êtes houdini:)) puisque vous avez
retiré l'héritage.

> - Lorsque j'exporte un site (stsadm -o export) et que je précise le
> paramètre "-includeusersecurity", ce dernier embarque les comptes et
> les
> autorisations: ok
>
> - Je supprime le site
>
> Lorsque je l'importe par (stsadm -o) avec le même paramètre, cela
> fonctionne
> et je retrouve bien les autorisations et les comptes.





Par contre, si vous me dite qu'avec un site ou l'héritage n'est pas brisé et
que, lors d'une importation, les permissions supérieures ne sont pas
héritées, alors dans ce cas, cela peut s'avérer être une comportement
anormal.

--
Marc
[Heureux celui qui a pu pénétrer les causes secrètes des choses]
Publicité
Poster une réponse
Anonyme