[MOSS 2007 SP1]Pb de création de Record Center

Le
Oriane
Bonjour,

Je n'arrive pas à créer normalement le site "Record Center", à cause d'un pb
de droits, bien que sois admin.

Le message d'erreur:

"Accès refusé. à
Microsoft.SharePoint.Administration.SPPersistedObject.Update()
à Microsoft.SharePoint.Administration.SPService.Update()
à
Microsoft.Office.RecordsManagement.InformationPolicy.PolicyResourceCollection.Add(String
xmlManifest)
à
Microsoft.Office.RecordsManagement.RecordsRepository.Setup.EnsureSetupExpirationActions(SPWeb
web) "

Malgré cela le site est créé, mais le "Envoyer à RecorCenter" d'un doc
quelconque ne fonctionne pas, ce qui ne m'étonne qu'à moitié

Oriane
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sébastien PICAMELOT
Le #16977501
Bonjour,

j'ai déjà obtenu cette erreur, avec le site créé et la même anomalie lors
d'une tentative d'envoi au record center.

Ce problème n'est pas lié au SP1. Je suis navré de ne pas pouvoir vous
donner d'avantages d'information, je n'ai pas réussi à résoudre ce problème
rapidement et j'ai préféré recréer ma VPC à l'époque.

--
Sébastien PICAMELOT
--------------------------------------
http://blogs.developpeur.org/gribouillon



"Oriane" a écrit :

Bonjour,

Je n'arrive pas crer normalement le site "Record Center", cause d'un pb
de droits, bien que sois admin.

Le message d'erreur:

"Accs refus.
Microsoft.SharePoint.Administration.SPPersistedObject.Update()
Microsoft.SharePoint.Administration.SPService.Update()

Microsoft.Office.RecordsManagement.InformationPolicy.PolicyResourceCollection.Add(String
xmlManifest)

Microsoft.Office.RecordsManagement.RecordsRepository.Setup.EnsureSetupExpirationActions(SPWeb
web) "

Malgr cela le site est cr, mais le "Envoyer RecorCenter" d'un doc
quelconque ne fonctionne pas, ce qui ne m'tonne qu' moiti...

Oriane



Oriane
Le #16977491
Bonjour Sébastien,

"Sébastien PICAMELOT" dans le message de
news:
Bonjour,

j'ai déjà obtenu cette erreur, avec le site créé et la même anomalie lors
d'une tentative d'envoi au record center.


Oui je sais tu m'as déjà répondu...

Ce problème n'est pas lié au SP1. Je suis navré de ne pas pouvoir vous
donner d'avantages d'information, je n'ai pas réussi à résoudre ce
problème
rapidement et j'ai préféré recréer ma VPC à l'époque.


Alors en prod, sur une machine réelle, on fait comment :-( ?

Oriane
Sébastien PICAMELOT
Le #16977451
Je craignais cette réponse... j'ai cherché un peu sur le net et j'ai apperçu
pas mal de vos messages à ce sujet.

Je n'ai pas de réponse toute faite, mais j'aurai tendance à vous proposer de
monter un second environnement à partir d'un backup de celui de prod (juste
le backup issu de stsadm -o backup) histoire d'identifier la localisation du
problème (configuration SharePoint, configuration du serveur ou contexte
réseau). De là on devrait y voir un peu plus clair.

--
Sébastien PICAMELOT
--------------------------------------
http://blogs.developpeur.org/gribouillon



"Oriane" a écrit :

Bonjour Sébastien,

"Sébastien PICAMELOT" dans le message de
news:
> Bonjour,
>
> j'ai déjà obtenu cette erreur, avec le site créé et la même anomalie lors
> d'une tentative d'envoi au record center.
Oui je sais tu m'as déjà répondu...

> Ce problème n'est pas lié au SP1. Je suis navré de ne pas pouvoir vous
> donner d'avantages d'information, je n'ai pas réussi à résoudre ce
> problème
> rapidement et j'ai préféré recréer ma VPC à l'époque.
Alors en prod, sur une machine réelle, on fait comment :-( ?

Oriane



Pierre VIVIER-MERLE
Le #16977431
Bonjour Oriane,

Est-ce que le compte utilisateur utilisé pour créer le record center est
administrateur de la ferme Sharepoint ?

Pierre Vivier-Merle - MPV MOSS 2007
http://blogs.developpeur.org/pierre


"Oriane" discussion :
Bonjour,

Je n'arrive pas à créer normalement le site "Record Center", à cause d'un
pb
de droits, bien que sois admin.

Le message d'erreur:

"Accès refusé. à
Microsoft.SharePoint.Administration.SPPersistedObject.Update()
à Microsoft.SharePoint.Administration.SPService.Update()
à
Microsoft.Office.RecordsManagement.InformationPolicy.PolicyResourceCollection.Add(String
xmlManifest)
à
Microsoft.Office.RecordsManagement.RecordsRepository.Setup.EnsureSetupExpirationActions(SPWeb
web) "

Malgré cela le site est créé, mais le "Envoyer à RecorCenter" d'un doc
quelconque ne fonctionne pas, ce qui ne m'étonne qu'à moitié...

Oriane



Oriane
Le #16977421
"Sébastien PICAMELOT" dans le message de
news:
Je craignais cette réponse... j'ai cherché un peu sur le net et j'ai
apperçu
pas mal de vos messages à ce sujet.

Je n'ai pas de réponse toute faite, mais j'aurai tendance à vous proposer
de
monter un second environnement à partir d'un backup de celui de prod
(juste
le backup issu de stsadm -o backup) histoire d'identifier la localisation
du
problème (configuration SharePoint, configuration du serveur ou contexte
réseau). De là on devrait y voir un peu plus clair.


Oui si c'était vraiment crucial j'en passerais par là. Pour l'instant, on ne
me demande pas explicitement de le faire.

Vous voulez dire qu'il faudrait par exemple monter un second SSP ? Parce que
s'il faut monter un autre SharePoint, ca va me prendre 1/2 jours, il faudra
que je trouve une autre machine (je n'en ai pas sous la main)...bref grosse
"perte de temps"...

Merci de votre aide
Oriane
Le #16973871
Bonjour Pierre,

"Pierre VIVIER-MERLE" message de news:
Bonjour Oriane,

Est-ce que le compte utilisateur utilisé pour créer le record center est
administrateur de la ferme Sharepoint ?

Pierre Vivier-Merle - MPV MOSS 2007
http://blogs.developpeur.org/pierre


Eh bien je vais vérifier. Je dois dire que j'ai quelques soucis à ce niveau
parce que parfois je prend le compte system, parfois mon compte perso...
Normalement, j'ai les mêmes privilèges sous les deux comptes mais dans la
pratique certaines actions me sont refusées sous mon compte perso. C'ets
effectivement peut être de là que viens ce message "Accès refusé"...

Merci de votre aide
Pierre VIVIER-MERLE
Le #16973761
A priori, le problème doit venir de là : vous n'avez probablement pas tous
les droits au niveau de la ferme et au niveau du SSP (le SSP est un site
comme un autre, donc vérifier ses droits)

Pierre

----------------------------------------------------------------
Pierre Vivier-Merle - MVP MOSS 2007
http://blogs.developpeur.org/pierre


"Oriane" discussion :
Bonjour Pierre,

"Pierre VIVIER-MERLE" message de news:
Bonjour Oriane,

Est-ce que le compte utilisateur utilisé pour créer le record center est
administrateur de la ferme Sharepoint ?

Pierre Vivier-Merle - MPV MOSS 2007
http://blogs.developpeur.org/pierre


Eh bien je vais vérifier. Je dois dire que j'ai quelques soucis à ce
niveau parce que parfois je prend le compte system, parfois mon compte
perso... Normalement, j'ai les mêmes privilèges sous les deux comptes mais
dans la pratique certaines actions me sont refusées sous mon compte perso.
C'ets effectivement peut être de là que viens ce message "Accès refusé"...

Merci de votre aide


Oriane
Le #16973681
Bonjour,
"Pierre VIVIER-MERLE" message de news:
A priori, le problème doit venir de là : vous n'avez probablement pas tous
les droits au niveau de la ferme et au niveau du SSP (le SSP est un site
comme un autre, donc vérifier ses droits)


Comme je l'ai écrit je suis administrateur du SSP. Mais lorsque je m'y
connecte depuis une machine quelconque, l'accès m'est refusé... Lorsque je
m'y connecte sur le serveur c'est ok, mais certaines actions me sont
interdites (par ex, le lien "Stratégies de services de profil"). Il y a donc
là un dysfonctionnement.

J'ai réessayé de créer le RecordCenter avec mon compte et celui de l'admin
sur ma machine: échec.
J'ai essayé avec le compte admin sur le serveur MOSS: ca a marché !

Mais, le "envoyer vers" le Record center ne fonctionne toujours pas, que je
sois sur le serveur ou ailleurs.

Oriane
Pierre VIVIER-MERLE
Le #16973651
Je pense qu'il y a plusieurs facteurs qui se combinent,

. sur votre poste client, vous devez trainer deux identitées ce qui fait que
lorsque vous basculez de l'administration centrale vers le SSP, vous changer
votre identifiant : utilisez vous le "changer d'identité" au niveau du menu
sharepoint ?
Sur le serveur, à mon avis vous conservez l'identité admin car vous vous
loguez avec en session windows. D'où le fait que cela fonctionne.

. pour autoriser les personnes à envoyer sur le record center, il faut le
déclarer dans l'admin centrale et peut être positionner des sécurités. voir
le technet sur la paramétrage du record center

Bon courage,

Pierre

----------------------------------------------------------------
Pierre Vivier-Merle - MVP MOSS 2007
http://blogs.developpeur.org/pierre


"Oriane" a écrit :

Bonjour,
"Pierre VIVIER-MERLE" message de news:
>A priori, le problme doit venir de l : vous n'avez probablement pas tous
>les droits au niveau de la ferme et au niveau du SSP (le SSP est un site
>comme un autre, donc vrifier ses droits)
Comme je l'ai crit je suis administrateur du SSP. Mais lorsque je m'y
connecte depuis une machine quelconque, l'accs m'est refus... Lorsque je
m'y connecte sur le serveur c'est ok, mais certaines actions me sont
interdites (par ex, le lien "Stratgies de services de profil"). Il y a donc
l un dysfonctionnement.

J'ai ressay de crer le RecordCenter avec mon compte et celui de l'admin
sur ma machine: chec.
J'ai essay avec le compte admin sur le serveur MOSS: ca a march !

Mais, le "envoyer vers" le Record center ne fonctionne toujours pas, que je
sois sur le serveur ou ailleurs.

Oriane



Oriane
Le #16973601
"Pierre VIVIER-MERLE" dans le message de
news:
Je pense qu'il y a plusieurs facteurs qui se combinent,

. sur votre poste client, vous devez trainer deux identitées ce qui fait
que
lorsque vous basculez de l'administration centrale vers le SSP, vous
changer
votre identifiant : utilisez vous le "changer d'identité" au niveau du
menu
sharepoint ?


Oui.
A noter que sur le serveur j'ai aussi deux identités mais que sur le client
je me logge sur un compte Windows local au client.

Sur le serveur, à mon avis vous conservez l'identité admin car vous vous
loguez avec en session windows. D'où le fait que cela fonctionne.


Non je me connecte avec mon compte.

. pour autoriser les personnes à envoyer sur le record center, il faut le
déclarer dans l'admin centrale et peut être positionner des sécurités.
voir
le technet sur la paramétrage du record center


Ah ouiche !! Faut que je voye...

Bon courage,


Merci mais heureusement qu'on ne demande pas ca pour hier...
Publicité
Poster une réponse
Anonyme