Mot de passe d'un compte de connexion saute au redémarrage...

Le
Olivier B.
Bonjour,

J'ai actuellement un service (programme développé en C++) installé sur un
serveur Windows 2003 server R2.

Pour fonctionner, le programme nécessite un compte de connexion qui n'est
pas "system local". Je lui ai donc associé un compte administrateur local de
la machine (je précise que j'ai également essayé avec un compte
administrateur du domaine).
Ce compte dispose d'un mot de passe qui est enregistré en même temps que le
compte de connexion.

Or à chaque reboot de la machine, le service ne redémarre pas
automatiquement car le mot de passe est systématiquement effacé (du moins
j'ai le message comme quoi le compte n'est pas autorisé à lancer le service).

Je suis obligé de réenregistrer le mot de passe et le service repart. C'est
la seule action que je fait.

J'ai également essayé de recréer un nouveau compte administrateur de A à Z
mais rien n'y fait.

Quelqu'un aurait-il une piste ?

Cordialement
Olivier B.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Emmanuel Dreux
Le #17311101
Bonjour,

c'est probablement le privilège de s'exécuter en tant que service qui n'est
pas octroyé à votre compte.
Lorsque vous entrez le user/mot de passe dans l'interface graphique, ce
privilège est automatiquement octroyé au compte.
Dans votre cas, ça doit être réinitialisé lors de l'application des GPO
domaine ou locale.

Regardez donc au niveau des GPO à l'emplacement suivant:
Configuration OrdinateurParamètes WindowsParamètres de sécuritéStratégies
localesAttribution des droits utilisateursOuvrir une session en tant que
service.

Conseil: dans la mesure du possible, évitez de faire tourner vos services en
tant qu'admin du domaine ou admin local. Cette considération doit être prise
en compte dès la phase de développement.

--
Cordialement,
Emmanuel Dreux
http://www.ilinfo.fr


"Olivier B." a écrit :

Bonjour,

J'ai actuellement un service (programme développé en C++) installé sur un
serveur Windows 2003 server R2.

Pour fonctionner, le programme nécessite un compte de connexion qui n'est
pas "system local". Je lui ai donc associé un compte administrateur local de
la machine (je précise que j'ai également essayé avec un compte
administrateur du domaine).
Ce compte dispose d'un mot de passe qui est enregistré en même temps que le
compte de connexion.

Or à chaque reboot de la machine, le service ne redémarre pas
automatiquement car le mot de passe est systématiquement effacé (du moins
j'ai le message comme quoi le compte n'est pas autorisé à lancer le service).

Je suis obligé de réenregistrer le mot de passe et le service repart. C'est
la seule action que je fait.

J'ai également essayé de recréer un nouveau compte administrateur de A à Z
mais rien n'y fait.

Quelqu'un aurait-il une piste ?

Cordialement
Olivier B.


Olivier B.
Le #17313931
Je viens de contacter les personnes responsables de l'administration des
serveurs chez mon client, et ils n'ont mis en place aucun stratégie de groupe.

Quand à la stratégie locale du serveur, j'ai bien trouvé l'option dans
l'attribution des droits utilisateurs "Ouvrir une session en tant que
Service" mais impossible d'y ajouter un quelconque groupe (appliquer est
grisé)

Il est dit "Ce paramètre est incompatible avec les ordinateurs exécutant le
Service Pack 1 de Windows 2000 ou une session antérieure. N'appliquez les
objets Stratégie de groupe contenant ce paramètre qu'aux ordinateurs
exécutant une version ultérieure du système d'exploitation".

J'ai cherché dans les stratégies de groupe, j'avoue que je ne suis pas
spécialiste et je n'ai pas trouvé l'équivalent de l'option "Ouvrir une
session en tant que Service"

Cordialement
Olivier B.
Emmanuel Dreux
Le #17322581
Bizarre.

Le paramètre que vous avez trouvé est bien celui là.
J'imagine que vous n'avez pas pû le modifier à cause d'un problème de
permisisons et que le message d'erreur est erroné.

Demandez à vos administrateurs du domaine s'ils peuvent l'éditer.

Pour déterminer de quelle gpo provient la valeur (si c'est positionné par
GPO), vous pouvez lancer la commande gpresult /z ou rsop.msc.

--
Cordialement,
Emmanuel Dreux
http://www.ilinfo.fr


"Olivier B." a écrit :


Je viens de contacter les personnes responsables de l'administration des
serveurs chez mon client, et ils n'ont mis en place aucun stratégie de groupe.

Quand à la stratégie locale du serveur, j'ai bien trouvé l'option dans
l'attribution des droits utilisateurs "Ouvrir une session en tant que
Service" mais impossible d'y ajouter un quelconque groupe (appliquer est
grisé)

Il est dit "Ce paramètre est incompatible avec les ordinateurs exécutant le
Service Pack 1 de Windows 2000 ou une session antérieure. N'appliquez les
objets Stratégie de groupe contenant ce paramètre qu'aux ordinateurs
exécutant une version ultérieure du système d'exploitation".

J'ai cherché dans les stratégies de groupe, j'avoue que je ne suis pas
spécialiste et je n'ai pas trouvé l'équivalent de l'option "Ouvrir une
session en tant que Service"

Cordialement
Olivier B.


Publicité
Poster une réponse
Anonyme