Moyenne

Le
oliver
bonjour,
en colonne A, j'ai 52 semaines, en colonne B j'ai des valeurs copiées avec
liaison.
je fait la moyenne des douze dernières semaines sans problème à partir de la
semaine encours-1 semaine.
nous sommes en semaine 22 donc moyenne de la 21 à la 10.
je souhaiterai faire la moyenne de la 1ère semaine à la 9ème semaine mais
comme il n'y a pas de valeurs de la 22 à la 52ème semaine, j'ai #DIV0! la
formule suivante me renvoie #DIV0!
=sommeprod((semaine<10)*(B1:B51))/10-1)
Merci du coup de main
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Modeste
Le #6719941
Bonsour® oliver avec ferveur ;o))) vous nous disiez :

bonjour,
en colonne A, j'ai 52 semaines, en colonne B j'ai des valeurs copiées
avec liaison.
je fait la moyenne des douze dernières semaines sans problème à
partir de la semaine encours-1 semaine.
nous sommes en semaine 22 donc moyenne de la 21 à la 10.
je souhaiterai faire la moyenne de la 1ère semaine à la 9ème semaine
mais comme il n'y a pas de valeurs de la 22 à la 52ème semaine, j'ai
#DIV0! la formule suivante me renvoie #DIV0!
=sommeprod((semaine<10)*(B1:B51))/10-1)
Merci du coup de main
en colonne A des N°de semaines ???

alors :
=SOMMEPROD(((A2:A54)<semainecourante)*((A2:A54)>=MAX(1;(semainecouran te-12)))*(B2:B54)*(B2:B54<>0))/MIN(12;semainecourante)



--
--
@+
;o)))

Publicité
Poster une réponse
Anonyme