Moyenne

Le
j-marc
Bonjour a tous
j'aimerai savoir si c'est possible d'avoir une formule qui calcule la
moyenne conditionnelle en s'ajustant au nombre de cellules ne contenant pas
de 0 ou vide
ex: 2+2+2+2+2= (moyenne 10/5 ) OK =2
ex:: 2+2+2+2+0=? formule (moyenne 8/4) la formule s'ajusterait
automatiquement, si c'est possible pas de macro.
Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tatanka
Le #21429191
Salut j-marc,

En supposant que tes données soient en A1:A10, essaie cette formule :
=MOYENNE(SI(A1:A10<>0;A1:A10;""))
( à valider par Ctrl+Maj+Entrée )

Serge

"j-marc"
Bonjour a tous
j'aimerai savoir si c'est possible d'avoir une formule qui calcule la
moyenne conditionnelle en s'ajustant au nombre de cellules ne contenant pas
de 0 ou vide
ex: 2+2+2+2+2= (moyenne 10/5 ) OK =2
ex:: 2+2+2+2+0=? formule (moyenne 8/4) la formule s'ajusterait
automatiquement, si c'est possible pas de macro.
Merci
isabelle
Le #21429181
bonjour,

=SOMME(A1:A5)/NB.SI(A1:A5;"<>0")

isabelle

Le 2010-03-23 20:30, j-marc a écrit :
Bonjour a tous
j'aimerai savoir si c'est possible d'avoir une formule qui calcule la
moyenne conditionnelle en s'ajustant au nombre de cellules ne contenant pas
de 0 ou vide
ex: 2+2+2+2+2= (moyenne 10/5 ) OK =2
ex:: 2+2+2+2+0=? formule (moyenne 8/4) la formule s'ajusterait
automatiquement, si c'est possible pas de macro.
Merci

Tatanka
Le #21429171
Et avec XL 2007, il y a plus simple :
=MOYENNE.SI(A1:A10;"<>0")
( à valider par Entrée )
Je ne sais pas si cette fonction est disponible
dans les versions antérieures à 2007.

Serge


"Tatanka"
Salut j-marc,

En supposant que tes données soient en A1:A10, essaie cette formule :
=MOYENNE(SI(A1:A10<>0;A1:A10;""))
( à valider par Ctrl+Maj+Entrée )

Serge

"j-marc"
Bonjour a tous
j'aimerai savoir si c'est possible d'avoir une formule qui calcule la
moyenne conditionnelle en s'ajustant au nombre de cellules ne contenant pas
de 0 ou vide
ex: 2+2+2+2+2= (moyenne 10/5 ) OK =2
ex:: 2+2+2+2+0=? formule (moyenne 8/4) la formule s'ajusterait
automatiquement, si c'est possible pas de macro.
Merci




Tatanka
Le #21429201
Bonsoir Isabelle,

=SOMME(A1:A5)/NB.SI(A1:A5;"<>0")
Cette formule tient compte des cellules vides !

Serge


"isabelle" a écrit dans le message de news:
bonjour,

=SOMME(A1:A5)/NB.SI(A1:A5;"<>0")

isabelle

Le 2010-03-23 20:30, j-marc a écrit :
Bonjour a tous
j'aimerai savoir si c'est possible d'avoir une formule qui calcule la
moyenne conditionnelle en s'ajustant au nombre de cellules ne contenant pas
de 0 ou vide
ex: 2+2+2+2+2= (moyenne 10/5 ) OK =2
ex:: 2+2+2+2+0=? formule (moyenne 8/4) la formule s'ajusterait
automatiquement, si c'est possible pas de macro.
Merci

Daniel.C
Le #21430331
Bonjour.
Juste une petite précision : MOYENNE ne tient pas compte des cellules
vides (vraiment vides, pas celles qui contiennent une formule renvoyant
[""]).
Cordialement.
Daniel

Bonjour a tous
j'aimerai savoir si c'est possible d'avoir une formule qui calcule la
moyenne conditionnelle en s'ajustant au nombre de cellules ne contenant pas
de 0 ou vide
ex: 2+2+2+2+2= (moyenne 10/5 ) OK =2
ex:: 2+2+2+2+0=? formule (moyenne 8/4) la formule s'ajusterait
automatiquement, si c'est possible pas de macro.
Merci
j-marc
Le #21432621
Bonjour Tatanka

La formule avec excel 2007 fontionne très bien avec une plage de cellules.
y a t'il un moyen d'avoir une formule semblable si j'ai des cellules qui ne
se suivent pas
EX: a1 c24 d5 ect
J'ai essayer plusieurs choses mais je ne réussi pas

merci à l'avance


"Tatanka" wrote:

Et avec XL 2007, il y a plus simple :
=MOYENNE.SI(A1:A10;"<>0")
( à valider par Entrée )
Je ne sais pas si cette fonction est disponible
dans les versions antérieures à 2007.

Serge


"Tatanka" > Salut j-marc,
>
> En supposant que tes données soient en A1:A10, essaie cette formule :
> =MOYENNE(SI(A1:A10<>0;A1:A10;""))
> ( à valider par Ctrl+Maj+Entrée )
>
> Serge
>
> "j-marc" >> Bonjour a tous
>> j'aimerai savoir si c'est possible d'avoir une formule qui calcule la
>> moyenne conditionnelle en s'ajustant au nombre de cellules ne contenant pas
>> de 0 ou vide
>> ex: 2+2+2+2+2= (moyenne 10/5 ) OK =2
>> ex:: 2+2+2+2+0=? formule (moyenne 8/4) la formule s'ajusterait
>> automatiquement, si c'est possible pas de macro.
>> Merci
>
>


.

Publicité
Poster une réponse
Anonyme