Moyenne

Le
Erico
Comment faire la moyenne sur 20 lignes et que seuleemnt 5 lignes a une moyenne.
Actuellement, il fait la moyenne des "0" aussi.

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
papou
Le #5015001
Bonjour
=MOYENNE(SI(A1:A20<>0;A1:A20;0))

Valider la formule par Ctrl + Shift + Entrée

Cordialement
Pascal

"Erico"
Comment faire la moyenne sur 20 lignes et que seuleemnt 5 lignes a une
moyenne.
Actuellement, il fait la moyenne des "0" aussi.

Merci


Erico
Le #5014961
J'ai ceci et ça ne fonctionne pas plus
{=MOYENNE(SI(AG22:AG41<>0;AG22:AG41;0))}

Dans AG22 à AG41 j'ai la formulaire comme ceci:
=SI(AB30+AC30=0;0;(AD30+AC30)/AB30)
les résultats sont 0,00%
peut-etre à cause de ça???

Merci pour ton aide.




Bonjour
=MOYENNE(SI(A1:A20<>0;A1:A20;0))

Valider la formule par Ctrl + Shift + Entrée

Cordialement
Pascal

"Erico"
Comment faire la moyenne sur 20 lignes et que seuleemnt 5 lignes a une
moyenne.
Actuellement, il fait la moyenne des "0" aussi.

Merci







papou
Le #5014901
Erico
Je viens de faire des tests, la formule matricielle fonctionne même avec du
0%.
Il y a peut-être un autre problème ?

Cordialement
Pascal

"Erico"

J'ai ceci et ça ne fonctionne pas plus
{=MOYENNE(SI(AG22:AG41<>0;AG22:AG41;0))}

Dans AG22 à AG41 j'ai la formulaire comme ceci:
=SI(AB30+AC30=0;0;(AD30+AC30)/AB30)
les résultats sont 0,00%
peut-etre à cause de ça???

Merci pour ton aide.




Bonjour
=MOYENNE(SI(A1:A20<>0;A1:A20;0))

Valider la formule par Ctrl + Shift + Entrée

Cordialement
Pascal

"Erico" news:

Comment faire la moyenne sur 20 lignes et que seuleemnt 5 lignes a une
moyenne.
Actuellement, il fait la moyenne des "0" aussi.

Merci









isabelle
Le #5014831
bonjour Erico,

une autre méthode,

=SOMME(AG22:AG41)/NB.SI(AG22:AG41;">0")

isabelle

J'ai ceci et ça ne fonctionne pas plus
{=MOYENNE(SI(AG22:AG41<>0;AG22:AG41;0))}

Dans AG22 à AG41 j'ai la formulaire comme ceci:
=SI(AB30+AC30=0;0;(AD30+AC30)/AB30)
les résultats sont 0,00%
peut-etre à cause de ça???

Merci pour ton aide.





Bonjour
=MOYENNE(SI(A1:A20<>0;A1:A20;0))

Valider la formule par Ctrl + Shift + Entrée

Cordialement
Pascal

"Erico"

Comment faire la moyenne sur 20 lignes et que seuleemnt 5 lignes a une
moyenne.
Actuellement, il fait la moyenne des "0" aussi.

Merci









Tatanka
Le #5013911
Salut Erico,

Essaie ceci :
=MOYENNE(SI(AG22:AG41=0;"";AG22:AG41))
( à valider par Ctrl+Maj+Entrée )
et dans la formule d'Isabelle, ne devrait-on pas remplacer
0 par <> 0 ?
=SOMME(AG22:AG41)/NB.SI(AG22:AG41;"<>0")

( à valider par Entrée )

Serge

"Erico"
Comment faire la moyenne sur 20 lignes et que seuleemnt 5 lignes a une moyenne.
Actuellement, il fait la moyenne des "0" aussi.

Merci


Publicité
Poster une réponse
Anonyme