moyenne sans 0

Le
gerard
Bonjour,
situation : colonne A : 3 valeurs numériques en A1, A2 et A3
colonne B : 3 valeurs numériques en B1, B2 et B3
colonne C : B1-A1 en C1, B2-A2 en C2, B3-A3 en C3

maintenant : en D1, moyenne des 3 valeurs de la colonne A
en D2, moyenne des 3 valeurs de la colonne B
en D3, moyenne des 3 valeurs de la colonne C

Résultats : OK pour D1 et pour D2, par contre, si le résultat est nul e=
n C3, le "0" est pris en compte dans la moyenne, alors que les cellules vid=
es en A3 et B3 ne sont pas prises en compte.
Admettons que l'on donne des valeurs d'un mois sur l'autre, il faut attendr=
e que le 3ème mois soit renseigné pour avoir une moyenne correcte en C3=
.

Ma question est donc : comment faire pour que la moyenne à calculer ne ti=
enne pas compte d'un "0" qui n'est pas le résultat d'une soustraction, ma=
is l'attente de résultats à venir ? S'il vous plait, en évitant d'ent=
rer du VBA !
Merci pour vos conseils.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #26380227
bonjour,

=SOMME.SI(A1:A3;" ou
=MOYENNE.SI(A1:A3;"<>0") 'dépend de la version

isabelle

Le 2015-12-02 16:06, gerard a écrit :
Bonjour, situation : colonne A : 3 valeurs numériques en A1, A2 et A3 colonne
B : 3 valeurs numériques en B1, B2 et B3 colonne C : B1-A1 en C1, B2-A2 en
C2, B3-A3 en C3

maintenant : en D1, moyenne des 3 valeurs de la colonne A en D2, moyenne des
3 valeurs de la colonne B en D3, moyenne des 3 valeurs de la colonne C

Résultats : OK pour D1 et pour D2, par contre, si le résultat est nul en C3,
le "0" est pris en compte dans la moyenne, alors que les cellules vides en A3
et B3 ne sont pas prises en compte. Admettons que l'on donne des valeurs d'un
mois sur l'autre, il faut attendre que le 3ème mois soit renseigné pour avoir
une moyenne correcte en C3.

Ma question est donc : comment faire pour que la moyenne à calculer ne tienne
pas compte d'un "0" qui n'est pas le résultat d'une soustraction, mais
l'attente de résultats à venir ? S'il vous plait, en évitant d'entrer du VBA
! Merci pour vos conseils.

isabelle
Le #26380229
correction,
=SOMME(A1:A3)/NB.SI(A1:A3;"<>0")

isabelle

Le 2015-12-02 18:03, isabelle a écrit :
bonjour,

=SOMME.SI(A1:A3;" ou
=MOYENNE.SI(A1:A3;"<>0") 'dépend de la version

isabelle

Le 2015-12-02 16:06, gerard a écrit :
Bonjour, situation : colonne A : 3 valeurs numériques en A1, A2 et A3 colonne
B : 3 valeurs numériques en B1, B2 et B3 colonne C : B1-A1 en C1, B2-A2 en
C2, B3-A3 en C3

maintenant : en D1, moyenne des 3 valeurs de la colonne A en D2, moyenne des
3 valeurs de la colonne B en D3, moyenne des 3 valeurs de la colonne C

Résultats : OK pour D1 et pour D2, par contre, si le résultat est nul en C3,
le "0" est pris en compte dans la moyenne, alors que les cellules vides en A3
et B3 ne sont pas prises en compte. Admettons que l'on donne des valeurs d'un
mois sur l'autre, il faut attendre que le 3ème mois soit renseigné pour avoir
une moyenne correcte en C3.

Ma question est donc : comment faire pour que la moyenne à calculer ne tienne
pas compte d'un "0" qui n'est pas le résultat d'une soustraction, mais
l'attente de résultats à venir ? S'il vous plait, en évitant d'entrer du VBA
! Merci pour vos conseils.

JièL
Le #26380243
Hello Isabelle (de la Geôlière) ;-)

et si une valeur est = à 0 ?
Je pense (donc j'essuie) que gerard voudrait que les formules qui
renvoient 0 ne renvoient rien pour ne pas être comptées dans la moyenne,
du genre =SI(ESTVIDE(...);"";...)

Mébon, suis pas sur du tout

--
JièL passur


Le 03/12/2015 03:38, isabelle a écrit :
correction,
=SOMME(A1:A3)/NB.SI(A1:A3;"<>0")

isabelle

Le 2015-12-02 18:03, isabelle a écrit :
bonjour,

=SOMME.SI(A1:A3;" ou
=MOYENNE.SI(A1:A3;"<>0") 'dépend de la version

isabelle

Le 2015-12-02 16:06, gerard a écrit :
Bonjour, situation : colonne A : 3 valeurs numériques en A1, A2 et A3
colonne
B : 3 valeurs numériques en B1, B2 et B3 colonne C : B1-A1 en C1,
B2-A2 en
C2, B3-A3 en C3

maintenant : en D1, moyenne des 3 valeurs de la colonne A en D2,
moyenne des
3 valeurs de la colonne B en D3, moyenne des 3 valeurs de la colonne C

Résultats : OK pour D1 et pour D2, par contre, si le résultat est nul
en C3,
le "0" est pris en compte dans la moyenne, alors que les cellules
vides en A3
et B3 ne sont pas prises en compte. Admettons que l'on donne des
valeurs d'un
mois sur l'autre, il faut attendre que le 3ème mois soit renseigné
pour avoir
une moyenne correcte en C3.

Ma question est donc : comment faire pour que la moyenne à calculer
ne tienne
pas compte d'un "0" qui n'est pas le résultat d'une soustraction, mais
l'attente de résultats à venir ? S'il vous plait, en évitant d'entrer
du VBA
! Merci pour vos conseils.

Jacky
Le #26380260
Bonjour gerard,
... il faut attendre que le 3ème mois soit renseigné pour avoir une moyenne
correcte...



En D1==> =SI(NBVAL(A1:A3)=3;MOYENNE(A1:A3);"")
En D2==> =SI(NBVAL(B1:B3)=3;MOYENNE(B1:B3);"")
Eb D3==> =SI(NBVAL(A1:B3)=6;MOYENNE(C1:C3);"")
--
Salutations
JJ

gerard a exposé le 02/12/2015 :
Bonjour,
situation : colonne A : 3 valeurs numériques en A1, A2 et A3
colonne B : 3 valeurs numériques en B1, B2 et B3
colonne C : B1-A1 en C1, B2-A2 en C2, B3-A3 en C3

maintenant : en D1, moyenne des 3 valeurs de la colonne A
en D2, moyenne des 3 valeurs de la colonne B
en D3, moyenne des 3 valeurs de la colonne C

Résultats : OK pour D1 et pour D2, par contre, si le résultat est nul en C3,
le "0" est pris en compte dans la moyenne, alors que les cellules vides en A3
et B3 ne sont pas prises en compte. Admettons que l'on donne des valeurs d'un
mois sur l'autre, il faut attendre que le 3ème mois soit renseigné pour avoir
une moyenne correcte en C3.

Ma question est donc : comment faire pour que la moyenne à calculer ne tienne
pas compte d'un "0" qui n'est pas le résultat d'une soustraction, mais
l'attente de résultats à venir ? S'il vous plait, en évitant d'entrer du VBA
! Merci pour vos conseils.
isabelle
Le #26380262
salut JièL,

on peut ajouter 1 autre critère (NB.SI),

=SOMME(B1:B3)/(NB.SI(B1:B3;"<>0")-NB.SI(B1:B3;"="))

isabelle

Le 2015-12-03 04:13, JièL a écrit :
Hello Isabelle (de la Geôlière) ;-)

et si une valeur est = à 0 ?
Je pense (donc j'essuie) que gerard voudrait que les formules qui renvoient 0 ne
renvoient rien pour ne pas être comptées dans la moyenne, du genre
=SI(ESTVIDE(...);"";...)

Mébon, suis pas sur du tout

gerard
Le #26380306
Isabelle, Jièl et Jacky : un grand merci à vous 3 pour vos contribution s. Cela répond tout-à-fait à mon attente, d'autant plus que dans les faits le résultat de la soustraction effective n'est jamais égal à 0, ainsi "=MOYENNE.SI(A1:A3;"<>0")" est adapté à mon besoin actuel. Je note néanmoins les autres propositions. Enfin, je travaille avec Excel 20 07.
Encore merci et à une autre fois.
Gérard
Publicité
Poster une réponse
Anonyme