Moyenne selective d'une ligne avec des erreurs #VALEUR! ?

Le
fred
Bonjour,

Je suis coincé sur ce probleme:

Certaines de mes cellules de A1 à N1 renvoient l'erreur #VALEUR d'autres des
chiffres!
J'aimerais quand même pouvoir avoir une moyenne des cellules qui comportent
des chiffres.
J'ai essayé une fonction si mais c'est vite limité (à moins qu'il n'y ait
que des erreurs au debut ou bien à la fin)


Exemple:
http://cjoint.com/?ihrnwgKHyZ

Auriez-vous une solution ?

Merci d'avance ;)
Fred
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #16497431
Bonjour,
Une piste en gérant l'erreur dans la formule initiale (en A1:N1) par
=si(esterr(ta formule);"";ta formule) ; les "vides" générés ne perturbent
pas le calcul de la moyenne
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"fred" news:489b118d$0$27112$
Bonjour,

Je suis coincé sur ce probleme:

Certaines de mes cellules de A1 à N1 renvoient l'erreur #VALEUR d'autres
des chiffres!
J'aimerais quand même pouvoir avoir une moyenne des cellules qui
comportent des chiffres.
J'ai essayé une fonction si mais c'est vite limité (à moins qu'il n'y ait
que des erreurs au debut ou bien à la fin)


Exemple:
http://cjoint.com/?ihrnwgKHyZ

Auriez-vous une solution ?

Merci d'avance ;)
Fred




JB
Le #16497711
Bonjour,

=MOYENNE(SI(ESTNUM(A1:N1);A1:N1))
Valider avec Maj+ctrl+Entrée

JB
http://boisgontierjacques.free.fr

On 7 août, 17:26, "Philippe.R"
Bonjour,
Une piste en gérant l'erreur dans la formule initiale (en A1:N1) par
=si(esterr(ta formule);"";ta formule) ; les "vides" générés ne pe rturbent
pas le calcul de la moyenne
--
Avec plaisirhttp://dj.joss.free.fr/trombine.htmhttp://jacxl.free.fr/mpfe/ trombino.html
Philippe.R
Pour se connecter au forum :http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"fred"


> Bonjour,

> Je suis coincé sur ce probleme:

> Certaines de mes cellules de A1 à N1 renvoient l'erreur #VALEUR d'aut res
> des chiffres!
> J'aimerais quand même pouvoir avoir une moyenne des cellules qui
> comportent des chiffres.
> J'ai essayé une fonction si mais c'est vite limité (à moins qu'il n'y ait
> que des erreurs au debut ou bien à la fin)

> Exemple:
>http://cjoint.com/?ihrnwgKHyZ

> Auriez-vous une solution ?

> Merci d'avance ;)
> Fred- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


fred
Le #16497701
Bonjour Philipe,

Une piste en gérant l'erreur dans la formule initiale (en A1:N1) par
=si(esterreur(ta formule);"";ta formule) ; les "vides" générés ne
perturbent pas le calcul de la moyenne



Super! Merci ;)
Bonne fin de journée ;)
Fred
fred
Le #16497691
Bonjour JB,

=MOYENNE(SI(ESTNUM(A1:N1);A1:N1))
Valider avec Maj+ctrl+Entrée



Merci! Une question : comment arriver à faire valider "Maj+ctrl+Entrée"
dans une macro ?

Merci d'avance,
Fred
michdenis
Le #16497971
Validation matricielle :

Ctrl + Maj + enter et tu adaptes la plage de cellules.
=MOYENNE(SI(ESTNUM(A1:A5);A1:A5))



"fred" 489b118d$0$27112$
Bonjour,

Je suis coincé sur ce probleme:

Certaines de mes cellules de A1 à N1 renvoient l'erreur #VALEUR d'autres des
chiffres!
J'aimerais quand même pouvoir avoir une moyenne des cellules qui comportent
des chiffres.
J'ai essayé une fonction si mais c'est vite limité (à moins qu'il n'y ait
que des erreurs au debut ou bien à la fin)


Exemple:
http://cjoint.com/?ihrnwgKHyZ

Auriez-vous une solution ?

Merci d'avance ;)
Fred
michdenis
Le #16498131
En VBA, ceci donnerait ça :

Range("A10").FormulaArray = "=Average(If(IsNumber(A1:A5),A1:A5))"


"michdenis" OU0HOXK%
Validation matricielle :

Ctrl + Maj + enter et tu adaptes la plage de cellules.
=MOYENNE(SI(ESTNUM(A1:A5);A1:A5))



"fred" 489b118d$0$27112$
Bonjour,

Je suis coincé sur ce probleme:

Certaines de mes cellules de A1 à N1 renvoient l'erreur #VALEUR d'autres des
chiffres!
J'aimerais quand même pouvoir avoir une moyenne des cellules qui comportent
des chiffres.
J'ai essayé une fonction si mais c'est vite limité (à moins qu'il n'y ait
que des erreurs au debut ou bien à la fin)


Exemple:
http://cjoint.com/?ihrnwgKHyZ

Auriez-vous une solution ?

Merci d'avance ;)
Fred
fred
Le #16498111
> En VBA, ceci donnerait ça :
Range("A10").FormulaArray = "=Average(If(IsNumber(A1:A5),A1:A5))"



Merci "michdenis"

J'avais bien essayer de m'enregistrer pour voir le résultat mais je me suis
trompé de nom de macro! ;(

Avec mes excuses et encore un grand merci à tous pour vos réponses si
rapides et précises. ;)
Publicité
Poster une réponse
Anonyme