moyenne.si (?) sur les dates

Le
Rekam
Re Bonjour !

Je reviens vers vous pour un problème qui a été résolu pour des sommes, mais
qui se repose à moi pour des moyennes. Voici le nouvel exposé, basé sur le
précédent:

je cherche à faire une moyenne.si (ça exite pas, mais bon) sur une plage
de date, en faisant le test sur
le mois. Plus précisément:

A1:A100 = des dates
B1:B100 = des montants

C1 = une date: exactement 01.02.2009

en D1, je souhaiterais avoir le total des montants correspondant au MOIS(C1).

La solution pour en faire une somme, qui a été proposée par Daniel C. et qui
fonctionne est la suivante:

=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100)

alors bon, moi, en tout naïf que je suis, j'ai fait :
=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*MOYENNE(B1:B100))
ou
=SOMMEPROD(MOYENNE((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100))

mais bien évidemment, ça ne fonctionne pas. Comment puis-je faire-je ?



merci d'avance!
rekam
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Rekam
Le #20313601
Je m'auto-répond en signalant 3 choses:

1) il faudrait que je fouille mieux le forum avant de poster une question,
j'y ai finalement trouvé mon bonheur ;)

2) j'ai excel 2003, donc pas de moyenne.si intégré

3) la solution que j'ai, en l'occurrence
=SOMMEPROD((MOIS(A76)=MOIS(A7:A60))*(ANNEE(A76)=ANNEE(A7:A60))*K7:K60)/SOMMEPROD((MOIS(A76)=MOIS(A7:A60))*(ANNEE(A76)=ANNEE(A7:A60))*1)
michdenis
Le #20313981
Bonjour Rekam,

Validation matricielle : Validation avec les touches : Ctrl + Maj + Enter
=Moyenne(si(A1:A100Á;B1:B100))


"Rekam" :
Re Bonjour !

Je reviens vers vous pour un problème qui a été résolu pour des sommes, mais
qui se repose à moi pour des moyennes. Voici le nouvel exposé, basé sur le
précédent:

je cherche à faire une moyenne.si (ça exite pas, mais bon...) sur une plage
de date, en faisant le test sur
le mois. Plus précisément:

A1:A100 = des dates
B1:B100 = des montants

C1 = une date: exactement 01.02.2009

en D1, je souhaiterais avoir le total des montants correspondant au MOIS(C1).

La solution pour en faire une somme, qui a été proposée par Daniel C. et qui
fonctionne est la suivante:

=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100)

alors bon, moi, en tout naïf que je suis, j'ai fait :
=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*MOYENNE(B1:B100))
ou
=SOMMEPROD(MOYENNE((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100))

mais bien évidemment, ça ne fonctionne pas. Comment puis-je faire-je ?



merci d'avance!
rekam
Jacky
Le #20314071
Bonjour,

Matricielle
=MOYENNE(SI((MOIS(A1:A100)=MOIS(C1))*(ANNEE(A1:A100)=ANNEE(C1));B1:B100))
--
Salutations
JJ


"Rekam"
Re Bonjour !

Je reviens vers vous pour un problème qui a été résolu pour des sommes,
mais
qui se repose à moi pour des moyennes. Voici le nouvel exposé, basé sur le
précédent:

je cherche à faire une moyenne.si (ça exite pas, mais bon...) sur une
plage
de date, en faisant le test sur
le mois. Plus précisément:

A1:A100 = des dates
B1:B100 = des montants

C1 = une date: exactement 01.02.2009

en D1, je souhaiterais avoir le total des montants correspondant au
MOIS(C1).

La solution pour en faire une somme, qui a été proposée par Daniel C. et
qui
fonctionne est la suivante:

=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100)

alors bon, moi, en tout naïf que je suis, j'ai fait :
=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*MOYENNE(B1:B100))
ou
=SOMMEPROD(MOYENNE((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100))

mais bien évidemment, ça ne fonctionne pas. Comment puis-je faire-je ?



merci d'avance!
rekam



garnote
Le #20314221
Bonjour Rekam,

Sans tenir compte de l'année, cette formule semble convenir :
=(SOMMEPROD((MOIS(A1:A10)=MOIS(C1))*B1:B10))/SOMME(1*(MOIS(A1:A10)=MOIS(C1)))

Qu'en dis-tu ?
Serge


"Rekam"
Re Bonjour !

Je reviens vers vous pour un problème qui a été résolu pour des sommes,
mais
qui se repose à moi pour des moyennes. Voici le nouvel exposé, basé sur le
précédent:

je cherche à faire une moyenne.si (ça exite pas, mais bon...) sur une
plage
de date, en faisant le test sur
le mois. Plus précisément:

A1:A100 = des dates
B1:B100 = des montants

C1 = une date: exactement 01.02.2009

en D1, je souhaiterais avoir le total des montants correspondant au
MOIS(C1).

La solution pour en faire une somme, qui a été proposée par Daniel C. et
qui
fonctionne est la suivante:

=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100)

alors bon, moi, en tout naïf que je suis, j'ai fait :
=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*MOYENNE(B1:B100))
ou
=SOMMEPROD(MOYENNE((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100))

mais bien évidemment, ça ne fonctionne pas. Comment puis-je faire-je ?



merci d'avance!
rekam



garnote
Le #20314201
=(SOMMEPROD((MOIS(A1:A10)=MOIS(C1))*B1:B10))/SOMME(1*(MOIS(A1:A10)=MOIS(C1)))
À valider par Ctrl+Majuscule+Entrée

Mais plus simplement, à la manière de Jacky :
=MOYENNE(SI(MOIS(A1:A10)=MOIS(C1);B1:B10))
À valider par Ctrl+Majuscule+Entrée

Serge

"garnote" O3Ny$
Bonjour Rekam,

Sans tenir compte de l'année, cette formule semble convenir :
=(SOMMEPROD((MOIS(A1:A10)=MOIS(C1))*B1:B10))/SOMME(1*(MOIS(A1:A10)=MOIS(C1)))

Qu'en dis-tu ?
Serge


"Rekam"
Re Bonjour !

Je reviens vers vous pour un problème qui a été résolu pour des sommes,
mais
qui se repose à moi pour des moyennes. Voici le nouvel exposé, basé sur
le
précédent:

je cherche à faire une moyenne.si (ça exite pas, mais bon...) sur une
plage
de date, en faisant le test sur
le mois. Plus précisément:

A1:A100 = des dates
B1:B100 = des montants

C1 = une date: exactement 01.02.2009

en D1, je souhaiterais avoir le total des montants correspondant au
MOIS(C1).

La solution pour en faire une somme, qui a été proposée par Daniel C. et
qui
fonctionne est la suivante:

=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100)

alors bon, moi, en tout naïf que je suis, j'ai fait :
=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*MOYENNE(B1:B100))
ou
=SOMMEPROD(MOYENNE((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100))

mais bien évidemment, ça ne fonctionne pas. Comment puis-je faire-je ?



merci d'avance!
rekam







michdenis
Le #20314191
Si tu dois tenir compte du mois :

La formule serait : Validation matricielle
=MOYENNE(SI(MOIS(A1:A100)=MOIS(C1);B1:B100))



"michdenis"
Bonjour Rekam,

Validation matricielle : Validation avec les touches : Ctrl + Maj + Enter
=Moyenne(si(A1:A100Á;B1:B100))


"Rekam" :
Re Bonjour !

Je reviens vers vous pour un problème qui a été résolu pour des sommes, mais
qui se repose à moi pour des moyennes. Voici le nouvel exposé, basé sur le
précédent:

je cherche à faire une moyenne.si (ça exite pas, mais bon...) sur une plage
de date, en faisant le test sur
le mois. Plus précisément:

A1:A100 = des dates
B1:B100 = des montants

C1 = une date: exactement 01.02.2009

en D1, je souhaiterais avoir le total des montants correspondant au MOIS(C1).

La solution pour en faire une somme, qui a été proposée par Daniel C. et qui
fonctionne est la suivante:

=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100)

alors bon, moi, en tout naïf que je suis, j'ai fait :
=SOMMEPROD((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*MOYENNE(B1:B100))
ou
=SOMMEPROD(MOYENNE((MOIS(C1)=MOIS(A1:A100))*(ANNEE(C1)=ANNEE(A1:A100))*B1:B100))

mais bien évidemment, ça ne fonctionne pas. Comment puis-je faire-je ?



merci d'avance!
rekam
Publicité
Poster une réponse
Anonyme