moyenne si

Le
Lulu
Bonjour,
Je sais que c'est tout simple

la colonne A il y a les valeurs
la colonne B des résultats

je voudrais faire la moyenne de la colonne B si la colonne A>235 par exemple
puis la moyenne de la colonne B si la colonne A<235.

A B
238.8 +1.59%
232.7 -0.99%
etc

moynne si ou matrice, j'y arrive pas

Merci de vos lumières

Luc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #21640401
Bonjour.
=MOYENNE.SI(A:A;">235";B:B)
=MOYENNE.SI(A:A;"<235";B:B)
=SOMMEPROD(N(A1:A10>235);B1:B10)/SOMMEPROD(N(A1:A10>235))
Cordialement.
Daniel

Bonjour,
Je sais que c'est tout simple

la colonne A il y a les valeurs
la colonne B des résultats

je voudrais faire la moyenne de la colonne B si la colonne A>235 par exemple
puis la moyenne de la colonne B si la colonne A<235.

A B
238.8 +1.59%
232.7 -0.99%
etc...

moynne si ou matrice, j'y arrive pas

Merci de vos lumières

Luc
Lulu
Le #21640871
Merci DANIEL,

Il ne connait pas la fonction MOYENNE.SI
est ce qu'il faut la télécharger ?

Cordialement
Luc

"Daniel.C"
Bonjour.
=MOYENNE.SI(A:A;">235";B:B)
=MOYENNE.SI(A:A;"<235";B:B)
=SOMMEPROD(N(A1:A10>235);B1:B10)/SOMMEPROD(N(A1:A10>235))
Cordialement.
Daniel

Bonjour,
Je sais que c'est tout simple

la colonne A il y a les valeurs
la colonne B des résultats

je voudrais faire la moyenne de la colonne B si la colonne A>235 par
exemple
puis la moyenne de la colonne B si la colonne A<235.

A B
238.8 +1.59%
232.7 -0.99%
etc...

moynne si ou matrice, j'y arrive pas

Merci de vos lumières

Luc




Daniel.C
Le #21641091
Non, comme c'était le titre de ton message, j'ai crû que tu avais
XL2007 (la fonction est dispopnible dans cette version). Utilise
SOMMEPROD.
Daniel

Merci DANIEL,

Il ne connait pas la fonction MOYENNE.SI
est ce qu'il faut la télécharger ?

Cordialement
Luc

"Daniel.C"
Bonjour.
=MOYENNE.SI(A:A;">235";B:B)
=MOYENNE.SI(A:A;"<235";B:B)
=SOMMEPROD(N(A1:A10>235);B1:B10)/SOMMEPROD(N(A1:A10>235))
Cordialement.
Daniel

Bonjour,
Je sais que c'est tout simple

la colonne A il y a les valeurs
la colonne B des résultats

je voudrais faire la moyenne de la colonne B si la colonne A>235 par
exemple
puis la moyenne de la colonne B si la colonne A<235.

A B
238.8 +1.59%
232.7 -0.99%
etc...

moynne si ou matrice, j'y arrive pas

Merci de vos lumières

Luc




Lulu
Le #21641241
ok ca marche
A quoi sert le N(....) dans la formule ?

Daniel merci encore
Luc

"Daniel.C" %
Non, comme c'était le titre de ton message, j'ai crû que tu avais XL2007
(la fonction est dispopnible dans cette version). Utilise SOMMEPROD.
Daniel

Merci DANIEL,

Il ne connait pas la fonction MOYENNE.SI
est ce qu'il faut la télécharger ?

Cordialement
Luc

"Daniel.C"
Bonjour.
=MOYENNE.SI(A:A;">235";B:B)
=MOYENNE.SI(A:A;"<235";B:B)
=SOMMEPROD(N(A1:A10>235);B1:B10)/SOMMEPROD(N(A1:A10>235))
Cordialement.
Daniel

Bonjour,
Je sais que c'est tout simple

la colonne A il y a les valeurs
la colonne B des résultats

je voudrais faire la moyenne de la colonne B si la colonne A>235 par
exemple
puis la moyenne de la colonne B si la colonne A<235.

A B
238.8 +1.59%
232.7 -0.99%
etc...

moynne si ou matrice, j'y arrive pas

Merci de vos lumières

Luc










Daniel.C
Le #21641311
A transformer les valeurs logiques VRAI ou FAUX, difficiles à
additionner en 1 et 0 respectivement.
Daniel

ok ca marche
A quoi sert le N(....) dans la formule ?

Daniel merci encore
Luc

"Daniel.C" %
Non, comme c'était le titre de ton message, j'ai crû que tu avais XL2007
(la fonction est dispopnible dans cette version). Utilise SOMMEPROD.
Daniel

Merci DANIEL,

Il ne connait pas la fonction MOYENNE.SI
est ce qu'il faut la télécharger ?

Cordialement
Luc

"Daniel.C"
Bonjour.
=MOYENNE.SI(A:A;">235";B:B)
=MOYENNE.SI(A:A;"<235";B:B)
=SOMMEPROD(N(A1:A10>235);B1:B10)/SOMMEPROD(N(A1:A10>235))
Cordialement.
Daniel

Bonjour,
Je sais que c'est tout simple

la colonne A il y a les valeurs
la colonne B des résultats

je voudrais faire la moyenne de la colonne B si la colonne A>235 par
exemple
puis la moyenne de la colonne B si la colonne A<235.

A B
238.8 +1.59%
232.7 -0.99%
etc...

moynne si ou matrice, j'y arrive pas

Merci de vos lumières

Luc










Lulu
Le #21641581
Ouiais, si tu le dis, c'est un peu compliqué pour ma logique

Merci de la réponse

a+ Luc

"Daniel.C"
A transformer les valeurs logiques VRAI ou FAUX, difficiles à additionner
en 1 et 0 respectivement.
Daniel

ok ca marche
A quoi sert le N(....) dans la formule ?

Daniel merci encore
Luc

"Daniel.C" %
Non, comme c'était le titre de ton message, j'ai crû que tu avais XL2007
(la fonction est dispopnible dans cette version). Utilise SOMMEPROD.
Daniel

Merci DANIEL,

Il ne connait pas la fonction MOYENNE.SI
est ce qu'il faut la télécharger ?

Cordialement
Luc

"Daniel.C"
Bonjour.
=MOYENNE.SI(A:A;">235";B:B)
=MOYENNE.SI(A:A;"<235";B:B)
=SOMMEPROD(N(A1:A10>235);B1:B10)/SOMMEPROD(N(A1:A10>235))
Cordialement.
Daniel

Bonjour,
Je sais que c'est tout simple

la colonne A il y a les valeurs
la colonne B des résultats

je voudrais faire la moyenne de la colonne B si la colonne A>235 par
exemple
puis la moyenne de la colonne B si la colonne A<235.

A B
238.8 +1.59%
232.7 -0.99%
etc...

moynne si ou matrice, j'y arrive pas

Merci de vos lumières

Luc
















Daniel.C
Le #21641751
Regarde :
SOMMEPROD({VRAI;FAUX}) retourne "Valeur!".
SOMMEPROD(N({VRAI;FAUX})) = SOMMEPROD(N({1;0})) = 1
Daniel

Ouiais, si tu le dis, c'est un peu compliqué pour ma logique

Merci de la réponse

a+ Luc

"Daniel.C"
A transformer les valeurs logiques VRAI ou FAUX, difficiles à additionner en
1 et 0 respectivement.
Daniel

ok ca marche
A quoi sert le N(....) dans la formule ?

Daniel merci encore
Luc

"Daniel.C" %
Non, comme c'était le titre de ton message, j'ai crû que tu avais XL2007
(la fonction est dispopnible dans cette version). Utilise SOMMEPROD.
Daniel

Merci DANIEL,

Il ne connait pas la fonction MOYENNE.SI
est ce qu'il faut la télécharger ?

Cordialement
Luc

"Daniel.C"
Bonjour.
=MOYENNE.SI(A:A;">235";B:B)
=MOYENNE.SI(A:A;"<235";B:B)
=SOMMEPROD(N(A1:A10>235);B1:B10)/SOMMEPROD(N(A1:A10>235))
Cordialement.
Daniel

Bonjour,
Je sais que c'est tout simple

la colonne A il y a les valeurs
la colonne B des résultats

je voudrais faire la moyenne de la colonne B si la colonne A>235 par
exemple
puis la moyenne de la colonne B si la colonne A<235.

A B
238.8 +1.59%
232.7 -0.99%
etc...

moynne si ou matrice, j'y arrive pas

Merci de vos lumières

Luc
















Daniel.C
Le #21641741
Oups:
Regarde :
SOMMEPROD(N({VRAI;FAUX})) = SOMMEPROD({1;0}) = 1
Daniel


Regarde :
SOMMEPROD({VRAI;FAUX}) retourne "Valeur!".
SOMMEPROD(N({VRAI;FAUX})) = SOMMEPROD(N({1;0})) = 1
Daniel

Ouiais, si tu le dis, c'est un peu compliqué pour ma logique

Merci de la réponse

a+ Luc

"Daniel.C"
A transformer les valeurs logiques VRAI ou FAUX, difficiles à additionner
en 1 et 0 respectivement.
Daniel

ok ca marche
A quoi sert le N(....) dans la formule ?

Daniel merci encore
Luc

"Daniel.C" %
Non, comme c'était le titre de ton message, j'ai crû que tu avais XL2007
(la fonction est dispopnible dans cette version). Utilise SOMMEPROD.
Daniel

Merci DANIEL,

Il ne connait pas la fonction MOYENNE.SI
est ce qu'il faut la télécharger ?

Cordialement
Luc

"Daniel.C"
Bonjour.
=MOYENNE.SI(A:A;">235";B:B)
=MOYENNE.SI(A:A;"<235";B:B)
=SOMMEPROD(N(A1:A10>235);B1:B10)/SOMMEPROD(N(A1:A10>235))
Cordialement.
Daniel

Bonjour,
Je sais que c'est tout simple

la colonne A il y a les valeurs
la colonne B des résultats

je voudrais faire la moyenne de la colonne B si la colonne A>235 par
exemple
puis la moyenne de la colonne B si la colonne A<235.

A B
238.8 +1.59%
232.7 -0.99%
etc...

moynne si ou matrice, j'y arrive pas

Merci de vos lumières

Luc
Publicité
Poster une réponse
Anonyme