Moyennes des N meilleures valeurs d'un tableau de résultats

Le
Alain
Bonjour,

Je cherche comment résoudre simplement ce pb sachant que j'ai déjà trouvé la
fonction GRANDE.VALEUR(matrice;n) qui permet de le faire mais de façon que je
qualifierais d'un peu bestiale, c'est à dire en faisant la somme des valeurs
de rang 1 à N et en divisant par N. Si on veut prendre par exemple les 30
meilleures valeurs d'un tableau de 100 résultats, la formule est un peu
(beaucoup) lourde :
=(grande.valeur(matrice;1)+grande.valeur(matrice;2)+..+grande.valeur(matrice;30))/30.

Je ne doute pas que quelqu'un ait une meilleure idée et je suis très preneur.

Merci d'avance.

Alain
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4961051
Bonsoir,

=MOYENNE(GRANDE.VALEUR(A2:A35;LIGNE(INDIRECT("1:30"))))

JB
http://boisgontierjacques.free.fr

On 6 oct, 19:45, Alain
Bonjour,

Je cherche comment résoudre simplement ce pb sachant que j'ai déjà trouvé la
fonction GRANDE.VALEUR(matrice;n) qui permet de le faire mais de façon que je
qualifierais d'un peu bestiale, c'est à dire en faisant la somme des va leurs
de rang 1 à N et en divisant par N. Si on veut prendre par exemple les 30
meilleures valeurs d'un tableau de 100 résultats, la formule est un peu
(beaucoup) lourde :
=(grande.valeur(matrice;1)+grande.valeur(matrice;2)+.....+grande.valeur (mat­rice;30))/30.

Je ne doute pas que quelqu'un ait une meilleure idée et je suis très preneur.

Merci d'avance.

Alain


garnote
Le #4961031
Salut Alain,

Essaie cette formule un peu moins bestiale ;-)
=MOYENNE(GRANDE.VALEUR(matrice;LIGNE(DECALER($A$1;0;0;30;1))))
(À valider par Ctrl+Maj+Entrée)

Serge

"Alain"
Bonjour,

Je cherche comment résoudre simplement ce pb sachant que j'ai déjà trouvé la
fonction GRANDE.VALEUR(matrice;n) qui permet de le faire mais de façon que je
qualifierais d'un peu bestiale, c'est à dire en faisant la somme des valeurs
de rang 1 à N et en divisant par N. Si on veut prendre par exemple les 30
meilleures valeurs d'un tableau de 100 résultats, la formule est un peu
(beaucoup) lourde :
=(grande.valeur(matrice;1)+grande.valeur(matrice;2)+.....+grande.valeur(matrice;30))/30.

Je ne doute pas que quelqu'un ait une meilleure idée et je suis très preneur.

Merci d'avance.

Alain


JB
Le #4961021
A valider avec Maj+Ctrl+Entrée bien sûr

JB
On 6 oct, 20:06, JB
Bonsoir,

=MOYENNE(GRANDE.VALEUR(A2:A35;LIGNE(INDIRECT("1:30"))))

JBhttp://boisgontierjacques.free.fr

On 6 oct, 19:45, Alain


Bonjour,

Je cherche comment résoudre simplement ce pb sachant que j'ai déj à trouvé la
fonction GRANDE.VALEUR(matrice;n) qui permet de le faire mais de faço n que je
qualifierais d'un peu bestiale, c'est à dire en faisant la somme des valeurs
de rang 1 à N et en divisant par N. Si on veut prendre par exemple le s 30
meilleures valeurs d'un tableau de 100 résultats, la formule est un p eu
(beaucoup) lourde :
=(grande.valeur(matrice;1)+grande.valeur(matrice;2)+.....+grande.vale ur(mat­­rice;30))/30.

Je ne doute pas que quelqu'un ait une meilleure idée et je suis trè s preneur.

Merci d'avance.

Alain- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



garnote
Le #4960961
La formule de JB est non seulement plus courte mais aussi plus sûre.
En effet avec ma formule, le fait de supprimer ou d'insérer des lignes
peut conduire à des erreurs. Donc ce que JB dixit est préférable.

Serge

"garnote"
Salut Alain,

Essaie cette formule un peu moins bestiale ;-)
=MOYENNE(GRANDE.VALEUR(matrice;LIGNE(DECALER($A$1;0;0;30;1))))
(À valider par Ctrl+Maj+Entrée)

Serge

"Alain"
Bonjour,

Je cherche comment résoudre simplement ce pb sachant que j'ai déjà trouvé la
fonction GRANDE.VALEUR(matrice;n) qui permet de le faire mais de façon que je
qualifierais d'un peu bestiale, c'est à dire en faisant la somme des valeurs
de rang 1 à N et en divisant par N. Si on veut prendre par exemple les 30
meilleures valeurs d'un tableau de 100 résultats, la formule est un peu
(beaucoup) lourde :
=(grande.valeur(matrice;1)+grande.valeur(matrice;2)+.....+grande.valeur(matrice;30))/30.

Je ne doute pas que quelqu'un ait une meilleure idée et je suis très preneur.

Merci d'avance.

Alain






Alain
Le #4960911
Bravo JB,

Je savais bien que je pouvais compter sur la communauté "Excel" pour
résoudre ce pb ; ça marche impeccable !

Et bravo également à Garnote qui très élégamment a reconnu que ta solution
était sans doute plus performante.

Bonne soirée ; bonne 2ème mi-temps !

A bientôt peut-être.

Alain


A valider avec Maj+Ctrl+Entrée bien sûr

JB
On 6 oct, 20:06, JB
Bonsoir,

=MOYENNE(GRANDE.VALEUR(A2:A35;LIGNE(INDIRECT("1:30"))))

JBhttp://boisgontierjacques.free.fr

On 6 oct, 19:45, Alain


Bonjour,

Je cherche comment résoudre simplement ce pb sachant que j'ai déjà trouvé la
fonction GRANDE.VALEUR(matrice;n) qui permet de le faire mais de façon que je
qualifierais d'un peu bestiale, c'est à dire en faisant la somme des valeurs
de rang 1 à N et en divisant par N. Si on veut prendre par exemple les 30
meilleures valeurs d'un tableau de 100 résultats, la formule est un peu
(beaucoup) lourde :
=(grande.valeur(matrice;1)+grande.valeur(matrice;2)+.....+grande.valeur(mat­­rice;30))/30.

Je ne doute pas que quelqu'un ait une meilleure idée et je suis très preneur.

Merci d'avance.

Alain- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -








garnote
Le #4960901
Salut Alain,

Tu pourrais aussi entrer le nombre de grandes valeurs dont tu veux calculer
la moyenne dans une cellule, par exemple, en A1 et utiliser cette formule :
=MOYENNE(GRANDE.VALEUR(matrice;LIGNE(INDIRECT("1:"&A1))))

Serge

"Alain"
Bravo JB,

Je savais bien que je pouvais compter sur la communauté "Excel" pour
résoudre ce pb ; ça marche impeccable !

Et bravo également à Garnote qui très élégamment a reconnu que ta solution
était sans doute plus performante.

Bonne soirée ; bonne 2ème mi-temps !

A bientôt peut-être.

Alain


A valider avec Maj+Ctrl+Entrée bien sûr

JB
On 6 oct, 20:06, JB
Bonsoir,

=MOYENNE(GRANDE.VALEUR(A2:A35;LIGNE(INDIRECT("1:30"))))

JBhttp://boisgontierjacques.free.fr

On 6 oct, 19:45, Alain


Bonjour,

Je cherche comment résoudre simplement ce pb sachant que j'ai déjà trouvé la
fonction GRANDE.VALEUR(matrice;n) qui permet de le faire mais de façon que je
qualifierais d'un peu bestiale, c'est à dire en faisant la somme des valeurs
de rang 1 à N et en divisant par N. Si on veut prendre par exemple les 30
meilleures valeurs d'un tableau de 100 résultats, la formule est un peu
(beaucoup) lourde :
=(grande.valeur(matrice;1)+grande.valeur(matrice;2)+.....+grande.valeur(mat­­rice;30))/30.

Je ne doute pas que quelqu'un ait une meilleure idée et je suis très preneur.

Merci d'avance.

Alain- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -










Alain
Le #4960601
Merci du complément qui me simplifie beaucoup l'exploitation de mon tableau
de résultats en permettant un paramétrage très souple pour faire sortir les
résultats.

Pour votre info, le pb que je résous est celui du classement annuel, en fin
de saison, d'une série d'environ 100 tournois de bridge en ne prenant que les
20 ou 30 ou N meilleurs obtenus par chacun des joueurs.

Je suis quand même étonné qu'une fonction du modèle de GRANDE.VALEUR
n'existe pas dans la panoplie des fonctions statistiques d'excel.

Merci encore à tous les deux et à bientôt peut-être sur un autre sujet.

Bon dimanche après ce samedi terminé en apothéose pour les "bleus" mais ceci
ne touchera que les amateurs du ballon ovale.

Alain


Salut Alain,

Tu pourrais aussi entrer le nombre de grandes valeurs dont tu veux calculer
la moyenne dans une cellule, par exemple, en A1 et utiliser cette formule :
=MOYENNE(GRANDE.VALEUR(matrice;LIGNE(INDIRECT("1:"&A1))))

Serge

"Alain"
Bravo JB,

Je savais bien que je pouvais compter sur la communauté "Excel" pour
résoudre ce pb ; ça marche impeccable !

Et bravo également à Garnote qui très élégamment a reconnu que ta solution
était sans doute plus performante.

Bonne soirée ; bonne 2ème mi-temps !

A bientôt peut-être.

Alain


A valider avec Maj+Ctrl+Entrée bien sûr

JB
On 6 oct, 20:06, JB
Bonsoir,

=MOYENNE(GRANDE.VALEUR(A2:A35;LIGNE(INDIRECT("1:30"))))

JBhttp://boisgontierjacques.free.fr

On 6 oct, 19:45, Alain


Bonjour,

Je cherche comment résoudre simplement ce pb sachant que j'ai déjà trouvé la
fonction GRANDE.VALEUR(matrice;n) qui permet de le faire mais de façon que je
qualifierais d'un peu bestiale, c'est à dire en faisant la somme des valeurs
de rang 1 à N et en divisant par N. Si on veut prendre par exemple les 30
meilleures valeurs d'un tableau de 100 résultats, la formule est un peu
(beaucoup) lourde :
=(grande.valeur(matrice;1)+grande.valeur(matrice;2)+.....+grande.valeur(mat­­rice;30))/30.

Je ne doute pas que quelqu'un ait une meilleure idée et je suis très preneur.

Merci d'avance.

Alain- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -















Publicité
Poster une réponse
Anonyme