Multicast IPv6

Le
Erwan David
Bonjour,

J'ai un problème avec ntp en multicast IPv6 (pour l'instant sans
authentification)

Le serveur envoie bien régulièrement ses paquets sur ff05::101

Mais le client n'en reçoit un que de temps en temps (au départ le serveur
envoie environ toutes les 64 s, le client a reçu le premier, puis un paquet au
bout de 862 s)

j'ai vu les paquets ICMPv6 Multicast Listener Record qui m'ont un peu étonné :
1 premier paquet include ff05::101, puis 2 exclude ff05::101 (dixit
wireshark).

Je ne suis pas sûr des switchs sur le réseau (cisco 6500 avec un IOS qui
ne connait pas IPv6, enterasys B2 et linksys SRW2008).

DOnc je suis pour le moins perplexe.

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
xavier
Le #23335151
Erwan David
J'ai un problème avec ntp en multicast IPv6 (pour l'instant sans
authentification)



Tu es sûr qu'il s'agit de multicast ? Parce que le mode par défaut, et qui est
donc utilisé 99 fois sur 100, c'est unicast

linksys SRW2008



Pour ce dernier, j'en ai un de la gamme au coeur de mon réseau, et les synchro
NTP se font par IPv6 entre machines et avec un des serveurs extérieurs.

[ ~]$ ntpq -pn
remote refid st t when poll reach delay offset jitter
============================================================================= *2001:1bc0::ffff 192.53.103.108 2 u 167 512 377 52.570 0.740 0.251
+192.93.2.20 .GPSi. 1 u 215 512 377 22.614 -2.505 1.317
2001:470:1f13:3 167.74.23.26 3 u 193 512 376 0.408 -1.657 0.004
2001:470:1f13:3 167.74.23.26 3 u 202 512 376 0.344 -1.597 0.088

De toutes façons, si tes switches ne font que du L2, peu leur importe ce qu'il
y a dans les paquets Ethernet....

--
XAv
In your pomp and all your glory you're a poorer man than me,
as you lick the boots of death born out of fear.
(Jethro Tull)
Erwan David
Le #23335451
(Xavier) écrivait :

Erwan David
J'ai un problème avec ntp en multicast IPv6 (pour l'instant sans
authentification)



Tu es sûr qu'il s'agit de multicast ? Parce que le mode par défaut, et qui est
donc utilisé 99 fois sur 100, c'est unicast



Oui, mais je dois mettre en place du ntp multicast IPv6 sur le réseau de
test IPv6 : je suis donc bien suûr que c'est du multicast...

Unicast fonctionne sans problème.

linksys SRW2008



Pour ce dernier, j'en ai un de la gamme au coeur de mon réseau, et les synchro
NTP se font par IPv6 entre machines et avec un des serveurs extérieurs.

[ ~]$ ntpq -pn
remote refid st t when poll reach delay offset jitter
============================================================================= > *2001:1bc0::ffff 192.53.103.108 2 u 167 512 377 52.570 0.740 0.251
+192.93.2.20 .GPSi. 1 u 215 512 377 22.614 -2.505 1.317
2001:470:1f13:3 167.74.23.26 3 u 193 512 376 0.408 -1.657 0.004
2001:470:1f13:3 167.74.23.26 3 u 202 512 376 0.344 -1.597 0.088

De toutes façons, si tes switches ne font que du L2, peu leur importe ce qu'il
y a dans les paquets Ethernet....



Pour les B2, il faut que je vérifie, mais le 6500 fait du L3, et comme
il ne connais pas IPv6, je crains.

Mais ça peut être aussi un équivalent de IGMP snooping sur un switch qui
connais IPv6.


--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Publicité
Poster une réponse
Anonyme