Multiplexage du son ?

Le
Eul_Bofo
Bonjour.

J'ai un petit soucis que je n'avais pas constaté avant (ce qui ne veut
pas dire qu'il n'était pas déjà présent), sur ma Debian 6 stable : je
n'ai plus de multiplexage du son.

Plus précisément, si une application (Iceweasel, Amarok) produit des
sons, je ne peux pas lancer Civ4 sous wine parce qu'il ne détecte plus
la présence de matériel son (même si j'ai coupé tous les bruits
produits, aimant jouer dans le calme :-). De la même façon, si je lance
une session Window$ XP dans Virtualbox, je ne peux plus écouter de
musique par exemple avec RadioTray. Et tout un tas d'autres exemples.

Ce que me dit l'icône de son de ma barre supérieure :
- matériel : Audio interne 1 sortie/1 entrée, profil Analog Stereo
Duplex,
- pas d'effets sonores.
Un truc bizarre : dernièrement, j'ai deux de ces icônes en haut à
droite.

J'utilise la carte son intégrée à ma carte mère, je n'ai jamais eu de
problème jusqu'à présent, et je sais avoir déjà par exemple pu jouer à
Civ4 en écoutant la radio ou un disque.

Le seul truc que j'ai éventuellement casser et que j'ai temporairement
(pour des raisons de compatibilité wine) installé une vieille carte
SoundBlaster que j'avais piquée dans l'ordinateur de ma femme, mais je
l'ai depuis enlevée.

Des idées ?

D'avance merci.

bye

--

Nicolas FRANCOIS | /
http://nicolas.francois.free.fr | |__|
X--/\
We are the Micro$oft. __V
Resistance is futile.
You will be assimilated. darthvader penguin
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sergio
Le #24642011
Le Sun, 15 Jul 2012 13:50:31 +0000, Eul_Bofo a écrit :

J'ai un petit soucis que je n'avais pas constaté avant (ce qui ne veut
pas dire qu'il n'était pas déjà présent), sur ma Debian 6 stable : je
n'ai plus de multiplexage du son.

Plus précisément, si une application (Iceweasel, Amarok...) produit des
sons, je ne peux pas lancer Civ4 sous wine parce qu'il ne détecte plus
la présence de matériel son (même si j'ai coupé tous les bruits
produits, aimant jouer dans le calme :-). De la même façon, si je lance
une session Window$ XP dans Virtualbox, je ne peux plus écouter de
musique par exemple avec RadioTray. Et tout un tas d'autres exemples.



Cela semble être un problème entre Wine VirtualBox et les autres
applications. Entre deux applications "Linux", deux applis wine, ça
marche ?

PS:
Quelle idée d'utiliser un programme Windows sous VirtualBox pour écouter
la radio ! Il y en a d'autres aussi biens, sinon mieux, en natif sous
Linux !
Eul_Bofo
Le #24642511
Le Mon, 16 Jul 2012 05:45:28 +0000, Sergio a écrit :

Le Sun, 15 Jul 2012 13:50:31 +0000, Eul_Bofo a écrit :

J'ai un petit soucis que je n'avais pas constaté avant (ce qui ne veut
pas dire qu'il n'était pas déjà présent), sur ma Debian 6 stable : je
n'ai plus de multiplexage du son.

Plus précisément, si une application (Iceweasel, Amarok...) produit des
sons, je ne peux pas lancer Civ4 sous wine parce qu'il ne détecte plus
la présence de matériel son (même si j'ai coupé tous les bruits
produits, aimant jouer dans le calme :-). De la même façon, si je lance
une session Window$ XP dans Virtualbox, je ne peux plus écouter de
musique par exemple avec RadioTray. Et tout un tas d'autres exemples.



Cela semble être un problème entre Wine VirtualBox et les autres
applications. Entre deux applications "Linux", deux applis wine, ça
marche ?



Entre deux applis Linux, après un peu de ménage, ça a l'air de
fonctionnner. Entre deux applis wine, je n'ai pas essayé. Par contre,
entre wine et les applis Linux, ça va de traviolle.

La page
http://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/
PerfectSetup
semble expliquer un peu le problème. Pas grave.

PS:
Quelle idée d'utiliser un programme Windows sous VirtualBox pour écouter
la radio ! Il y en a d'autres aussi biens, sinon mieux, en natif sous
Linux !



Heu, soit je ne me suis pas bien expliqué, soit tu t'es emballé ! Je
n'utilise wine que pour jouer à Civ4, et Virtualbox pour faire mumuse
avec Window$ sans danger. J'écoute la radio avec RadioTray, et ça, C'EST
une application Linux (pas mal du tout, d'ailleurs, quoiqu'un peu
rustique). Par contre, si Window$ sous Virtualbox est en marche, il prend
d'autorité toutes les ressources son, et DU COUP, je ne peux pas écouter
ma radio Jazz préférée (sous Linux, donc !).

bye

--

Nicolas FRANCOIS | /
http://nicolas.francois.free.fr | |__|
X--/\
We are the Micro$oft. __V
Resistance is futile.
You will be assimilated. darthvader penguin
Sergio
Le #24642681
Le Mon, 16 Jul 2012 11:41:24 +0000, Eul_Bofo a écrit :

Cela semble être un problème entre Wine VirtualBox et les autres
applications. Entre deux applications "Linux", deux applis wine, ça
marche ?



Entre deux applis Linux, après un peu de ménage, ça a l'air de
fonctionnner. Entre deux applis wine, je n'ai pas essayé. Par contre,
entre wine et les applis Linux, ça va de traviolle.

La page
http://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/
PerfectSetup semble expliquer un peu le problème. Pas grave.

PS:
Quelle idée d'utiliser un programme Windows sous VirtualBox pour
écouter la radio ! Il y en a d'autres aussi biens, sinon mieux, en
natif sous Linux !



Heu, soit je ne me suis pas bien expliqué, soit tu t'es emballé !



Désolé, j'avais lu un peu rapidement !

n'utilise wine que pour jouer à Civ4, et Virtualbox pour faire mumuse
avec Window$ sans danger. J'écoute la radio avec RadioTray, et ça, C'EST
une application Linux (pas mal du tout, d'ailleurs, quoiqu'un peu
rustique). Par contre, si Window$ sous Virtualbox est en marche, il
prend d'autorité toutes les ressources son, et DU COUP, je ne peux pas
écouter ma radio Jazz préférée (sous Linux, donc !).



Dans les préférences de son, il y a un "mixer" entre les applications.
Y'as-tu accès ?

Ça devrait donner (à peu près) ça :
http://cjoint.com/12ju/BGqpvPTRVkp_preferences_du_son_001.png
Publicité
Poster une réponse
Anonyme