Multiplication sous condition

Le
Lulu
Bonjour,

Dans l'exemple ci-joint, je sais utiliser
SOMMEPROD(prixunitaire*quantitéproduit) par CLIENT
mais comment le faire par CLIENT et par FOURNISSEUR

http://www.cijoint.fr/cij9879234136119.xls

Merci encore des cours sur news.excel

Luc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Trirème
Le #5343171
Bonjour Luc,
Selon ton exemple, à mettre en L5 et recopier vers le bas et vers la droite :
=SOMMEPROD(--($B$2:$G$2=L$2);$B$3:$G$3;$B5:$G5)

Tu retrouveras dans $B$3:$G$3;$B5:$G5 la notion de Prix Unitaire x Quantité et
dans la partie ($B$2:$G$2=L$2), la construction d'une matrice de VRAI/FAUX
correspondant aux fournisseurs. Les "--" transforment les VRAI/FAUX en 0/1.

On aurait pu écrire aussi :
=SOMMEPROD(($B$2:$G$2=L$2)*$B$3:$G$3;$B5:$G5)
Le '*' force la conversion des VRAI/FAUX en 0/1

Cordialement,
Trirème

Bonjour,

Dans l'exemple ci-joint, je sais utiliser
SOMMEPROD(prixunitaire*quantitéproduit) par CLIENT
mais comment le faire par CLIENT et par FOURNISSEUR

http://www.cijoint.fr/cij9879234136119.xls

Merci encore des cours sur news.excel

Luc




Ellimac
Le #5343151
Rebonjour Lulu,

=SOMMEPROD((B2:G2=O2)*(B5:G5)*(B3:G3)+(B2:G2=P2)*(B5:G5)*(B3:G3))

Camille


Bonjour,

Dans l'exemple ci-joint, je sais utiliser
SOMMEPROD(prixunitaire*quantitéproduit) par CLIENT
mais comment le faire par CLIENT et par FOURNISSEUR

http://www.cijoint.fr/cij9879234136119.xls

Merci encore des cours sur news.excel

Luc





Lulu
Le #5343101
ok ca marche
Il faut que je me fasse au matrice

Merci encore CAMILLE
Luc


"Ellimac" news:
Rebonjour Lulu,

=SOMMEPROD((B2:G2=O2)*(B5:G5)*(B3:G3)+(B2:G2=P2)*(B5:G5)*(B3:G3))

Camille


Bonjour,

Dans l'exemple ci-joint, je sais utiliser
SOMMEPROD(prixunitaire*quantitéproduit) par CLIENT
mais comment le faire par CLIENT et par FOURNISSEUR

http://www.cijoint.fr/cij9879234136119.xls

Merci encore des cours sur news.excel

Luc







Lulu
Le #5343091
Merci TRIREME,

Avec les explications de CAMILLE et les tiennes, j'assimile doucement mais
surement les notions de matrice

Merci encore
Luc

"Trirème"
Bonjour Luc,
Selon ton exemple, à mettre en L5 et recopier vers le bas et vers la
droite :
=SOMMEPROD(--($B$2:$G$2=L$2);$B$3:$G$3;$B5:$G5)

Tu retrouveras dans $B$3:$G$3;$B5:$G5 la notion de Prix Unitaire x
Quantité et dans la partie ($B$2:$G$2=L$2), la construction d'une matrice
de VRAI/FAUX correspondant aux fournisseurs. Les "--" transforment les
VRAI/FAUX en 0/1.

On aurait pu écrire aussi :
=SOMMEPROD(($B$2:$G$2=L$2)*$B$3:$G$3;$B5:$G5)
Le '*' force la conversion des VRAI/FAUX en 0/1

Cordialement,
Trirème

Bonjour,

Dans l'exemple ci-joint, je sais utiliser
SOMMEPROD(prixunitaire*quantitéproduit) par CLIENT
mais comment le faire par CLIENT et par FOURNISSEUR

http://www.cijoint.fr/cij9879234136119.xls

Merci encore des cours sur news.excel

Luc




Publicité
Poster une réponse
Anonyme