mutt et format mbox

Le
dyrmak
Bonjour,

Je dois récupérer mon courrier cumulé depuis 2000-- sur
un serveur qui désactive son service, ils proposent
un pop et un imap comme vecteurs de récupération parmi d'autres
possibilités, un coup de fetchmail devrait pouvoir
le faire sur l'un ou l'autre des serveurs et je devrait
me retrouver avec disons, un fichier mbox assez volumineux.

Il se trouve que chaque année je fais le nettoyage et j'archive
le courrier annuel de mon FAI avec cette même technique, je
me retrouve avec des mbox-FAI-1 mbox-FAI-2 etc..

Pour les consulter je lance: mutt -f mbox-FAI-3 par exemple
et la lecture se fait dans mon cas exactement comme si le courrier
se trouvait chez le fournisseur.

Mais je viens de découvrir quelque chose de désagréable dans cette
consultation, la présentation de courrier force un indicateur "O"
sur tout le courrier archivé; quand on le lit directement avec
mutt -f mbox, au départ il y a bien "N" mais aussitôt qu'on
abandonne et on recommence l'indicateur passe à "O" sur tous
les courriers et pas moyen de le forcer à revenir sur "N"..

Je sais c'est du vieux courrier lu et relu probablement, je sais
c'est du mbox et je constate que si je lis mon courrier sur
mon serveur pop/imap privé, le courrier au format INBOX ne me pose
pas ce problème, là, je peux changer à volonté les indicateurs et
ces indicateurs ne changent par la suite que selon l'action que
j'applique, et si je veux revenir à l'indicateur "N" je le fais
sans aucun problème apparemment.
Je pourrais faire alimenter mon webmail privé directement de pop
à pop mais d'une part je n'ai jamais fait ça et mon courrier se
retrouverait au format mbox j'imagine ET surtout je n'ai pas envie
de passer par mon webmail privé pour faire ça.
Mais peut-être que je me noie dans un verre d'eau et qu'une action
bien précise sur mutt ou sur la mbox me permettrait
de faire adopter le comportement que je souhaite ?

Merci déjà de m'avoir lu, je sais que c'est pénible .

dyrmak
--
Un ¤uro de oro
++++ ++++
Linux operating system
++++ ++++
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacques Belin
Le #26367975
Le vendredi 18 septembre 2015 11:40:52,
dyrmak
Mais je viens de découvrir quelque chose de désagréable dans cett e
consultation, la présentation de courrier force un indicateur "O"
sur tout le courrier archivé; quand on le lit directement avec
mutt -f mbox, au départ il y a bien "N" mais aussitôt qu'on
abandonne et on recommence l'indicateur passe à "O" sur tous
les courriers et pas moyen de le forcer à revenir sur "N".....



As-tu essayé l'option de configuration "mark_old" ?

"mark_old

Type: boolean
Default: yes

Controls whether or not Mutt makes the distinction between new
messages and old unread messages. By default, Mutt will mark new
messages as old if you exit a mailbox without reading them. The next
time you start Mutt, the messages will show up with an "O" next to
them in the index menu, indicating that they are old. In order to
make Mutt treat all unread messages as new only, you can unset this
variable."


A+ Jacques.
--
Le dernier Homme connecté sur le Net regardait d'anciens sites Webs.
"Vous avez du courrier" apparut sur l'écran...
--------------------------- adapté d'une courte histoire de Fredric Brown
dyrmak
Le #26368257
En 34 lignes Jacques Belin a écrit
dans news:
le vendredi, 18 septembre 2015 à 17:33:52 :


As-tu essayé l'option de configuration "mark_old" ?




Merci!

C'était bien ça.

Disons simplement pour clarifier que pour me connecter
au serveur avec mutt j'utilise des muttrc différents
et là j'avais:

grep mark_old muttrc-int-ext
unset mark_old


C'est pour cela que ça marche quand je me connecte "à chaud" sur
le serveur et pas quand je lis "à froid" la mbox archivée.

grep mark_old .muttrc

dyrmak
--
Todo lo que sea vino su derredor
++++ --- ++++
Linux operating system
++++ --- ++++
Publicité
Poster une réponse
Anonyme