Nb de cellules différentes

Le
Infogroup
Bonjour à tous,

j'ai en colonne A une série de chiffres avec des doublons, voir des triples
ou des quadruples.

en colonne D, j'ai une suite de lettres A, D, C, E, H etc..

Je voudrais connaître le nombre de chiffres différents en colonne A, mais
seulement pour les valeurs "E" de la colonne D

J'ai bien la formule
{=SOMME(SI(NBCAR(A2:A1000)>0;1/(NB.SI(A2:A1000;A2:A1000));0))} qui me donne
le nombre de chiffres différents en colonne A

et donc, je voudrais en plus ajouter la condition que la cellule
correspondante à A dans la colonne D soit égale à "E"

Merci par avance pour votre aide

Cordialement

Infogroup
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Coetera
Le #18532021
> Je voudrais connaître le nombre de chiffres différents en colonne A, mais
seulement pour les valeurs "E" de la colonne D



***************
Une matricielle :

=NB(1/FREQUENCE(SI(D2:D1000="E";EQUIV(A2:A1000;A2:A1000;0));LIGNE(INDIRECT("1:"&LIGNES(A2:A1000)))))

Atc
Infogroup
Le #18532811
Merci Coetera, c'est nickel

merci encore.

Cdl

Infogroup



"Coetera" news:
Je voudrais connaître le nombre de chiffres différents en colonne A, mais
seulement pour les valeurs "E" de la colonne D



***************
Une matricielle :

=NB(1/FREQUENCE(SI(D2:D1000="E";EQUIV(A2:A1000;A2:A1000;0));LIGNE(INDIRECT("1:"&LIGNES(A2:A1000)))))

Atc



Publicité
Poster une réponse
Anonyme