Nb de jours ouvrables dans une année

Le
Al
Bonjour à tous,

Je sais que la question a déja dû être posée.

Comment calculer le nb de jour ouvrables (Lundi au Vendredi) dans une année
en tenant compte des jours fériés.?

Merci pour votre aide et Bonnes Fêtes
Al
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #20847341
Bonjour,

Dans la feuille de calcul, il y a la formule :
= NB.JOURS.OUVRES(date_Départ;Date_Fin;Plage_Congé)
tu définis une plage nommée pour les jours de congé
que tu insères dans la formule



"Al"
Bonjour à tous,

Je sais que la question a déja dû être posée....

Comment calculer le nb de jour ouvrables (Lundi au Vendredi) dans une année
en tenant compte des jours fériés....?

Merci pour votre aide et Bonnes Fêtes
Al
FS
Le #21086771
Bonsoir,

Une formule à rallonge (sans utilitaire d'analyse ni plage de fériés) à
partir de l'année en A1 :

=SOMMEPROD(--(JOURSEM(LIGNE(INDIRECT(DATE(A1;1;1)&":"&DATE(A1;12;31)));2)<5))-3-SOMMEPROD(--(JOURSEM(DATE(A1;{1;5;5;7;8;11;11;12};{1;1;8;14;15;1;11;25});2)<=5))

Il y a probablement plus court...et le cas, assez rare, de 2 fériés (1
fixe et un mobile) tombant le même jour (cas du 1er mai en 2008 par ex)
n'est pas traité.

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

Al a écrit :
Bonjour à tous,

Je sais que la question a déja dû être posée....

Comment calculer le nb de jour ouvrables (Lundi au Vendredi) dans une
année en tenant compte des jours fériés....?

Merci pour votre aide et Bonnes Fêtes
Al


FS
Le #21086881
Oups, l'année était un peu courte (ou les WE un peu longs) !
Plutôt :

=SOMMEPROD(--(JOURSEM(LIGNE(INDIRECT(DATE(A1;1;1)&":"&DATE(A1;12;31)));2)<6))-3-SOMMEPROD(--(JOURSEM(DATE(A1;{1;5;5;7;8;11;11;12};{1;1;8;14;15;1;11;25});2)<6))

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

FS a écrit :
Bonsoir,

Une formule à rallonge (sans utilitaire d'analyse ni plage de fériés) à
partir de l'année en A1 :

=SOMMEPROD(--(JOURSEM(LIGNE(INDIRECT(DATE(A1;1;1)&":"&DATE(A1;12;31)));2)<5))-3-SOMMEPROD(--(JOURSEM(DATE(A1;{1;5;5;7;8;11;11;12};{1;1;8;14;15;1;11;25});2)<=5))


Il y a probablement plus court...et le cas, assez rare, de 2 fériés (1
fixe et un mobile) tombant le même jour (cas du 1er mai en 2008 par ex)
n'est pas traité.

FS


Publicité
Poster une réponse
Anonyme