NB.SI avec 2 conditions

Le
eric
Bonjour

J'ai un fichier listing comprenant plus de 30000 lignes sur une première
feuille de calcul.

Dans une colonne B (allant de B1 à B30000), j'ai des noms comme pommes,
pêches, poires ou des noms composés (pêches/pommes)

Dans une colonne C au format pourcentage, j'ai des cellules soit vides, soit
à 0%, soit à 100%.

Dans une deuxième feuille de calcul, je veux déterminer le nombre total de
lignes contenant les 2 conditions suivantes:

- la cellule en B contient le mot pommes (j'insiste bien sur contient)
- la cellule en C est à 100%

j'essaye de travailler avec la formule suivante

=SOMMEPROD((Feuil1!B1:B30000="*pommes*")*(Feuil1!C1:C30000="100%"))

mais cette formule m'affiche toujours 0

je ne sais plus quoi faire, merci pour votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Trirème
Le #4467181
Bonsoir Éric,
Essaie ceci :
=SOMMEPROD(NON(ESTERREUR(CHERCHE("pomme";B1:B30000)))*(C1:C30000=1))
Le 100% devrait surement être un "1" au format %
Bonne compote.

Cordialement,
Trirème

Bonjour

J'ai un fichier listing comprenant plus de 30000 lignes sur une première
feuille de calcul.

Dans une colonne B (allant de B1 à B30000), j'ai des noms comme pommes,
pêches, poires ou des noms composés (pêches/pommes...)

Dans une colonne C au format pourcentage, j'ai des cellules soit vides, soit
à 0%, soit à 100%.

Dans une deuxième feuille de calcul, je veux déterminer le nombre total de
lignes contenant les 2 conditions suivantes:

- la cellule en B contient le mot pommes (j'insiste bien sur contient)
- la cellule en C est à 100%

j'essaye de travailler avec la formule suivante

=SOMMEPROD((Feuil1!B1:B30000="*pommes*")*(Feuil1!C1:C30000="100%"))

mais cette formule m'affiche toujours 0

je ne sais plus quoi faire, merci pour votre aide


eric
Le #4466181
Merci beaucoup, c'est impeccable


Bonsoir Éric,
Essaie ceci :
=SOMMEPROD(NON(ESTERREUR(CHERCHE("pomme";B1:B30000)))*(C1:C30000=1))
Le 100% devrait surement être un "1" au format %
Bonne compote.

Cordialement,
Trirème

Bonjour

J'ai un fichier listing comprenant plus de 30000 lignes sur une première
feuille de calcul.

Dans une colonne B (allant de B1 à B30000), j'ai des noms comme pommes,
pêches, poires ou des noms composés (pêches/pommes...)

Dans une colonne C au format pourcentage, j'ai des cellules soit vides, soit
à 0%, soit à 100%.

Dans une deuxième feuille de calcul, je veux déterminer le nombre total de
lignes contenant les 2 conditions suivantes:

- la cellule en B contient le mot pommes (j'insiste bien sur contient)
- la cellule en C est à 100%

j'essaye de travailler avec la formule suivante

=SOMMEPROD((Feuil1!B1:B30000="*pommes*")*(Feuil1!C1:C30000="100%"))

mais cette formule m'affiche toujours 0

je ne sais plus quoi faire, merci pour votre aide





Publicité
Poster une réponse
Anonyme