nb.si

Le
jp
Bonjour,
J'ai un tableau dans lequel j'ai des T majuscules et des t minuscules.
NB.SI(plage;"T") donne le même résultat que NB.SI(plage;"t").
Y a t-il une solution pour faire la différence?
Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Modeste
Le #17732961
Bonsour® jp avec ferveur ;o))) vous nous disiez :

J'ai un tableau dans lequel j'ai des T majuscules et des t minuscules.
NB.SI(plage;"T") donne le même résultat que NB.SI(plage;"t").
Y a t-il une solution pour faire la différence?



=SOMMEPROD(1*(CODE($A$1:$A$18)=CODE("T")))
=SOMMEPROD(1*(CODE($A$1:$A$18)=CODE("t")))


--
--
@+
;o)))
jp
Le #17732941
On 3 nov, 12:02, "Modeste"
Bonsour® jp  avec ferveur  ;o))) vous nous disiez :

> J'ai un tableau dans lequel j'ai des T majuscules et des t minuscules.
> NB.SI(plage;"T") donne le même résultat que NB.SI(plage;"t").
> Y a t-il une solution pour faire la différence?

=SOMMEPROD(1*(CODE($A$1:$A$18)=CODE("T")))
=SOMMEPROD(1*(CODE($A$1:$A$18)=CODE("t")))

--
--
@+
;o)))



Très bien merci Modeste
Corto
Le #17732931
Bonjour jp,
=NB(--TROUVE("t";plage)) a valider par Ctrl+Maj+Supp

Corto

jp a écrit :
Bonjour,
J'ai un tableau dans lequel j'ai des T majuscules et des t minuscules.
NB.SI(plage;"T") donne le même résultat que NB.SI(plage;"t").
Y a t-il une solution pour faire la différence?
Merci



Jacky
Le #17732921
Bonjour,

Ou encore ;o)
=SOMMEPROD((EXACT(plage;"T"))*1)

--
Salutations
JJ


"jp"
Bonjour,
J'ai un tableau dans lequel j'ai des T majuscules et des t minuscules.
NB.SI(plage;"T") donne le même résultat que NB.SI(plage;"t").
Y a t-il une solution pour faire la différence?
Merci
legege
Le #17770831
Bonjour à tous,

j'essaye d'utiliser vos 2 formules qui marchent très bien si aucune cellule
n'est vide, par contre si au moins une est vide j'ai #VALEUR comme résultat.
j'essaye avec cette formule :
SOMMEPROD((NON($C10:BL10=""))*(CODE($C10:$BL10)=CODE("r"))*1)
ou celle-là :
SOMMEPROD((NON(ESTVIDE($C10:BL10))*(CODE($C10:$BL10)=CODE("r"))*1))
mais j'ai toujours : #valeur en résultat
quelqu'un peut-il m'aider ?

d'avance merci
legege

"Jacky" a écrit :

Bonjour,

Ou encore ;o)
=SOMMEPROD((EXACT(plage;"T"))*1)

--
Salutations
JJ


"jp"
Bonjour,
J'ai un tableau dans lequel j'ai des T majuscules et des t minuscules.
NB.SI(plage;"T") donne le même résultat que NB.SI(plage;"t").
Y a t-il une solution pour faire la différence?
Merci





Corto
Le #17772051
Bonjour legege,
=NB(--TROUVE("r";plage)) fonctionne même avec des cellules vides d ans la
plage

Corto

legege a écrit :
Bonjour à tous,

j'essaye d'utiliser vos 2 formules qui marchent très bien si aucun e cellule
n'est vide, par contre si au moins une est vide j'ai #VALEUR comme rà ©sultat.
j'essaye avec cette formule :
SOMMEPROD((NON($C10:BL10=""))*(CODE($C10:$BL10)=CODE("r"))*1)
ou celle-là :
SOMMEPROD((NON(ESTVIDE($C10:BL10))*(CODE($C10:$BL10)=CODE("r"))*1))
mais j'ai toujours : #valeur en résultat
quelqu'un peut-il m'aider ?

d'avance merci
legege

"Jacky" a écrit :


Bonjour,

Ou encore ;o)
=SOMMEPROD((EXACT(plage;"T"))*1)

--
Salutations
JJ


"jp"
Bonjour,
J'ai un tableau dans lequel j'ai des T majuscules et des t minuscules.
NB.SI(plage;"T") donne le même résultat que NB.SI(plage;"t") .
Y a t-il une solution pour faire la différence?
Merci








legege
Le #17773361
Re,

désolé, mais il semble que cela ne marche pas : le résultat ne me donne plus
#valeur mais 0 sauf si la plage n'est que d'une case !!

question subsidiaire : à quoi sert les 2 tirets dans la formule que tu m'as
donné ?

legege

"Corto" a écrit :

Bonjour legege,
=NB(--TROUVE("r";plage)) fonctionne même avec des cellules vides dans la
plage

Corto

legege a écrit :
> Bonjour à tous,
>
> j'essaye d'utiliser vos 2 formules qui marchent très bien si aucune cellule
> n'est vide, par contre si au moins une est vide j'ai #VALEUR comme résultat.
> j'essaye avec cette formule :
> SOMMEPROD((NON($C10:BL10=""))*(CODE($C10:$BL10)=CODE("r"))*1)
> ou celle-là :
> SOMMEPROD((NON(ESTVIDE($C10:BL10))*(CODE($C10:$BL10)=CODE("r"))*1))
> mais j'ai toujours : #valeur en résultat
> quelqu'un peut-il m'aider ?
>
> d'avance merci
> legege
>
> "Jacky" a écrit :
>
>
>> Bonjour,
>>
>> Ou encore ;o)
>> =SOMMEPROD((EXACT(plage;"T"))*1)
>>
>> --
>> Salutations
>> JJ
>>
>>
>> "jp" >>
>> Bonjour,
>> J'ai un tableau dans lequel j'ai des T majuscules et des t minuscules.
>> NB.SI(plage;"T") donne le même résultat que NB.SI(plage;"t").
>> Y a t-il une solution pour faire la différence?
>> Merci
>>
>>
>>
>>



Jacky
Le #17773641
RE..
j'essaye d'utiliser vos 2 formules qui marchent très bien si aucune
cellule
n'est vide, par contre si au moins une est vide j'ai #VALEUR comme
résultat.


???
Voir ici
http://cjoint.com/?lhnRLhnojM
--
Salutations
JJ


"legege"
Bonjour à tous,

j'essaye d'utiliser vos 2 formules qui marchent très bien si aucune
cellule
n'est vide, par contre si au moins une est vide j'ai #VALEUR comme
résultat.
j'essaye avec cette formule :
SOMMEPROD((NON($C10:BL10=""))*(CODE($C10:$BL10)=CODE("r"))*1)
ou celle-là :
SOMMEPROD((NON(ESTVIDE($C10:BL10))*(CODE($C10:$BL10)=CODE("r"))*1))
mais j'ai toujours : #valeur en résultat
quelqu'un peut-il m'aider ?

d'avance merci
legege

"Jacky" a écrit :

Bonjour,

Ou encore ;o)
=SOMMEPROD((EXACT(plage;"T"))*1)

--
Salutations
JJ


"jp"
Bonjour,
J'ai un tableau dans lequel j'ai des T majuscules et des t minuscules.
NB.SI(plage;"T") donne le même résultat que NB.SI(plage;"t").
Y a t-il une solution pour faire la différence?
Merci







Corto
Le #17773991
Bonjour legege,
Il faut valider par Ctrl+Maj+Supp (formule matricielle)
les -- servent à remplacer Vrai ou Faux par 0 ou 1

Corto

legege a écrit :
Re,

désolé, mais il semble que cela ne marche pas : le résul tat ne me donne plus
#valeur mais 0 sauf si la plage n'est que d'une case !!

question subsidiaire : à quoi sert les 2 tirets dans la formule qu e tu m'as
donné ?

legege

"Corto" a écrit :


Bonjour legege,
=NB(--TROUVE("r";plage)) fonctionne même avec des cellules vide s dans la
plage

Corto

legege a écrit :

Bonjour à tous,

j'essaye d'utiliser vos 2 formules qui marchent très bien si auc une cellule
n'est vide, par contre si au moins une est vide j'ai #VALEUR comme rà ©sultat.
j'essaye avec cette formule :
SOMMEPROD((NON($C10:BL10=""))*(CODE($C10:$BL10)=CODE("r"))*1)
ou celle-là :
SOMMEPROD((NON(ESTVIDE($C10:BL10))*(CODE($C10:$BL10)=CODE("r"))*1))
mais j'ai toujours : #valeur en résultat
quelqu'un peut-il m'aider ?

d'avance merci
legege

"Jacky" a écrit :



Bonjour,

Ou encore ;o)
=SOMMEPROD((EXACT(plage;"T"))*1)

--
Salutations
JJ


"jp"
Bonjour,
J'ai un tableau dans lequel j'ai des T majuscules et des t minuscule s.
NB.SI(plage;"T") donne le même résultat que NB.SI(plage;"t ").
Y a t-il une solution pour faire la différence?
Merci













legege
Le #17774181
Re,

merci beaucoup, ça marche !!

cordialement
legege

"Jacky" a écrit :

RE..
> j'essaye d'utiliser vos 2 formules qui marchent très bien si aucune
> cellule
> n'est vide, par contre si au moins une est vide j'ai #VALEUR comme
> résultat.
???
Voir ici
http://cjoint.com/?lhnRLhnojM
--
Salutations
JJ


"legege"
> Bonjour à tous,
>
> j'essaye d'utiliser vos 2 formules qui marchent très bien si aucune
> cellule
> n'est vide, par contre si au moins une est vide j'ai #VALEUR comme
> résultat.
> j'essaye avec cette formule :
> SOMMEPROD((NON($C10:BL10=""))*(CODE($C10:$BL10)=CODE("r"))*1)
> ou celle-là :
> SOMMEPROD((NON(ESTVIDE($C10:BL10))*(CODE($C10:$BL10)=CODE("r"))*1))
> mais j'ai toujours : #valeur en résultat
> quelqu'un peut-il m'aider ?
>
> d'avance merci
> legege
>
> "Jacky" a écrit :
>
>> Bonjour,
>>
>> Ou encore ;o)
>> =SOMMEPROD((EXACT(plage;"T"))*1)
>>
>> --
>> Salutations
>> JJ
>>
>>
>> "jp" >>
>> Bonjour,
>> J'ai un tableau dans lequel j'ai des T majuscules et des t minuscules.
>> NB.SI(plage;"T") donne le même résultat que NB.SI(plage;"t").
>> Y a t-il une solution pour faire la différence?
>> Merci
>>
>>
>>





Publicité
Poster une réponse
Anonyme