NB SI...

Le
Manu
Bonsoir,

J'ai de A1 à A280 das cellules remplis avec diverses lettres A ; B ;
C..etc et ca va jusqu'à Y.

Je souhaiterais compter le nombre de cellules utiliser hormis celle qui sont
égal à : B ; D ; E ; F ; H ; L ; M ; T ; U ; V

J'ai tenté avec NB.SI mais ca fait vraiment une formule à rallonge, il doit
y avoir mieux.

Merci

Manu
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #18814901
Bonsoir,

=SOMMEPROD(--(A1:A26=
{"A"."C"."G"."I"."J"."K"."N"."O"."P"."Q"."R"."S"."W"."X"."Y"."Z"}))

JB
http://boisgontierjacques.free.fr

On 3 mar, 18:09, "Manu"
Bonsoir,

J'ai de A1 à A280 das cellules remplis avec diverses lettres A ; B ;
C.....etc et ca va jusqu'à Y.

Je souhaiterais compter le nombre de cellules utiliser hormis celle qui s ont
égal à : B ; D ; E ; F ; H ; L ; M ; T ; U ; V

J'ai tenté avec NB.SI mais ca fait vraiment une formule à rallonge, i l doit
y avoir mieux.

Merci

Manu


JB
Le #18814871
Si 'tcodes' contient B ; D ; E ; F ; H ; L ; M ; T ; U ; V


=SOMMEPROD(--(NON(ESTNUM(EQUIV(A1:A100;tcodes;0)))))

JB

On 3 mar, 19:26, JB
Bonsoir,

=SOMMEPROD(--(A1:A26=
{"A"."C"."G"."I"."J"."K"."N"."O"."P"."Q"."R"."S"."W"."X"."Y"."Z"}))

JBhttp://boisgontierjacques.free.fr

On 3 mar, 18:09, "Manu"


> Bonsoir,

> J'ai de A1 à A280 das cellules remplis avec diverses lettres A ; B ;
> C.....etc et ca va jusqu'à Y.

> Je souhaiterais compter le nombre de cellules utiliser hormis celle qui sont
> égal à : B ; D ; E ; F ; H ; L ; M ; T ; U ; V

> J'ai tenté avec NB.SI mais ca fait vraiment une formule à rallonge, il doit
> y avoir mieux.

> Merci

> Manu- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


Manu
Le #18815261
Merci JB,
Autant fonctionne
=SOMMEPROD(--(A1:A26={"A"."C"."G"."I"."J"."K"."N"."O"."P"."Q"."R"."S"."W"."X"."Y"."Z"}))

En revanche, ne fonctionne pas
=SOMMEPROD(--(NON(ESTNUM(EQUIV(A1:A100;tcodes;0)))))

Mais ceci dis chapeau , ca me raccourcis ma formule quelque chose de pepere
car avec mon
=NBVAL(G1:G27)-NB.SI($G$1:$G$27;"B")-NB.SI($G$1:$G$27;"D")-NB.SI($G$1:$G$27;"E")...........................
je ne m'en sortais pas sur la longueur.

Merci

Manu

"JB"
Si 'tcodes' contient B ; D ; E ; F ; H ; L ; M ; T ; U ; V


=SOMMEPROD(--(NON(ESTNUM(EQUIV(A1:A100;tcodes;0)))))

JB

On 3 mar, 19:26, JB
Bonsoir,

=SOMMEPROD(--(A1:A26 > {"A"."C"."G"."I"."J"."K"."N"."O"."P"."Q"."R"."S"."W"."X"."Y"."Z"}))

JBhttp://boisgontierjacques.free.fr

On 3 mar, 18:09, "Manu"


> Bonsoir,

> J'ai de A1 à A280 das cellules remplis avec diverses lettres A ; B ;
> C.....etc et ca va jusqu'à Y.

> Je souhaiterais compter le nombre de cellules utiliser hormis celle qui
> sont
> égal à : B ; D ; E ; F ; H ; L ; M ; T ; U ; V

> J'ai tenté avec NB.SI mais ca fait vraiment une formule à rallonge, il
> doit
> y avoir mieux.

> Merci

> Manu- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


JB
Le #18815541
Voir PJ

http://cjoint.com/?dfuWXveiOd

JB

On 3 mar, 20:16, "Manu"
Merci JB,
Autant  fonctionne
=SOMMEPROD(--(A1:A26={"A"."C"."G"."I"."J"."K"."N"."O"."P"."Q"."R"."S" ."W"."­X"."Y"."Z"}))

En revanche, ne fonctionne pas
=SOMMEPROD(--(NON(ESTNUM(EQUIV(A1:A100;tcodes;0)))))

Mais ceci dis chapeau , ca me raccourcis ma formule quelque chose de pepe re
car avec mon
=NBVAL(G1:G27)-NB.SI($G$1:$G$27;"B")-NB.SI($G$1:$G$27;"D")-NB.SI($G$1:$ G$27­;"E")...........................
je ne m'en sortais pas sur la longueur.

Merci

Manu

"JB"
Si 'tcodes' contient B ; D ; E ; F ; H ; L ; M ; T ; U ; V

=SOMMEPROD(--(NON(ESTNUM(EQUIV(A1:A100;tcodes;0)))))

JB

On 3 mar, 19:26, JB


> Bonsoir,

> =SOMMEPROD(--(A1:A26=
> {"A"."C"."G"."I"."J"."K"."N"."O"."P"."Q"."R"."S"."W"."X"."Y"."Z"}))

> JBhttp://boisgontierjacques.free.fr

> On 3 mar, 18:09, "Manu"
> > Bonsoir,

> > J'ai de A1 à A280 das cellules remplis avec diverses lettres A ; B ;
> > C.....etc et ca va jusqu'à Y.

> > Je souhaiterais compter le nombre de cellules utiliser hormis celle q ui
> > sont
> > égal à : B ; D ; E ; F ; H ; L ; M ; T ; U ; V

> > J'ai tenté avec NB.SI mais ca fait vraiment une formule à rallong e, il
> > doit
> > y avoir mieux.

> > Merci

> > Manu- Masquer le texte des messages précédents -

> - Afficher le texte des messages précédents -- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


MichDenis
Le #18816161
il y a aussi ceci :

=SOMME(NB.SI(D1:D6;{"x";"s";"d";"e";"f";"a"}))
Moi, c'était à titre d'exemple... remplace ces lettres
par celle que tu veux compter.
Pas besoin d'une validation matricielle.



"Manu"
Bonsoir,

J'ai de A1 à A280 das cellules remplis avec diverses lettres A ; B ;
C.....etc et ca va jusqu'à Y.

Je souhaiterais compter le nombre de cellules utiliser hormis celle qui sont
égal à : B ; D ; E ; F ; H ; L ; M ; T ; U ; V

J'ai tenté avec NB.SI mais ca fait vraiment une formule à rallonge, il doit
y avoir mieux.

Merci

Manu
Michel Angelosanto
Le #18816121
Essaie plutôt ceci:
=SOMMEPROD((CHERCHE(A1:A280;"BDEFHLMTUVACGIJKNOPQRSWXYZ")>10)*1)

A+
"Manu" news:
Bonsoir,

J'ai de A1 à A280 das cellules remplis avec diverses lettres A ; B ;
C.....etc et ca va jusqu'à Y.

Je souhaiterais compter le nombre de cellules utiliser hormis celle qui
sont égal à : B ; D ; E ; F ; H ; L ; M ; T ; U ; V

J'ai tenté avec NB.SI mais ca fait vraiment une formule à rallonge, il
doit y avoir mieux.

Merci

Manu





--
Michel Angelosanto, Bordeaux
Dernières mises à jour du site Voyage au pays Internet
http://angelosa.free.fr/index.php?t=8
Manu
Le #18817921
Super,

Merci à tous et bonne journée

Manu

"MichDenis"
il y a aussi ceci :

=SOMME(NB.SI(D1:D6;{"x";"s";"d";"e";"f";"a"}))
Moi, c'était à titre d'exemple... remplace ces lettres
par celle que tu veux compter.
Pas besoin d'une validation matricielle.



"Manu" discussion :

Bonsoir,

J'ai de A1 à A280 das cellules remplis avec diverses lettres A ; B ;
C.....etc et ca va jusqu'à Y.

Je souhaiterais compter le nombre de cellules utiliser hormis celle qui
sont
égal à : B ; D ; E ; F ; H ; L ; M ; T ; U ; V

J'ai tenté avec NB.SI mais ca fait vraiment une formule à rallonge, il
doit
y avoir mieux.

Merci

Manu



Publicité
Poster une réponse
Anonyme