NB.SI sur texte qui contient des chiffres

Le
ppuy Hors ligne
Bonjour à tous,

J'ai une feuille F qui contient entre autres valeurs '0000880' et '0880E0000' en colonne A (une seule fois chacun)

Dans une autre feuille, en colonne A une référence et en B une formule NB.SI('F'!A:A;"="&A2)

Si A2 contient '0000880', le résultat en B2 est 2 alors que j'attends 1. Cette fonction voit 0880E000 comme le même chiffre que 0000880

Comment faire sans être obligé de rajouter un caractère dans la référence (ex X0000880 qui sera vu comme un texte ) ?

Merci de votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #23182511
Bonjour,
Utilise une colonne supplémenatire (ici, B) dans laquelle tu mets en B1
:
ÎLLULE("format";A1)
recopie vers le bas.
Pour obtenir le résultat, utilise, si tu as XL2007 ou ultérieure :
=NB.SI.ENS(F!A1:A10;880;F!B1:B10;"S")
sinon :
=SOMMEPROD((F!A1:A10ˆ0)*(F!B1:B10="s"))
Cordialement.
Daniel


Bonjour à tous,

J'ai une feuille F qui contient entre autres valeurs '0000880' et '0880E0000'
en colonne A (une seule fois chacun)

Dans une autre feuille, en colonne A une référence et en B une formule
NB.SI('F'!A:A;"="&A2)

Si A2 contient '0000880', le résultat en B2 est 2 alors que j'attends 1.
Cette fonction voit 0880E000 comme le même chiffre que 0000880 ...

Comment faire sans être obligé de rajouter un caractère dans la référence (ex
X0000880 qui sera vu comme un texte ) ?

Merci de votre aide.
Le #23182781
DanielCo a écrit le 07/03/2011 à 11h17 :
Bonjour,
Utilise une colonne supplémenatire (ici, B) dans laquelle tu mets en B1
:
ÎLLULE("format";A1)
recopie vers le bas.
Pour obtenir le résultat, utilise, si tu as XL2007 ou ultérieure
:
=NB.SI.ENS(F!A1:A10;880;F!B1:B10;"S")
sinon :
=SOMMEPROD((F!A1:A10ˆ0)*(F!B1:B10="s"))
Cordialement.
Daniel


Bonjour à tous,

J'ai une feuille F qui contient entre autres valeurs '0000880' et '0880E0000'
en colonne A (une seule fois chacun)

Dans une autre feuille, en colonne A une référence et en B une
formule
NB.SI('F'!A:A;"="&A2)

Si A2 contient '0000880', le résultat en B2 est 2 alors que j'attends
1.
Cette fonction voit 0880E000 comme le même chiffre que 0000880 ...

Comment faire sans être obligé de rajouter un caractère
dans la référence (ex
X0000880 qui sera vu comme un texte ) ?

Merci de votre aide.




Bonjour Daniel,


merci pour ta réponse, mais elle ne résout pas mon problème, car, bien que forcées en "texte", la fonction CELLULE (et non ÎLLULE comme dans ton message :=)) renvoi "S".

Pierre
DanielCo
Le #23182941
???
Daniel


DanielCo a écrit le 07/03/2011 à 11h17 :
Bonjour,
Utilise une colonne supplémenatire (ici, B) dans laquelle tu mets en B1



ÎLLULE("format";A1)
recopie vers le bas.
Pour obtenir le résultat, utilise, si tu as XL2007 ou ultérieure



=NB.SI.ENS(F!A1:A10;880;F!B1:B10;"S")
sinon :
=SOMMEPROD((F!A1:A10
Le #23183031
DanielCo a écrit le 07/03/2011 à 14h25 :
???
Daniel


DanielCo a écrit le 07/03/2011 à 11h17 :
Bonjour,
Utilise une colonne supplémenatire (ici, B) dans laquelle tu mets en
B1




ÎLLULE("format";A1)
recopie vers le bas.
Pour obtenir le résultat, utilise, si tu as XL2007 ou
ultérieure




=NB.SI.ENS(F!A1:A10;880;F!B1:B10;"S")
sinon :
=SOMMEPROD((F!A1:A10






Daniel,

Voici ce qui est un exemple de mon problème :
A B C D
1 000800 S
2 0800e00 S 000800 2

et, en visualisation des formules :

000800 ÎLLULE("format";A1)
0800e00 ÎLLULE("format";A2) 000800 =NB.SI(A:A;D2)


En D2 j'obtiens 2 alors que j'attends 1 ...

Merci d'avance
DanielCo
Le #23183301
Quel est le format des cellules de lascolonnes A et C ?
Un exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj201103/cijWGtAPHl.xls
Daniel


DanielCo a écrit le 07/03/2011 à 14h25 :
???
Daniel


DanielCo a écrit le 07/03/2011 à 11h17 :
Bonjour,
Utilise une colonne supplémenatire (ici, B) dans laquelle tu mets en
B1




ÎLLULE("format";A1)
recopie vers le bas.
Pour obtenir le résultat, utilise, si tu as XL2007 ou
ultérieure




=NB.SI.ENS(F!A1:A10;880;F!B1:B10;"S")
sinon :
=SOMMEPROD((F!A1:A10






Daniel,

Voici ce qui est un exemple de mon problème :
A B C D
1 000800 S
2 0800e00 S 000800 2

et, en visualisation des formules :

000800 ÎLLULE("format";A1)
0800e00 ÎLLULE("format";A2) 000800 =NB.SI(A:A;D2)


En D2 j'obtiens 2 alors que j'attends 1 ...

Merci d'avance
Le #23183341
DanielCo a écrit le 07/03/2011 à 16h43 :
Quel est le format des cellules de lascolonnes A et C ?
Un exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj201103/cijWGtAPHl.xls
Daniel


DanielCo a écrit le 07/03/2011 à 14h25 :
???
Daniel


DanielCo a écrit le 07/03/2011 à 11h17 :
Bonjour,
Utilise une colonne supplémenatire (ici, B) dans laquelle tu mets en
B1





ÎLLULE("format";A1)
recopie vers le bas.
Pour obtenir le résultat, utilise, si tu as XL2007 ou
ultérieure





=NB.SI.ENS(F!A1:A10;880;F!B1:B10;"S")
sinon :
=SOMMEPROD((F!A1:A10









Daniel,

Voici ce qui est un exemple de mon problème :
A B C D
1 000800 S
2 0800e00 S 000800 2

et, en visualisation des formules :

000800 ÎLLULE("format";A1)
0800e00 ÎLLULE("format";A2) 000800 =NB.SI(A:A;D2)


En D2 j'obtiens 2 alors que j'attends 1 ...

Merci d'avance




A et C sont en format texte (ce sont des références de produits, toutes traitées en texte, notamment pour gérer des références commençant par 0)

Ton exemple montre bien que le résultat n'est pas ce que je veux : je veux compter séparément 000880 et 00880E000 comme deux références distinctes.

Pierre
DanielCo
Le #23183461
A et C sont en format texte (ce sont des références de produits, toutes
traitées en texte, notamment pour gérer des références commençant par 0)

Ton exemple montre bien que le résultat n'est pas ce que je veux : je veux
compter séparément 000880 et 00880E000 comme deux références distinctes.

Pierre



Alors :
=SOMMEPROD(--ESTERR(CHERCHE("e";A1:A10))*(A1:A10Â))
Daniel
michel ou sam
Le #23184201
Bonjour,
j'étais allé chercher des T, des EXACT, des TEXTE et je m'aperçois que
=SOMMEPROD((A1:A10Â)*1)
fonctionne !

Michel

"DanielCo" il32dl$m74$
A et C sont en format texte (ce sont des références de produits, toutes
traitées en texte, notamment pour gérer des références commençant par 0)

Ton exemple montre bien que le résultat n'est pas ce que je veux : je
veux
compter séparément 000880 et 00880E000 comme deux références distinctes.
Pierre



Alors :
=SOMMEPROD(--ESTERR(CHERCHE("e";A1:A10))*(A1:A10Â))
Daniel


DanielCo
Le #23185351
Bonjour,
Génial de simplicité !
Daniel
Bonjour,
j'étais allé chercher des T, des EXACT, des TEXTE et je m'aperçois que
=SOMMEPROD((A1:A10Â)*1)
fonctionne !

Michel

"DanielCo" il32dl$m74$
A et C sont en format texte (ce sont des références de produits, toutes
traitées en texte, notamment pour gérer des références commençant par 0)

Ton exemple montre bien que le résultat n'est pas ce que je veux : je veux
compter séparément 000880 et 00880E000 comme deux références distinctes.
Pierre



Alors :
=SOMMEPROD(--ESTERR(CHERCHE("e";A1:A10))*(A1:A10Â))
Daniel


Publicité
Poster une réponse
Anonyme