nb de valeurs différentes d'une colonne

Le
antho
bonjour
je cherche à déterminer le nombre de valeurs différentes d'une colone
merci pour vos réponse
anthony
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #20713741
Bonjour,

http://boisgontierjacques.free.fr/pages_site/sommeprod.htm#CompterNbDiff

JB


On 7 déc, 13:26, antho
bonjour
je cherche à déterminer le nombre de valeurs différentes d'une colo ne
merci pour vos réponse
anthony


FFO
Le #20713911
Salut à toi
soit la colonne A avec les différentes valeurs
Mets comme valeur 1 en B1
Mets en colonne B à partir de B2 en regard de chaque valeur cette formule :

=SI(A2<>A1;B1+1;B1) (Mets la en B2 et copier/coller vers le bas)

Tu tries ta colonne A

Ta dernière cellule colonne B te donnes le nombre de valeurs différentes

Fais des essais et dis moi !!!!!!
Caetera
Le #20714721
"antho"
bonjour
je cherche à déterminer le nombre de valeurs différentes d'une colone
merci pour vos réponse



**********************

Les solutions (formules matricielles) seront différentes selon le contenu
possible des cellules :

Numériques et texte mélangées, pas de vides ni valeurs d'erreur :
=SOMME(1/NB.SI(laPlage;laPlage))

Contenus idem mais avec vides (sans les compter) :
=SOMME(SI(NBCAR(laPlage);1/NB.SI(laPlage;laPlage)))

Contenus idem mais avec vides (sans les compter) et valeurs d'erreurs (sans les
compter) :
=SOMME(SI(ESTVIDE(laPlage);"";1/NB.SI(laPlage;laPlage)-ESTERREUR(laPlage)))

Contenus idem mais avec vides (sans les compter) et valeurs d'erreurs (en les
comptant !) :
=SOMME(SI(NB.SI(laPlage;laPlage)<>0;1/NB.SI(laPlage;laPlage);""))

Exemples non exhaustifs
http://www.cijoint.fr/cjlink.php?file=cj200912/cijP8v4fNy.xls

Etc
antho
Le #20720891
merci pour les réponses
j'utilise la formule suivante" =SOMMEPROD(1/NB.SI(F2:F569;F2:F569))" et ç a
fonctionne pour mes données

Anthony

"Caetera" a écrit :

"Caetera"

erreur de fichier...........
> http://www.cijoint.fr/cjlink.php?file=cj200912/cijP8v4fNy.xls

Le bon ...............
http://www.cijoint.fr/cjlink.php?file=cj200912/cij9Kp0q9W.xls


.



Publicité
Poster une réponse
Anonyme