NBVAL avec cellules contenant formules

Le
Unss34
Bonjour,
Voila mon problème: à l'arrivée d'une course, un classement "scratch" est
affiché en colonne B.
J'aimerai que le classement par catégorie (F ou G en colonne I) se fasse en
colonne M pour les G et N pour les F.
J'ai mis cette formule:

=SI(I4="G";NBVAL(debG:INDIRECT(ADRESSE(LIGNE()-1;COLONNE())))+1;"")
debG est la 1ère cellule de la colonne
mais puisqu'il y a des formules dans les cellules, même quand elles sont
'vides', elles sont comptabilisées et mon incrémentation est fausse.
Pas facile à expliquer, le fichier est ici:
http://cjoint.com/?keseWFfo8c
Merci de votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ChrisV
Le #17421671
Bonjour Unss34,

Selon les données de ton exemple, en M3:
(à saisir sans les { } et valider par Ctrl +Shift + Entrée)

{=SI((D3<>"")*(N3="");NB.SI(I$3:I3;M$1)+NB(N$3:N3);"")}
à recopier vers Mxx

en N3
{=SI((D3<>"")*(M3="");NB.SI(I$3:I3;N$1)+NB(M$3:M3);"")}
à recopier vers Nxx

Chris
[de passage...]



"Unss34" %
Bonjour,
Voila mon problème: à l'arrivée d'une course, un classement "scratch" est
affiché en colonne B.
J'aimerai que le classement par catégorie (F ou G en colonne I) se fasse
en colonne M pour les G et N pour les F.
J'ai mis cette formule:

=SI(I4="G";NBVAL(debG:INDIRECT(ADRESSE(LIGNE()-1;COLONNE())))+1;"")
debG est la 1ère cellule de la colonne
mais puisqu'il y a des formules dans les cellules, même quand elles sont
'vides', elles sont comptabilisées et mon incrémentation est fausse.
Pas facile à expliquer, le fichier est ici:
http://cjoint.com/?keseWFfo8c
Merci de votre aide.




Unss34
Le #17422071
Merci de cette proposition, mais elle donne 0 dans toutes les cellules...
Je l'ai bien saisie mais je ne la comprends pas et ne peux donc l'adapter...

"ChrisV"
Bonjour Unss34,

Selon les données de ton exemple, en M3:
(à saisir sans les { } et valider par Ctrl +Shift + Entrée)

{=SI((D3<>"")*(N3="");NB.SI(I$3:I3;M$1)+NB(N$3:N3);"")}
à recopier vers Mxx

en N3
{=SI((D3<>"")*(M3="");NB.SI(I$3:I3;N$1)+NB(M$3:M3);"")}
à recopier vers Nxx

Chris
[de passage...]



"Unss34" %
Bonjour,
Voila mon problème: à l'arrivée d'une course, un classement "scratch" est
affiché en colonne B.
J'aimerai que le classement par catégorie (F ou G en colonne I) se fasse
en colonne M pour les G et N pour les F.
J'ai mis cette formule:

=SI(I4="G";NBVAL(debG:INDIRECT(ADRESSE(LIGNE()-1;COLONNE())))+1;"")
debG est la 1ère cellule de la colonne
mais puisqu'il y a des formules dans les cellules, même quand elles sont
'vides', elles sont comptabilisées et mon incrémentation est fausse.
Pas facile à expliquer, le fichier est ici:
http://cjoint.com/?keseWFfo8c
Merci de votre aide.








ChrisV
Le #17422281
Re,

Au moins deux solutions alors...

a) ajouter aux formules proposées la condition suppllémentaire I3<>""
soit, en M3:
{=SI((D3<>"")*(N3="")*(I3<>"");NB.SI(I$3:I3;M$1)+NB(N$3:N3);"")}

b) tout en conservant les propositions précédentes
mettre la plage de cellules M3:Nxx au format personnalisé:
0;;;;


ChrisV


"Unss34" OSA%
Merci de cette proposition, mais elle donne 0 dans toutes les cellules...
Je l'ai bien saisie mais je ne la comprends pas et ne peux donc
l'adapter...

"ChrisV" news:
Bonjour Unss34,

Selon les données de ton exemple, en M3:
(à saisir sans les { } et valider par Ctrl +Shift + Entrée)

{=SI((D3<>"")*(N3="");NB.SI(I$3:I3;M$1)+NB(N$3:N3);"")}
à recopier vers Mxx

en N3
{=SI((D3<>"")*(M3="");NB.SI(I$3:I3;N$1)+NB(M$3:M3);"")}
à recopier vers Nxx

Chris
[de passage...]



"Unss34" %
Bonjour,
Voila mon problème: à l'arrivée d'une course, un classement "scratch"
est affiché en colonne B.
J'aimerai que le classement par catégorie (F ou G en colonne I) se fasse
en colonne M pour les G et N pour les F.
J'ai mis cette formule:

=SI(I4="G";NBVAL(debG:INDIRECT(ADRESSE(LIGNE()-1;COLONNE())))+1;"")
debG est la 1ère cellule de la colonne
mais puisqu'il y a des formules dans les cellules, même quand elles sont
'vides', elles sont comptabilisées et mon incrémentation est fausse.
Pas facile à expliquer, le fichier est ici:
http://cjoint.com/?keseWFfo8c
Merci de votre aide.












Sam
Le #17422451
Bonjour,
pourquoi pas tout simplement
en M3: =SI(I3="G";B3;"")
en N3: =SI(I3="F";B3;"")
puis tirer vers le bas pour les autres cellules
?
Cordialement
Michel dit "Sam"
"Unss34" %
Bonjour,
Voila mon problème: à l'arrivée d'une course, un classement "scratch" est
affiché en colonne B.
J'aimerai que le classement par catégorie (F ou G en colonne I) se fasse
en colonne M pour les G et N pour les F.
J'ai mis cette formule:

=SI(I4="G";NBVAL(debG:INDIRECT(ADRESSE(LIGNE()-1;COLONNE())))+1;"")
debG est la 1ère cellule de la colonne
mais puisqu'il y a des formules dans les cellules, même quand elles sont
'vides', elles sont comptabilisées et mon incrémentation est fausse.
Pas facile à expliquer, le fichier est ici:
http://cjoint.com/?keseWFfo8c
Merci de votre aide.




Unss34
Le #17422571
Merci Sam, mais avec ta proposition, on obtient le classement du scratch,
et non le classement de chaque catégorie.
En travaillant, j'ai finalement trouvé une solution: en ligne 4

=SI(I4="G";NBVAL($M$3)-NB.SI($M$3:$M$3;""+1;"")
je retranche le nb de cellules avec "" du nb de valeurs contenues depuis M3
jusqu'à la ligne précédente et je rajoute 1
puis tirer en bas, c'est bon.
Peut-être un peu lourdingue...

"Sam" 48e7c5da$0$895$

Bonjour,
pourquoi pas tout simplement
en M3: =SI(I3="G";B3;"")
en N3: =SI(I3="F";B3;"")
puis tirer vers le bas pour les autres cellules
?
Cordialement
Michel dit "Sam"
"Unss34" %
Bonjour,
Voila mon problème: à l'arrivée d'une course, un classement "scratch" est
affiché en colonne B.
J'aimerai que le classement par catégorie (F ou G en colonne I) se fasse
en colonne M pour les G et N pour les F.
J'ai mis cette formule:

=SI(I4="G";NBVAL(debG:INDIRECT(ADRESSE(LIGNE()-1;COLONNE())))+1;"")
debG est la 1ère cellule de la colonne
mais puisqu'il y a des formules dans les cellules, même quand elles sont
'vides', elles sont comptabilisées et mon incrémentation est fausse.
Pas facile à expliquer, le fichier est ici:
http://cjoint.com/?keseWFfo8c
Merci de votre aide.








Fredo P
Le #17422551
Je vous salut bien bas cher Chris
Chris
[de passage...]


Passez un bon weekend.



ChrisV
Le #17423131
Mais tout le plaisir est pour moi Fred ! ;-)
Bon w.e


ChrisV


"Fredo P" message de news:
Je vous salut bien bas cher Chris
Chris
[de passage...]


Passez un bon weekend.







Publicité
Poster une réponse
Anonyme