NET Framework 3.5 sp1 et imprimantes non validées ?

Le
Roland Pisano
Bonjour,

J'ai le problème suivant sur ma "ferme" TSE Windows 2003 server (2 AD en
standard, 5 TSE en enterprise).
Tout marchait très bien mais depuis l'application du SP1 du Net Framework
3.5, quand les utilisateurs TSE se logguent, ils ont un message :
"Le logiciel que vous êtes en train d'installer pour ce matériel :
Imprimantes
n'a pas été validé lors du test permettant d'obtenir le logo
Windows et vérifiant sa compatibilité avec cette version de
Windows. (Indiquez-moi pourquoi ce test est important.)
L'installation de ce logiciel peut nuire au bon
fonctionnement de votre système, maintenant ou à
l'avenir. Microsoft recommande fortement que vous
arrêtiez cette installation maintenant et contactiez le
fournisseur du matériel pour obtenir le logiciel qui a été
validé lors du test permettant d'obtenir le logo Windows."
Deux boutons : Continuer et Arrêter l'installation.

Quel que soit celui qu'on choisit, le résultat est le même : pas de
problèmes, on imprime.
Le message apparaît à partir du moment où le client RDP ou le client léger
pousse une imprimante.
Les drivers sont standardisés en HP Deskjet 990c ou HP Laserjet 2100
d'origine Windows 2003 ou PDFCreator.
Avant ce correctif, nous n'avions pas cela.
J'ai essayé de pousser une gpo pour installer les pilotes non signés sans
avertissement, mais rien n'y fait.
Il n'y a pas eu d'autres modifs. En gros, tout marchait bien sans ce
message, ce week-end je déploie le sp1 du net framework par WSUS, je reboote
individuellement les serveurs et paf, le problème est apparu.
Une recherche chez Microsoft ou sur Google ne me donne rien pour WS2003,
mais par contre je trouve un truc pour WS2008 et le net framework qui aurait
modifié une classe générique et donc tous les pilotes dépendant de
l'ancienne classe apparaissent non signés même s'ils le sont ! Un hot-fixe
est dispo pour Vista et pour WS2008, rien pour WS2003.

Une idée pour se débarrasser de ce truc ?

Cordialement,

--
Roland Pisano - Service informatique
informatique1 -at- chs-levalmont -point- fr
CHS Le Valmont - BP 16
Domaine des Rebatières - 26760 Montéléger
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Cédric GEORGEOT - Blog e-Novatic
Le #18683081
Bonjour,

Le vérification de pilote est importante pour un gage de stabilité du
serveur. La certification WHQL est donc un critère important pour les
serveurs TSE, sachant que ces mêmes serveurs plantent souvent à cause de
mauvais pilotes !

Tu n'es pas le seul =>
http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID83721

Essaye de faire un Windows Update manuellement sur 1 serveur pour tester.

Cédric GEORGEOT
Blog e-Novatic
http://blog.e-novatic.fr

--
Cédric GEORGEOT
Blog e-Novatic
http://blog.e-novatic.fr
"Roland Pisano" news:
Bonjour,

J'ai le problème suivant sur ma "ferme" TSE Windows 2003 server (2 AD en
standard, 5 TSE en enterprise).
Tout marchait très bien mais depuis l'application du SP1 du Net Framework
3.5, quand les utilisateurs TSE se logguent, ils ont un message :
"Le logiciel que vous êtes en train d'installer pour ce matériel :
Imprimantes
n'a pas été validé lors du test permettant d'obtenir le logo
Windows et vérifiant sa compatibilité avec cette version de
Windows. (Indiquez-moi pourquoi ce test est important.)
L'installation de ce logiciel peut nuire au bon
fonctionnement de votre système, maintenant ou à
l'avenir. Microsoft recommande fortement que vous
arrêtiez cette installation maintenant et contactiez le
fournisseur du matériel pour obtenir le logiciel qui a été
validé lors du test permettant d'obtenir le logo Windows."
Deux boutons : Continuer et Arrêter l'installation.

Quel que soit celui qu'on choisit, le résultat est le même : pas de
problèmes, on imprime.
Le message apparaît à partir du moment où le client RDP ou le client léger
pousse une imprimante.
Les drivers sont standardisés en HP Deskjet 990c ou HP Laserjet 2100
d'origine Windows 2003 ou PDFCreator.
Avant ce correctif, nous n'avions pas cela.
J'ai essayé de pousser une gpo pour installer les pilotes non signés sans
avertissement, mais rien n'y fait.
Il n'y a pas eu d'autres modifs. En gros, tout marchait bien sans ce
message, ce week-end je déploie le sp1 du net framework par WSUS, je
reboote individuellement les serveurs et paf, le problème est apparu.
Une recherche chez Microsoft ou sur Google ne me donne rien pour WS2003,
mais par contre je trouve un truc pour WS2008 et le net framework qui
aurait modifié une classe générique et donc tous les pilotes dépendant de
l'ancienne classe apparaissent non signés même s'ils le sont ! Un hot-fixe
est dispo pour Vista et pour WS2008, rien pour WS2003.

Une idée pour se débarrasser de ce truc ?

Cordialement,

--
Roland Pisano - Service informatique
informatique1 -at- chs-levalmont -point- fr
CHS Le Valmont - BP 16
Domaine des Rebatières - 26760 Montéléger



Roland Pisano
Le #18683941
Problème résolu. Je suis tombé sur un fichier de log (dans le dossier
windows, qui augmentait à chaque connexion TSE) qui me montrait où était le
problème : dans c:windowsdriver cachei386, j'avais 4 fichiers
(unidrv.dll, unidrvui.dll, unidrv.hlp, unires.dll) qui étaient en version
vista sp1 ! J'ai copié à la place les fichiers de Windows Server 2003 sp2 et
tout est rentré dans l'ordre.
Pourquoi est-il allé me chercher ces foutues versions, je n'en ai aucune
idée. Surtout que j'utilise wsus pour déployer les mises à jour...

Mais bon, le principal c'est que ça marche.
Ca m'a juste fait chercher une quinzaine de jours...

Merci de la réponse, j'espère que ça aidera d'autres personnes.

--
Roland Pisano - Service informatique
informatique1 -at- chs-levalmont -point- fr
CHS Le Valmont - BP 16
Domaine des Rebatières - 26760 Montéléger
"Cédric GEORGEOT - Blog e-Novatic" message de news:
Bonjour,

Le vérification de pilote est importante pour un gage de stabilité du
serveur. La certification WHQL est donc un critère important pour les
serveurs TSE, sachant que ces mêmes serveurs plantent souvent à cause de
mauvais pilotes !

Tu n'es pas le seul =>
http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID83721

Essaye de faire un Windows Update manuellement sur 1 serveur pour tester.

Cédric GEORGEOT
Blog e-Novatic
http://blog.e-novatic.fr

--
Cédric GEORGEOT
Blog e-Novatic
http://blog.e-novatic.fr
"Roland Pisano" de news:
Bonjour,

J'ai le problème suivant sur ma "ferme" TSE Windows 2003 server (2 AD en
standard, 5 TSE en enterprise).
Tout marchait très bien mais depuis l'application du SP1 du Net Framework
3.5, quand les utilisateurs TSE se logguent, ils ont un message :
"Le logiciel que vous êtes en train d'installer pour ce matériel :
Imprimantes
n'a pas été validé lors du test permettant d'obtenir le logo
Windows et vérifiant sa compatibilité avec cette version de
Windows. (Indiquez-moi pourquoi ce test est important.)
L'installation de ce logiciel peut nuire au bon
fonctionnement de votre système, maintenant ou à
l'avenir. Microsoft recommande fortement que vous
arrêtiez cette installation maintenant et contactiez le
fournisseur du matériel pour obtenir le logiciel qui a été
validé lors du test permettant d'obtenir le logo Windows."
Deux boutons : Continuer et Arrêter l'installation.

Quel que soit celui qu'on choisit, le résultat est le même : pas de
problèmes, on imprime.
Le message apparaît à partir du moment où le client RDP ou le client
léger pousse une imprimante.
Les drivers sont standardisés en HP Deskjet 990c ou HP Laserjet 2100
d'origine Windows 2003 ou PDFCreator.
Avant ce correctif, nous n'avions pas cela.
J'ai essayé de pousser une gpo pour installer les pilotes non signés sans
avertissement, mais rien n'y fait.
Il n'y a pas eu d'autres modifs. En gros, tout marchait bien sans ce
message, ce week-end je déploie le sp1 du net framework par WSUS, je
reboote individuellement les serveurs et paf, le problème est apparu.
Une recherche chez Microsoft ou sur Google ne me donne rien pour WS2003,
mais par contre je trouve un truc pour WS2008 et le net framework qui
aurait modifié une classe générique et donc tous les pilotes dépendant de
l'ancienne classe apparaissent non signés même s'ils le sont ! Un
hot-fixe est dispo pour Vista et pour WS2008, rien pour WS2003.

Une idée pour se débarrasser de ce truc ?

Cordialement,

--
Roland Pisano - Service informatique
informatique1 -at- chs-levalmont -point- fr
CHS Le Valmont - BP 16
Domaine des Rebatières - 26760 Montéléger






Publicité
Poster une réponse
Anonyme