NetBSD : LD4 (5eme disque) step 2 First Boot.

Le
olivier.burelli
bonsoir,

suite à mes premiers déboires, où lors de sysinst de NetBSD il fallait=

monter les devices pour le cinquième périphérique de la chaine LDx et
relancer sysinst.

je boot bien sur le disque NETBSD.

Néanmoins, et avec mes maigres connaissance du démarrage d'un system
BSD, j'en deduis cela :

le chargeur de boot (grub) amorce bien la première phase de démarrage
(amorce sur HD4,0).
La détection des périphérique se passe et lors de la seconde, montage
du FS, le noyau ne trouve pas le périphérique LD4 (manquant dans le
répertoire /dev).

Err : "swapctl: /dev/ld4b : No suxh file or directory"
" Can't stat /dev/ld4a (No such file or directory"
etc etc.

en mode mono utilisateur, le FS étant en lecture seul, et ne pouvant
taper dans un autre disque (et oui c'est presque un cas d'école^^)
je ne peux monter le device pour LD4.

Si ma déduction est bonne sans disque disponible, (/dev n'ayant pas
les devices pour rld4x et plus) je ne peux tenter un :

mount -o rw /dev/ldXa

mon raisonnement part du principe qu'il faut monter le kernel avec les
périphériques LD4 et +.

Si j'ai raison, deux soluces :

intervertir les partitions, il va de soi que je veux installer sur le
cinquieme disque : LD4

Demander de l'aide ^^

Auriez vous des suggestions ?

Mon raisonnement est-il correct ?

Cdlt,

Olivier.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Manuel Bouyer
Le #6885531
wrote:
bonsoir,

[...]

Err : "swapctl: /dev/ld4b : No suxh file or directory"
" Can't stat /dev/ld4a (No such file or directory"
etc etc....

en mode mono utilisateur, le FS étant en lecture seul, et ne pouvant
taper dans un autre disque (et oui c'est presque un cas d'école^^)
je ne peux monter le device pour LD4.

Si ma déduction est bonne sans disque disponible, (/dev n'ayant pas
les devices pour rld4x et plus) je ne peux tenter un :

mount -o rw /dev/ldXa


exact


mon raisonnement part du principe qu'il faut monter le kernel avec les
périphériques LD4 et +.

Si j'ai raison, deux soluces :

intervertir les partitions, il va de soi que je veux installer sur le
cinquieme disque : LD4

Demander de l'aide ^^

Auriez vous des suggestions ?


redemarer avec la disquette d'install
sortir de sysinst
cd /dev/ ; ./MAKEDEV ld4
mount /dev/ld4a /mnt
cd /mnt/dev
./MAKEDEV ld4
cd /
reboot

et la il devrait pouvoir booter sur disque sans problemes,
maintenant qu'on a cree /dev/ld4*

--
Manuel Bouyer NetBSD: 26 ans d'experience feront toujours la difference
--

olivier.burelli
Le #6892191
(...)
redemarer avec la disquette d'install
sortir de sysinst
cd /dev/ ; ./MAKEDEV ld4
mount /dev/ld4a /mnt
cd /mnt/dev
./MAKEDEV ld4
cd /
reboot

et la il devrait pouvoir booter sur disque sans problemes,
maintenant qu'on a cree /dev/ld4*

--
Manuel Bouyer NetBSD: 26 ans d'experience feront toujours la difference
--


Effectivement cela coulait de source... :) (j'étais quand meme parti
sur une union, sans le disque monté... ou la poule ki...)

bon du coup g crée les autres device (4 -> 7)

NetBSD et FreeBSD cohabitent avec mon chti bubulle l'épineux....


Merci bcp pour votre aide.

Cdlt,

Olivier.

Publicité
Poster une réponse
Anonyme