NIS entre server Linux et client NetBSD

Le
JKB
Bonjour à tous,

Petit problème du matin. J'ai un serveur Linux sur lequel tourne un
NIS qui fonctionne parfaitement (une palanquée et demi de client se
connecte dessus sans problème). J'ai au l'idée de monter un NetBSD
sur ce NIS et j'ai l'impression d'avoir raté un truc :

Mon /etc/passwd se termine par quelque chose du genre "+::::::".
Idem pour le /etc/group. J'ai des deux côté un chiffrement md5.

Le /etc/nsswitch est :

group: compat
group_compat: nis
hosts: files dns
netgroup: files [notfound=return] nis
networks: files
passwd: compat
passwd_compat: nis
shells: files

Et lorsque j'essaye de me connecter en ssh, j'obtiens un superbe :

Feb 12 11:07:46 riemann sshd[814]: Invalid user bertrand from
192.168.0.83
Feb 12 11:07:46 riemann sshd[814]: Failed none for invalid user bertrand
from 192.168.0.83 port 52214 ssh2
Feb 12 11:07:48 riemann sshd[814]: error: PAM: unknown user for illegal
user bertrand from fermat.systella.fr
Feb 12 11:07:49 riemann sshd[814]: Failed keyboard-interactive/pam for
invalid user bertrand from 192.168.0.83 port 52214 ssh2

Les deux premières lignes sont logguées _avant_ la demande du mot de
passe. Un ypcat renvoie bien les bonnes informations. Je n'arrive
pas non plus à me connecter sur la console

Une idée ? Le problème doit être très bête, mais je sèche
lamentablement

Cordialement,

JKB

--
Le cerveau, c'est un véritable scandale écologique. Il représente 2% de notre
masse corporelle, mais disperse à lui seul 25% de l'énergie que nous
consommons tous les jours.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Manuel Bouyer
Le #908871
JKB
Bonjour à tous,

Petit problème du matin. J'ai un serveur Linux sur lequel tourne un
NIS qui fonctionne parfaitement (une palanquée et demi de client se
connecte dessus sans problème). J'ai au l'idée de monter un NetBSD
sur ce NIS et j'ai l'impression d'avoir raté un truc :

Mon /etc/passwd se termine par quelque chose du genre "+::::::".
Idem pour le /etc/group. J'ai des deux côté un chiffrement md5.
[...]

Et lorsque j'essaye de me connecter en ssh, j'obtiens un superbe :

Feb 12 11:07:46 riemann sshd[814]: Invalid user bertrand from
192.168.0.83
Feb 12 11:07:46 riemann sshd[814]: Failed none for invalid user bertrand
from 192.168.0.83 port 52214 ssh2
Feb 12 11:07:48 riemann sshd[814]: error: PAM: unknown user for illegal
user bertrand from fermat.systella.fr
Feb 12 11:07:49 riemann sshd[814]: Failed keyboard-interactive/pam for
invalid user bertrand from 192.168.0.83 port 52214 ssh2

Les deux premières lignes sont logguées _avant_ la demande du mot de
passe. Un ypcat renvoie bien les bonnes informations. Je n'arrive
pas non plus à me connecter sur la console...

Une idée ? Le problème doit être très bête, mais je sèche
lamentablement...


Ca ressemble a un shell qui n'existe pas. Verifie que le shell indique
dans les NIS est bien present sur le NetBSD, et au bon endroit.

--
Manuel Bouyer NetBSD: 26 ans d'experience feront toujours la difference
--

JKB
Le #908869
Le 12-02-2008, à propos de
Re: NIS entre server Linux et client NetBSD,
Manuel Bouyer écrivait dans fr.comp.os.bsd :
JKB
Bonjour à tous,

Petit problème du matin. J'ai un serveur Linux sur lequel tourne un
NIS qui fonctionne parfaitement (une palanquée et demi de client se
connecte dessus sans problème). J'ai au l'idée de monter un NetBSD
sur ce NIS et j'ai l'impression d'avoir raté un truc :

Mon /etc/passwd se termine par quelque chose du genre "+::::::".
Idem pour le /etc/group. J'ai des deux côté un chiffrement md5.
[...]

Et lorsque j'essaye de me connecter en ssh, j'obtiens un superbe :

Feb 12 11:07:46 riemann sshd[814]: Invalid user bertrand from
192.168.0.83
Feb 12 11:07:46 riemann sshd[814]: Failed none for invalid user bertrand
from 192.168.0.83 port 52214 ssh2
Feb 12 11:07:48 riemann sshd[814]: error: PAM: unknown user for illegal
user bertrand from fermat.systella.fr
Feb 12 11:07:49 riemann sshd[814]: Failed keyboard-interactive/pam for
invalid user bertrand from 192.168.0.83 port 52214 ssh2

Les deux premières lignes sont logguées _avant_ la demande du mot de
passe. Un ypcat renvoie bien les bonnes informations. Je n'arrive
pas non plus à me connecter sur la console...

Une idée ? Le problème doit être très bête, mais je sèche
lamentablement...


Ca ressemble a un shell qui n'existe pas. Verifie que le shell indique
dans les NIS est bien present sur le NetBSD, et au bon endroit.


Le shell est un bash. Sur le NetBSD en question, c'est un lien vers
sh. J'ai plutôt l'impression que le problème se situe autour du NIS.
Quoi qu'il en soit, tant que le bestiau n'est pas stable sur
HyperSPARC (et je pense que ce n'est pas demain la veille), on va
laisser la bête éteinte...

Cordialement,

JKB

--
Le cerveau, c'est un véritable scandale écologique. Il représente 2% de notre
masse corporelle, mais disperse à lui seul 25% de l'énergie que nous
consommons tous les jours.


Manuel Bouyer
Le #908867
JKB
Le 12-02-2008, à propos de
Re: NIS entre server Linux et client NetBSD,
Manuel Bouyer écrivait dans fr.comp.os.bsd :
JKB
Bonjour à tous,

Petit problème du matin. J'ai un serveur Linux sur lequel tourne un
NIS qui fonctionne parfaitement (une palanquée et demi de client se
connecte dessus sans problème). J'ai au l'idée de monter un NetBSD
sur ce NIS et j'ai l'impression d'avoir raté un truc :

Mon /etc/passwd se termine par quelque chose du genre "+::::::".
Idem pour le /etc/group. J'ai des deux côté un chiffrement md5.
[...]

Et lorsque j'essaye de me connecter en ssh, j'obtiens un superbe :

Feb 12 11:07:46 riemann sshd[814]: Invalid user bertrand from
192.168.0.83
Feb 12 11:07:46 riemann sshd[814]: Failed none for invalid user bertrand
from 192.168.0.83 port 52214 ssh2
Feb 12 11:07:48 riemann sshd[814]: error: PAM: unknown user for illegal
user bertrand from fermat.systella.fr
Feb 12 11:07:49 riemann sshd[814]: Failed keyboard-interactive/pam for
invalid user bertrand from 192.168.0.83 port 52214 ssh2

Les deux premières lignes sont logguées _avant_ la demande du mot de
passe. Un ypcat renvoie bien les bonnes informations. Je n'arrive
pas non plus à me connecter sur la console...

Une idée ? Le problème doit être très bête, mais je sèche
lamentablement...


Ca ressemble a un shell qui n'existe pas. Verifie que le shell indique
dans les NIS est bien present sur le NetBSD, et au bon endroit.


Le shell est un bash. Sur le NetBSD en question, c'est un lien vers
sh. J'ai plutôt l'impression que le problème se situe autour du NIS.


Dans ce cas je pense que sshd doit mettre plus de details sur ce qui ne
lui plait pas dans /var/log/authlog

--
Manuel Bouyer NetBSD: 26 ans d'experience feront toujours la difference
--



JKB
Le #908866
Le 13-02-2008, à propos de
Re: NIS entre server Linux et client NetBSD,
Manuel Bouyer écrivait dans fr.comp.os.bsd :
JKB
Le 12-02-2008, à propos de
Re: NIS entre server Linux et client NetBSD,
Manuel Bouyer écrivait dans fr.comp.os.bsd :
JKB
Bonjour à tous,

Petit problème du matin. J'ai un serveur Linux sur lequel tourne un
NIS qui fonctionne parfaitement (une palanquée et demi de client se
connecte dessus sans problème). J'ai au l'idée de monter un NetBSD
sur ce NIS et j'ai l'impression d'avoir raté un truc :

Mon /etc/passwd se termine par quelque chose du genre "+::::::".
Idem pour le /etc/group. J'ai des deux côté un chiffrement md5.
[...]

Et lorsque j'essaye de me connecter en ssh, j'obtiens un superbe :

Feb 12 11:07:46 riemann sshd[814]: Invalid user bertrand from
192.168.0.83
Feb 12 11:07:46 riemann sshd[814]: Failed none for invalid user bertrand
from 192.168.0.83 port 52214 ssh2
Feb 12 11:07:48 riemann sshd[814]: error: PAM: unknown user for illegal
user bertrand from fermat.systella.fr
Feb 12 11:07:49 riemann sshd[814]: Failed keyboard-interactive/pam for
invalid user bertrand from 192.168.0.83 port 52214 ssh2

Les deux premières lignes sont logguées _avant_ la demande du mot de
passe. Un ypcat renvoie bien les bonnes informations. Je n'arrive
pas non plus à me connecter sur la console...

Une idée ? Le problème doit être très bête, mais je sèche
lamentablement...


Ca ressemble a un shell qui n'existe pas. Verifie que le shell indique
dans les NIS est bien present sur le NetBSD, et au bon endroit.


Le shell est un bash. Sur le NetBSD en question, c'est un lien vers
sh. J'ai plutôt l'impression que le problème se situe autour du NIS.


Dans ce cas je pense que sshd doit mettre plus de details sur ce qui ne
lui plait pas dans /var/log/authlog


Il faudrait que je regarde ça. Mais comme dit, comme le truc n'est
pas stable sur HyperSPARC/SMP, je ne suis vraiment pas pressé pour
trouver la solution (ou alors, faudrait que je mette ça en dual
SM-71...).

Cordialement,

JKB

--
Le cerveau, c'est un véritable scandale écologique. Il représente 2% de notre
masse corporelle, mais disperse à lui seul 25% de l'énergie que nous
consommons tous les jours.




Publicité
Poster une réponse
Anonyme